PDA

View Full Version : Issue with thrustmaster tx 458



Mon Pavion
10-02-2018, 18:32
So each race starts out with good force feedback but after about 10mins of driving the feedback becomes very weak. It doesnt go away entirely just weakens significantly.

Anyone have a fix for this?

Bealdor
10-02-2018, 18:53
Does the FFB graph show weaker FFB too?
My G27 does a similar thing but the widget is still showing the occasional clipping for me.
Overheating FFB motors maybe?

Mon Pavion
10-02-2018, 19:11
Does the FFB graph show weaker FFB too?
My G27 does a similar thing but the widget is still showing the occasional clipping for me.
Overheating FFB motors maybe?

Yes it does. The bars barely move.

My first thought was overheating as well.

Bealdor
10-02-2018, 19:14
Does it come suddenly or does the FFB decrease steadily?
Are your tires overheating?

Mon Pavion
10-02-2018, 22:25
Does it come suddenly or does the FFB decrease steadily?
Are your tires overheating?

It comes sorta gradually. Maybe over the course of a min or two.

Tires are always within optimal range.

Shoemaker
10-02-2018, 22:46
Your wheel is overheating. It will dial down the ffb to prevent damage.Its designed to do this so don’t worry. You need to install the latest wheel firmware to the wheel with ‘forced cooling’ mode enabled. This will leave the wheel fans on permanently and you will be able race with no fading. Hook up your wheel to a pc and download the firmware from thrustmaster.

Mon Pavion
11-02-2018, 04:36
Your wheel is overheating. It will dial down the ffb to prevent damage.Its designed to do this so don’t worry. You need to install the latest wheel firmware to the wheel with ‘forced cooling’ mode enabled. This will leave the wheel fans on permanently and you will be able race with no fading. Hook up your wheel to a pc and download the firmware from thrustmaster.

I will give that a try.

Mon Pavion
11-02-2018, 05:46
So i tried to update the firmware but got an entry point not found error when trying to run the updater.
My pc is ancient.

Firmware is old. Its version 50. Shoulf be 51

Shoemaker
11-02-2018, 07:37
So i tried to update the firmware but got an entry point not found error when trying to run the updater.
My pc is ancient.

Firmware is old. Its version 50. Shoulf be 51
The updater never worked for me either, I downloaded and installed it manually.

RoccoTTS
11-02-2018, 07:43
So i tried to update the firmware but got an entry point not found error when trying to run the updater.
My pc is ancient.

Firmware is old. Its version 50. Shoulf be 51

First you have to update/download the correct drivers, you find them on the official TM forum (Package 2017_TTRS_7). After doing this you can update the correct firmware.

Mon Pavion
11-02-2018, 20:37
First you have to update/download the correct drivers, you find them on the official TM forum (Package 2017_TTRS_7). After doing this you can update the correct firmware.

I did do this. Still no dice

Mon Pavion
11-02-2018, 20:41
Exact error:

The procedure entry point K32GetModuleFileNameExW could not be located in the dynamic link library KERNEL32.dll.

Mon Pavion
11-02-2018, 20:54
I have contacted thrustmaster tech support to hopefully get a resolution here

RoccoTTS
12-02-2018, 07:08
Exact error:

The procedure entry point K32GetModuleFileNameExW could not be located in the dynamic link library KERNEL32.dll.

If you get an error of any kind, the first thing you have to do is copy/paste the error into google search and see if someone else has the same error.
So after doing this, i find a lot of people getting this error with any kind of software. In most cases the conclusion was the they were trying to install their software to an unsupported Windows platform.

Are you still on windows xp or vista ? Is your OS up to date ? Probably means your OS is too old and not up to date, this thrustmaster software probably does not support your system anymore.

Mon Pavion
12-02-2018, 13:03
If you get an error of any kind, the first thing you have to do is copy/paste the error into google search and see if someone else has the same error.
So after doing this, i find a lot of people getting this error with any kind of software. In most cases the conclusion was the they were trying to install their software to an unsupported Windows platform.

Are you still on windows xp or vista ? Is your OS up to date ? Probably means your OS is too old and not up to date, this thrustmaster software probably does not support your system anymore.

Windows vista yes.

Its embarrassing to admit. My pc at home is o er a decade old. Never had a reason to upgrade it really.

Bealdor
12-02-2018, 13:14
Windows vista yes.

Its embarrassing to admit. My pc at home is o er a decade old. Never had a reason to upgrade it really.

From the driver info file: System Requirement: Windows® 10/ 8.1/ 8 / 7(32-bit / 64-bit)

Do you have a friend who has a newer PC where you could update your drivers?

Mon Pavion
12-02-2018, 16:15
From the driver info file: System Requirement: Windows® 10/ 8.1/ 8 / 7(32-bit / 64-bit)

Do you have a friend who has a newer PC where you could update your drivers?

Yeah I kinda came to the conclusion I will have to do that. I can bring the base into work and use my office PC

Mon Pavion
12-02-2018, 16:47
This could just be a sign to finally pull the trigger and get a new PC

RoccoTTS
12-02-2018, 17:16
This could just be a sign to finally pull the trigger and get a new PC

Yes, i think it's a sign ;)

Bealdor
12-02-2018, 17:19
Yeah I kinda came to the conclusion I will have to do that. I can bring the base into work and use my office PC

"Yo boss, don't worry. I just brought my wheel to tidy up that Excel file I've been working on!"

Schnizz58
12-02-2018, 17:33
"Yo boss, don't worry. I just brought my wheel to tidy up that Excel file I've been working on!"

I'm lucky. My boss has his racing wheel at work already.

Mon Pavion
12-02-2018, 18:53
"Yo boss, don't worry. I just brought my wheel to tidy up that Excel file I've been working on!"

My boss is the kind of boss that likes to spend the long Chicago winters out in Palm Springs while the rest of us toil away under 22 inches of snow. So I am flying free until the spring :D

Mon Pavion
16-02-2018, 13:51
From the driver info file: System Requirement: Windows® 10/ 8.1/ 8 / 7(32-bit / 64-bit)

Do you have a friend who has a newer PC where you could update your drivers?

So just a quick update on this. You were absolutely right. I did the update procedure on a computer with Windows 10 and it worked without a hitch.

Also, the FFB now feels a million times better. I didn't have a chance yet to test if the original overheating issue I had that was causing a gradual loss of FFB was fixed or not (I've been really busy the last few days) but I did have a quick test session last night and the wheel felt SOOOO much better.

Thanks fellas!

Shoemaker
16-02-2018, 14:46
So just a quick update on this. You were absolutely right. I did the update procedure on a computer with Windows 10 and it worked without a hitch.

Also, the FFB now feels a million times better. I didn't have a chance yet to test if the original overheating issue I had that was causing a gradual loss of FFB was fixed or not (I've been really busy the last few days) but I did have a quick test session last night and the wheel felt SOOOO much better.

Thanks fellas!

The newer firmware is set to auto cooling, the fan kicks in at a certain temperature, V50 or above gives you the option for forced cooling but you do have to enable it by Simultaneously pressing the “MENU and “MODE” buttons
= The “Forced” mode becomes active (the LED flashes twice). This will save to the wheels memory. To revert back Simultaneously press the “MENU*” and “MODE” buttons
= The “Automatic” mode becomes active (the LED flashes once). I always have forced cooling and never have any ffb fading.

Mon Pavion
16-02-2018, 14:50
The newer firmware is set to auto cooling, the fan kicks in at a certain temperature, V50 or above gives you the option for forced cooling but you do have to enable it by Simultaneously pressing the “MENU and “MODE” buttons
= The “Forced” mode becomes active (the LED flashes twice). This will save to the wheels memory. To revert back Simultaneously press the “MENU*” and “MODE” buttons
= The “Automatic” mode becomes active (the LED flashes once). I always have forced cooling and never have any ffb fading.

I was just about to google how to enable forced cooling. Thanks Shoemaker!

Mon Pavion
20-02-2018, 14:00
So wheel works fine now. Fans stay on and i do not lose ffb at all.

Was definitely a overheating issue

RoccoTTS
20-02-2018, 14:03
Nice to hear your problem is solved.