PDA

View Full Version : Project Cars not launching in VR mode on Vive pro



grimhammer
13-12-2018, 13:09
Hi.

I have googled, I have read forums, reddit, articles, I have tried god damn everything and can't get Project Cars to start in VR mode.

Let's go thru the list.
I have tried starting Steam VR first, waiting for it to fully load and then starting PC from SteamVR Home
I have tried starting it from the steam client by rightclicking and selecting launch in vr with vive
I have tried starting it from the Viveport app.
I have tried creating a shortcut and appending /vr to the steam link (steam://) with SteamVR started

In all these situations the game launches on my monitor while in the headset it's just the loading title card (the project cars big picture mode banner with the three bars below)
I know it's supposed to show up in the headset in 2d and be 3d while driving but it just shows it loading with sound coming from the vive pro headphones.

I have also tried launching it with steamvr turned off, selecting vr mode with vive in the launch options dialog, this starts the game but steamVR doesn't start and headset remains dark.
Also tried starting it from a created desktop icon with steamvr turned off and /vr appended to the steam link in the shortcut and the result is the same. It starts the game, I can see it on my monitor but headset is dark cause steamVR doesn't start.

I have tried removing the settings files under documents\project cars
There was no settings files for vive of any kind, there was graphics settings and oculus settings but I cleared them out and tried again.
I have done a fresh install of project cars.
I have tried full-screen and windowed and windowed borderless. I have tried binding a key to reset the HMD position and hitting it without result.

In every single situation described above the game starts on my monitor but not in the HMD and while in-game under options there is NO virtual reality menu. It's not greyed out, it just doesn't exist. There is no -novr added to any of the launch variants described above.

I am running a gaming laptop MSI GE72MVR 7RG Apache Pro with a GTX 1070, 16 GB DDR4, Win 10 with latest updates, latest nvidia drivers. CPU is i7-7700HQ. Other pure VR titles work, as does subnautica and Elite:Dangerous for titles with added VR support.

Let me know if I need to upload any logs and if so where to find them.

/Erik Grimms

grimhammer
14-12-2018, 09:25
Hi.

I have googled, I have read forums, reddit, articles, I have tried god damn everything and can't get Project Cars to start in VR mode.

Let's go thru the list.
I have tried starting Steam VR first, waiting for it to fully load and then starting PC from SteamVR Home
I have tried starting it from the steam client by rightclicking and selecting launch in vr with vive
I have tried starting it from the Viveport app.
I have tried creating a shortcut and appending /vr to the steam link (steam://) with SteamVR started

In all these situations the game launches on my monitor while in the headset it's just the loading title card (the project cars big picture mode banner with the three bars below)
I know it's supposed to show up in the headset in 2d and be 3d while driving but it just shows it loading with sound coming from the vive pro headphones.

I have also tried launching it with steamvr turned off, selecting vr mode with vive in the launch options dialog, this starts the game but steamVR doesn't start and headset remains dark.
Also tried starting it from a created desktop icon with steamvr turned off and /vr appended to the steam link in the shortcut and the result is the same. It starts the game, I can see it on my monitor but headset is dark cause steamVR doesn't start.

I have tried removing the settings files under documents\project cars
There was no settings files for vive of any kind, there was graphics settings and oculus settings but I cleared them out and tried again.
I have done a fresh install of project cars.
I have tried full-screen and windowed and windowed borderless. I have tried binding a key to reset the HMD position and hitting it without result.

In every single situation described above the game starts on my monitor but not in the HMD and while in-game under options there is NO virtual reality menu. It's not greyed out, it just doesn't exist. There is no -novr added to any of the launch variants described above.

I am running a gaming laptop MSI GE72MVR 7RG Apache Pro with a GTX 1070, 16 GB DDR4, Win 10 with latest updates, latest nvidia drivers. CPU is i7-7700HQ. Other pure VR titles work, as does subnautica and Elite:Dangerous for titles with added VR support.

Let me know if I need to upload any logs and if so where to find them.

/Erik Grimms

This thread can be moved (or copied) to the PC2 vr support forum because I have today tried to get the demo on steam for project cars 2 and it behaves exactly the same way

cluck
14-12-2018, 09:29
The only thing that immediately springs to my mind is whether the game is launching on the Intel GPU on your laptop, rather than the dedicated nVidia one. If it's possible to do so, it might be worth trying to completely disable the Intel GPU. Other than that, I don't know what to suggest myself, you seem to have already tried all the obvious things.

grimhammer
14-12-2018, 10:19
The only thing that immediately springs to my mind is whether the game is launching on the Intel GPU on your laptop, rather than the dedicated nVidia one. If it's possible to do so, it might be worth trying to completely disable the Intel GPU. Other than that, I don't know what to suggest myself, you seem to have already tried all the obvious things.

Will try, don't know if I can fully disable it. It launches the process on the nvidia cuz if it was on the intel it would be very noticable but perhaps the VR server is trying to send the 3d visuals via the intel.

Mad Al
14-12-2018, 10:44
I assume you haven't got any launch options set in Steam for the game launch... you wouldn't be the first person on the planet to have previously put -novr in the launch options and forgotten about it....

grimhammer
14-12-2018, 11:43
I assume you haven't got any launch options set in Steam for the game launch... you wouldn't be the first person on the planet to have previously put -novr in the launch options and forgotten about it....

It's stated in the original post that there is no -novr appended anywhere. Found a reddit thread by someone who had the exact same experience as me and it turned out he had -novr in launch options but alas, no such luck.

Unable to completely disable the integrated GPU but in nvidia settings I have put the nvidia gpu as global default for all applications.