Page 52 of 52 FirstFirst ... 242505152
Results 511 to 514 of 514

Thread: Dedicated Server HowTo (Work in Progress)

  1. #511
    GT4 Pilot F1_Racer68's Avatar
    Join Date
    Aug 2012
    Location
    Canadian Tire Motorsports Park (Mosport)
    Posts
    2,350
    Platform
    PC
    Has anyone ever gotten the FORCE_MANUAL_PITSTOPS option to work when the server controls the game setup? I have tried using both "ManualPitStops" and "PitControl" in the config options, and have tried both 0 and 1 as settings, but nothing causes the server setting to override the player's setting. If the player is set for Manual Pit Stops NO in their game profile, then they get automated pit stops regardless of what the server is set for.

    If I set the server so that I can use the -selectds argument and build the online session manually, then the Force Manual PitStops works as expected.

    It's only an issue when the server is controlling the session. Pretty sure this is a known issue, as it's been this way for a long time. I was hoping it would have been fixed by now.

    The funny thing is, if I set the cfg file with "ManualPitStops" : 1, then the API web page shows FOrce Manual Stop YES, but in game it still shows NO, and it does not override the player's setting.
    CanAm Virtual Racing League - League President Twitter: @canamvrl @F1_Racer68
    System Specs
    CPU - AMD FX-8370 w/Wraith Cooler MoBo - GB-78LMT-USB3 (Rev 6.0) RAM - 24GB 1600 DDR3, Video - Zotac GTX1060 AMP! 6GB DDR5, OS - Win10 Pro 64bit, SSD - Corsair 240GB Force LE, Controller - Fanatec CSW v2.5, CSL Elite LC Pedals, DIY Button Box, G27 Shifter (USB) Monitor - Samsung UN28H4000AF 28" LED x3

  2. #512
    Kart Driver
    Join Date
    May 2015
    Posts
    71
    Platform
    PC
    Hello,
    At home, it works like this:

    sms_rotate_config.json:

    "ManualPitStops": 1,

    server.cfg:

    "PitControl": 1,

    You can test on my server:

    LES_CASSE_COU_hotlaps / OPEN

    excuse me for my bad English, I'm using a translator

  3. #513
    WMD Member Asturbo's Avatar
    Join Date
    Jun 2012
    Location
    Asturias / Spain
    Posts
    783
    Platform
    PC
    PitControl in the documentation says that will subtitute ManualPitStops parameter, but it is in "TO DO" status.

    In the docs or in the DS API, possible values for "ManualPitStop" are 0 and 1, but it you set to 2, works perfect for me.
    CPU: Intel i7-8700K | GPU: nVidia GTX 1080 | RAM: Gskill 2x8GB DDR4 3200 | MB: Asus ROG Strix Z370 | SSD: Samsung 951 PCI 250GB | Monitor: Asus VG248 144Hz | Wheel: Fanatec CSL | SO: Windows 10 Pro 64bits
    WMD1 & WMD2 Gold Member /// Steam Profile /// Unofficial Issue List /// Button Box Label Template /// DS Flags Calculator/// Open Weather App
    The following user likes this Post: F1_Racer68


  4. #514
    GT4 Pilot F1_Racer68's Avatar
    Join Date
    Aug 2012
    Location
    Canadian Tire Motorsports Park (Mosport)
    Posts
    2,350
    Platform
    PC
    Quote Originally Posted by Asturbo View Post
    PitControl in the documentation says that will subtitute ManualPitStops parameter, but it is in "TO DO" status.

    In the docs or in the DS API, possible values for "ManualPitStop" are 0 and 1, but it you set to 2, works perfect for me.
    This solution solved the problem for me.

    Thanks!
    CanAm Virtual Racing League - League President Twitter: @canamvrl @F1_Racer68
    System Specs
    CPU - AMD FX-8370 w/Wraith Cooler MoBo - GB-78LMT-USB3 (Rev 6.0) RAM - 24GB 1600 DDR3, Video - Zotac GTX1060 AMP! 6GB DDR5, OS - Win10 Pro 64bit, SSD - Corsair 240GB Force LE, Controller - Fanatec CSW v2.5, CSL Elite LC Pedals, DIY Button Box, G27 Shifter (USB) Monitor - Samsung UN28H4000AF 28" LED x3

Similar Threads

  1. [ANSWERED] Handbrake doesn't seem to work?
    By DigitalX90 in forum General Discussion
    Replies: 13
    Last Post: 02-10-2017, 20:16
  2. Dedicated Server
    By OzDeaDMeaT in forum Multiplayer
    Replies: 9
    Last Post: 14-09-2015, 14:02
  3. Created a dedicated Server Linux of Windows CFG
    By gwadagamer in forum Multiplayer
    Replies: 7
    Last Post: 08-05-2015, 16:04
  4. Dedicated Server - HTTP API Request
    By Ph0eNiX in forum PC - Technical Help & Support
    Replies: 3
    Last Post: 08-05-2015, 11:18
  5. Setting Manual transmission on PS4 game pad does not work
    By Iwanchek in forum PS4 - Technical Help & Support
    Replies: 3
    Last Post: 08-05-2015, 05:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •