Results 1 to 7 of 7

Thread: PS4 Thrustmaster T300RS trouble

  1. #1
    Rookie
    Join Date
    May 2015
    Location
    Modena
    Posts
    3
    Platform
    PS4

    PS4 Thrustmaster T300RS trouble

    Help me please.
    I play Project Cars on my Playstation 4 with a Thrustmaster T300RS, but when I start a race, the machine 9 times out of 10 do not start, I press the accelerator, shift gears, but the car remains stationary on the starting line.
    The same behavior happen also if I'm going to crash and stop against a wall, the car stay stuck, I put into reverse and press the accelerator, but I do not move.
    When I can go and do the race is changing the accelerator and the shift work perfectly.
    Anyone using the T300RS con help me on this problem?

  2. #2
    Kart Driver
    Join Date
    May 2015
    Location
    Copenhagen
    Posts
    14
    Platform
    PS4
    try turning on automatic engine ignition in the options menu. Also tjek your button mapping. Maybe you need to sign a button for engine start ie. R3. Then hold down the clutch and press the speeder hvile pushing R3 then the engine starts. Note it is possible to stall the engine as in real life.

  3. #3
    Rookie
    Join Date
    May 2015
    Location
    Modena
    Posts
    3
    Platform
    PS4
    Quote Originally Posted by TWIsM View Post
    try turning on automatic engine ignition in the options menu. Also tjek your button mapping. Maybe you need to sign a button for engine start ie. R3. Then hold down the clutch and press the speeder hvile pushing R3 then the engine starts. Note it is possible to stall the engine as in real life.
    The machine start and the engine is working right.
    I hear the noise of the motore and see on the screen the graphic that show the throttle go up.
    I think is not this the problem.

    I've joust update the wheel firmware to the new 24 version, hope this resolve some problem....

  4. #4
    Moderator+WMD 1/2 Member Siberian Tiger's Avatar
    Join Date
    Mar 2012
    Location
    Rafz, Switzerland
    Posts
    2,028
    Platform
    PC
    Have you downloaded the latest Patch? (Day1Patch)
    Just to be sure you are running the latest available..
    Member Status: WMD 1 Senior x3 / WMD2 Gold
    Portable System: Dell XPS 17 Notebook CPU: Intel Core i7-2670QM @2.2 GHZ , RAM: 8GB, GPU: NVIDIA GForce GT555M, HDD: WD 2.5" Notebook 500GB, OS: Windows 7 64-bit,Wheel: Logitech G25, Sound: NVidia Onboard Soundcard
    Gaming System AsRock Z77 Extreme 4 / i7 7700K with Antec H2o 920 Liquid Cooling System / PSU: Be Quiet! Straight Power E9 680W / GPU: MSI Gaming GTX1070 (OC) / RAM: 16GB (4x4GB) Corsair Vengeance / SSD: 250GB Samsung Basic 840 / HDD: 1TB WD Caviar Black / OS: Windows 7 64-Bit / Wheel: Thrustmaster T500RS - Standart GT Rim / Monitor: Epson EH-TW3200 Homecinema 16:9 Full HD Beamer / RacingSeat: Playseat with some Modifications...

  5. #5
    Kart Driver ivan-hoe78's Avatar
    Join Date
    May 2015
    Location
    Barcelona
    Posts
    53
    Platform
    PS4
    Quote Originally Posted by Stevedue View Post
    Help me please.
    I play Project Cars on my Playstation 4 with a Thrustmaster T300RS, but when I start a race, the machine 9 times out of 10 do not start, I press the accelerator, shift gears, but the car remains stationary on the starting line.
    The same behavior happen also if I'm going to crash and stop against a wall, the car stay stuck, I put into reverse and press the accelerator, but I do not move.
    When I can go and do the race is changing the accelerator and the shift work perfectly.
    Anyone using the T300RS con help me on this problem?
    With the manual clutch, like I have, at the start of a race you need to push and maintain it, then shift first gear and when the lights turn green leave the clutch and push the throttle. If you loose the car or crash with walls, you need to push the clutch (and maintain it pushed) before the engine turns off. If you put the shifter in neutral you can leave the clutch. If the engine turns off, you need to ignite it again (mapping a button for ignition needed). Like in real life. The point about this, for me is difficult to run again when the car is stopped, the clutch is very sensitive and the engine turns off a lot of times I'm proving it. I need to push throttle a lot for high revolutions and then slowly and carefully I can run again.

    Hope it helps. Regards.


    PS4 - T300 GTE wheel + T3PA pedals + TH8A shifter H mode + TH8A shifter sequential mode - 55" TV SAMSUNG UE55ES8000 - YAMAHA RXV863 7.1 Surround Sound
    The following user likes this Post: JohnSchoonsBeard


  6. #6
    Rookie
    Join Date
    May 2015
    Location
    Modena
    Posts
    3
    Platform
    PS4
    Quote Originally Posted by ivan-hoe78 View Post
    With the manual clutch, like I have, at the start of a race you need to push and maintain it, then shift first gear and when the lights turn green leave the clutch and push the throttle. If you loose the car or crash with walls, you need to push the clutch (and maintain it pushed) before the engine turns off. If you put the shifter in neutral you can leave the clutch. If the engine turns off, you need to ignite it again (mapping a button for ignition needed). Like in real life. The point about this, for me is difficult to run again when the car is stopped, the clutch is very sensitive and the engine turns off a lot of times I'm proving it. I need to push throttle a lot for high revolutions and then slowly and carefully I can run again.

    Hope it helps. Regards.
    Thanks for the reply, but I've the standard T300 pedals, without the clutch.

    But luckily I've resolved all my T300RS problems doing a firmware upgrade.
    I've the old firmware version 23. Upgrade to the new 24 version, and now the wheel works perfectly

    Hope this help other people
    The following 2 users likes this Post: ivan-hoe78, JohnSchoonsBeard


  7. #7
    Rookie
    Join Date
    May 2015
    Posts
    4
    Platform
    PS4
    Hi my wheel was working perfectly up until last nite and then it just stop calibrating when I turned on my ps4, I only have it a week and it's doing this, was it hard to update the firmware?

Similar Threads

  1. Settings - Thrustmaster T300RS for PS4
    By dblui89 in forum PC - Technical Help & Support
    Replies: 2
    Last Post: 01-11-2015, 21:55
  2. Thrustmaster t300rs
    By bcfcgaz in forum PS4 - Technical Help & Support
    Replies: 28
    Last Post: 15-06-2015, 19:43
  3. t300rs settings
    By evolaco in forum PC - Technical Help & Support
    Replies: 2
    Last Post: 16-05-2015, 13:23
  4. Thrustmaster T300RS PS4
    By Danno in forum PS4 - Technical Help & Support
    Replies: 33
    Last Post: 15-05-2015, 22:46
  5. Thrustmaster tx
    By Dazza in forum XB1 - Technical Help & Support
    Replies: 10
    Last Post: 13-05-2015, 01:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •