Results 1 to 7 of 7

Thread: All input ignored in an online event

  1. #1
    WMD Member
    Join Date
    Dec 2011
    Location
    Budapest
    Posts
    314
    Platform
    PC

    All input ignored in an online event

    Today was my first foray into the online scene and managed to run into a quite serious issue right off the bat. I joined a GT3 event at Bathurst with a 15 min qualifying and 7 lap race session. The problem was that in quali when the AI was driving me out of the pits and at the end gave me control over my car I had no steering. The sim didn't react to any button on my wheel either. I tried to retire from the session and join again, but my keyboard didn't work either, so I had to close pCARS from the task manager.

    When I restarted it I verified my control settings, but everything looked fine and the when I rejoined the online event an this time everything worked properly. Before the first try I did a quick solo Time Trial session and there I had no issues at all. I noticed in the known issues thread that Fanatec wheels tend to stop working sometimes, but I think my case was different, because I didn't have to recalibrate my wheel, its settings didn't change at all, and I also lost keyboard control.

  2. #2
    WMD Member
    Join Date
    Dec 2011
    Location
    Budapest
    Posts
    314
    Platform
    PC
    Forgot to add my config to my signature. Hopefully it will show up below this post.
    AMD Ryzen 1700 3.0ghz | Asus Prime B350-Plus | 16GB G.Skill F4-3200C16-8GTZB | Gigabyte GeForce GTX 1060 Windforce OC 6G | Corsair Neutron 120gb SSD | Windows 10 64bit

    Fanatec Porsche 911 Carrera wheel | Fanatec CSR Elite pedals | Driver version 115

    Resolution 1920x1080 | Windowed Mode NO | Texture Resolution HIGH | Texture Filtering 16x | V-Sync OFF (Adaptive from nV CP) | Anti-Aliasing MSAA MEDIUM | Reflections HIGH | Environment Map HIGH | Car Detail HIGH | Track Detail HIGH | Pit Crew Detail ALL | Shadow Detail HIGH | Enhanced Mirror YES | Motion Blur HIGH | Render Frames Ahead 4 | Detailed Grass HIGH | Particle Level HIGH | Particle Density HIGH

    All Visual FX options enabled

  3. #3
    WMD Member x107's Avatar
    Join Date
    Dec 2011
    Posts
    27
    Hey David, I also had this problem for quite a while too. What fixed it for me was not using the Steam overlay during any online session. Since doing this I haven't had the problem again. You could also disable the overlay, but then you can't see message/invite notifications while in game. To solve that problem I leave the overlay on so I can see notifications, but use the Steam app on a phone for all messages and alt tab out of the game to accept invites. By doing this I never have to use the overlay, which avoids the loss of input problem.

    May not be perfect, but it's a good solution for now. Hope this helps.
    PC Specs: CPU: AMD Phenom II X6 1075T 3.00 GHz, GPU: Gigabyte G1 Gaming GTX 970 4GB GDDR5, Memory: Corsair Vengeance 16GB DDR3, OS: Windows 7 64 bit

    Flickr Gallery

  4. #4
    WMD Member
    Join Date
    Dec 2011
    Location
    Budapest
    Posts
    314
    Platform
    PC
    Since I wrote my OP it didn't happen again, but if does I'll start doing online races without the overlay and see if the issue pops up again after that. Thanks for the tip!
    AMD Ryzen 1700 3.0ghz | Asus Prime B350-Plus | 16GB G.Skill F4-3200C16-8GTZB | Gigabyte GeForce GTX 1060 Windforce OC 6G | Corsair Neutron 120gb SSD | Windows 10 64bit

    Fanatec Porsche 911 Carrera wheel | Fanatec CSR Elite pedals | Driver version 115

    Resolution 1920x1080 | Windowed Mode NO | Texture Resolution HIGH | Texture Filtering 16x | V-Sync OFF (Adaptive from nV CP) | Anti-Aliasing MSAA MEDIUM | Reflections HIGH | Environment Map HIGH | Car Detail HIGH | Track Detail HIGH | Pit Crew Detail ALL | Shadow Detail HIGH | Enhanced Mirror YES | Motion Blur HIGH | Render Frames Ahead 4 | Detailed Grass HIGH | Particle Level HIGH | Particle Density HIGH

    All Visual FX options enabled

  5. #5
    Kart Driver doneta's Avatar
    Join Date
    May 2015
    Posts
    39
    Platform
    PC
    This has happened to me many times. It's very frustrating.

  6. #6
    Rookie AERODANCE's Avatar
    Join Date
    Jun 2015
    Posts
    3
    Platform
    PC
    This happening often with me when playing PCars.
    Seems it's game engine bug. When game is starting to load race session or loading back to menu after session end - you should never use steam overlay in this moments. Looks like game engine loosing focus when it loading anything, because steam overlay laying on top of it (i.e. overlay have more priority).

    And then game can't see your controller (G25 wheel in my situation).
    Only game restart helps, after that.

    This bug exists since PCars release.
    It's so cute when steam game is not compatible with steam.

    Hope this weird bug will be fixed sometime.

  7. #7
    WMD Member
    Join Date
    May 2015
    Posts
    54
    Platform
    PC
    This has happened loads of times for me too. Always from steam overlay. Still hapenning in 2.5
    Formula 1 is boring & corrupt. Turn it off and tune into something better like FIA WEC or Blancpain GT.

Similar Threads

  1. AI input
    By Tom vandamme in forum PS4 - Technical Help & Support
    Replies: 1
    Last Post: 06-06-2015, 12:49
  2. Help Regarding TX Wheel Steering Input
    By ARusling in forum Project CARS on Xbox One
    Replies: 7
    Last Post: 01-06-2015, 20:59
  3. [BUG] Controller and Keyboard input non responsive after joining online game
    By Narcarsiss in forum PC - Technical Help & Support
    Replies: 1
    Last Post: 27-05-2015, 12:40
  4. control input on dualshock 4???
    By hanteed24 in forum Project CARS on Playstation 4
    Replies: 1
    Last Post: 09-05-2015, 15:16
  5. Input Mode and other settings
    By bobblebob in forum XB1 - Technical Help & Support
    Replies: 2
    Last Post: 09-05-2015, 07:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •