So after yesterday's snafu with the LE Car pack, everything had been working fine. This morning installed LE Car pack when it became available, game started and ran fine, I shut it down and went about my day.

Now I go to boot the game and it shows the intro splash screens, then prompts me to hit the menu button. I click Menu, and then select my Live Profile, and the next screen with 4 animated bars before the video is supposed to start never leaves. The animation of the bars and the background rain never stops, and I am able to navigate back to xbox menu, but the game never progresses past this point. I have let it run for over 30 minutes and no change.

I am on energy saver mode, internal HD, wired internet. In fact, every time I turn my xbox off I hold the power button for 20+ seconds to make sure it is all the way off.

I have tried with and without my wheel attached
Tried without any peripherals at all attached
tried with all car packs, without LE car pack, and with no car packs.
I have cleared the cache tapping the power button without being plugged in
I have uninstalled and reinstalled the game (disk install) and tried to boot fresh without any peripherals or addons.
I have deleted and re-synced my local save files

The only thing I have not done is delete my save files everywhere, because I highly doubt it will work and I would be very angry with myself if I did do that and it solved nothing.

Any assistance?

Thanks in advance.