Results 1 to 4 of 4

Thread: Dedicated server question

  1. #1
    Rookie
    Join Date
    Jan 2019
    Location
    Barcelona
    Posts
    2
    Platform
    PC

    Dedicated server question

    Hi, I have crawled the forums but I'm not able to solve my issue...

    The problem is that I cannot see my server ingame. I am launching the dedicated server in a laptop and the game in my gaming pc, which are in the same local network. This way i see the server with no problem and I can join in, but my friends cannot. If I use the wifi of my mobile phone in the gaming pc, so connecting from outside of my local network, the server does not appear ingame.

    Those are the steps I followed:

    I have set up the server.cfg properly and run DedicatedServerCmd.exe with apparently no error. I have not changed anything besides server.cfg (no luas or anything else). This is the result in the cmd:

    Code:
    [2020-05-24 22:26:44] INFO: Starting up the Dedicated Server Library.
    [2020-05-24 22:26:44] INFO: Server configuration loaded:
    - server build version: 1
    - protocol version: 64 (1.0.0.64)
    - server name: Puesta a Punto SR 2.0 Casual racing
    - max session size: 24
    - details: secure, bind IP INADDR_ANY, Steam port 8766, host port 27015, query port 27016, password protected yes
    - whitelist size: 0
    - blacklist size: 0
    - lua api: enabled
    - http api: enabled listening at 127.0.0.1:9000, 1 extra header(s) defined
    - allow empty join: enabled
    - game setup control: enabled
    - sports play : disabled
    Setting breakpad minidump AppID = 378860
    [2020-05-24 22:26:44] INFO: HttpApi started
    [2020-05-24 22:26:44] INFO: Loading LuaApi addon 'sms_base'...
    [2020-05-24 22:26:44] INFO: Loading LuaApi addon 'sms_rotate'...
    [2020-05-24 22:26:44] INFO: Loading LuaApi addon 'lib_rotate'...
    [2020-05-24 22:26:44] INFO: Loading LuaApi addon 'sms_motd'...
    [2020-05-24 22:26:44] INFO: Loading LuaApi addon 'sms_stats'...
    [2020-05-24 22:26:44] INFO: LuaApi started
    [2020-05-24 22:26:44] INFO: Dedicated server is starting...
    [2020-05-24 22:26:45] INFO: Connection to Steam established
    [2020-05-24 22:26:45] INFO: Received public IP 93.176.157.21
    [2020-05-24 22:26:45] INFO: Server logged in with Steam id 90135552676304904 ; server is secure
    [2020-05-24 22:26:45] INFO: Server startup finished: AppId 378860, public IP [my public IP], Steam id [My Steam ID] ; switching to running state
    [2020-05-24 22:26:45] INFO: Saving persistent data for addon 'sms_rotate' into 'lua_config\sms_rotate_data.json'
    I also loaded the localhost user interface, but it shows a cross at "Joinable".

    I have an IP fixed by DHCP in my laptop and I have opened the ports specified in server.cfg in my router, or at least I think so. I have tried with the default ports, as well as some random ones. The thing is that with a port forwarding checking tool i see them as closed, no matter which I try...

    I can see the server in the online server lists, but I cannot see it using the builtin Steam server search tool, where you search for active games in a particular IP and port (cannot post pics or links as I am new to this forum...).

    I created a rule in the windows 10 firewall for the same ports and even disabled the firewall completely, with no success.

    I am at this point and I don't know what to do or where to search for a solution. Is this a "I cannot open my ports even if I tried" kind of problem?
    Last edited by thisisrhun; Yesterday at 21:03.

  2. #2
    WMD Member Asturbo's Avatar
    Join Date
    Jun 2012
    Location
    Asturias / Spain
    Posts
    1,373
    Platform
    PC
    If you see the server from LAN that means that the setup files are correct. So the problem looks the port forwarding in your router is not working. Some ideas:

    - The Steam and Host ports are TPC but the query port is UDP. If your router has both options set the right one.
    - Check if the router has any firewall and try disabling it.
    - Disable Windows Firewall and/or antivirus in the host computer.
    - Try starting the CMD as administrator.

    There is other parameter in Steam client that could make your server invisible, but doesn't look it's your problem.

    For testing porpouses (not recommended), you can also open the HTTP port to see if you can connect from outside to see if the forwarding rules works.
    Last edited by Asturbo; Yesterday at 21:45.
    CPU: Intel i7-8700K | GPU: nVidia RTX2080 | RAM: Gskill 2x8GB DDR4 3200 | MB: Asus ROG Strix Z370 | SSD: Samsung EVO 970 500Gb | Monitor: Acer Predator Z35P UW WQHD | Wheel: Fanatec DD1 + Porsche Endurance + Formula 1 V2 | SO: Windows 10 Pro 64bits
    WMD1 & WMD2 Gold Member /// Steam Profile /// Unofficial Issue List /// Button Box Label Template /// DS Flags Calculator /// Open Weather App /// DS Config Samples /// Google Standings /// PC3 wish list

  3. #3
    Superkart Pilot Visceral_Syn's Avatar
    Join Date
    May 2015
    Location
    Memphis, TN
    Posts
    210
    Platform
    PC
    To see dedicated servers not listing in steam, and you know it's there. You must lower max server pings settings, in steam settings from the default, to a lower value, 250 works fine for mine, as well as for almost everyone else. As for port forwarding, 8766 both UDP/TCP to the ip of the hosting computer. I also have steam ports 27015 and 27016 both UDP/TCP forwarded to the server. I'm not 100% sure if the steam ports are needed, but 8766 is. Do not bind ip to loopback, use the ip of ethernet interface. software firewalls on computers are only additional problems, your router IS your firewall. NAT, is a firewall.
    Last edited by Visceral_Syn; Yesterday at 23:58.
    Game-Rig: Intel i7 4770S | eVGA GTX 1080 | 16GB Crucial Ballistix | Asus Z87-A | BenQ Zowie XL2730 | Microsoft Windows 10 | Logitech z5500 5.1 Digital | Thrustmaster TS-PC | Thrustmaster T3PA-Pro | Thrustmaster TH8A | Natural Point Track IR 4 | Playseats Evolution
    Server: Intel L5639 Xeon | Asus P6T | 12GB Corsair Vengeance | 128GB Crucial SSD | CentOS 7.4 | Linux Kernel 4.14 | pCars˛ Dedicated Server: Beale St. Blues | Steam: Visceral_Syn


  4. #4
    Rookie
    Join Date
    Jan 2019
    Location
    Barcelona
    Posts
    2
    Platform
    PC
    Quote Originally Posted by Asturbo View Post
    If you see the server from LAN that means that the setup files are correct. So the problem looks the port forwarding in your router is not working.
    Thanks, I think my problem is with the router. I'll talk to my internet provider because I think I am behind a CGNAT. (Nos vemos en PAP!)

Similar Threads

  1. Replies: 6
    Last Post: 09-05-2019, 01:21
  2. Private Dedicated Server Question
    By weapon2057 in forum Multiplayer
    Replies: 2
    Last Post: 11-03-2019, 18:31
  3. Question about Dedicated Server Flags
    By M700N in forum Multiplayer
    Replies: 7
    Last Post: 30-05-2018, 12:54
  4. Dedicated server question: host migration?
    By bloozmahn in forum Multiplayer
    Replies: 1
    Last Post: 04-11-2017, 15:55
  5. Replies: 21
    Last Post: 03-10-2017, 19:42

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •