Results 1 to 6 of 6

Thread: Thrustmaster Redefines Normal

  1. #1
    Kart Driver
    Join Date
    Dec 2015
    Posts
    80
    Platform
    PC

    Thrustmaster Redefines Normal

    Wanted to share for anyone who has bought or is thinking of buying a Thrustmaster TS-PC Racer.

    After about 6 weeks my TS-PC Racer developed a buzzing noise which would start up about 5 or 10 mins after I started using the wheel. I bought it direct from TM so better raise a support ticket I thought. I done so and sent them a description of the problem along with a video of the noise.

    I was trying to get TM to send me a replacement wheel before I had to send mine off for repair as being without it is a huge inconvenience but the signs weren't good. 3 days and several calls and emails later while waiting to hear about whether they would send me a replacement first I got this in an email (extracted the relevant part below verbatim).

    We have been informed that the type and level of noise that you are getting from the unit is normal.

    This has been replicated on some of our own units used in all sorts of testing.

    This noise is caused by the fan inside the unit and the level of it is within the normal limits.


    This is the very video I sent them:

    https://www.youtube.com/watch?v=LqxdEnhBbxk

    Here was crazy old me thinking my PC-Racer was faulty. I'm of course much happier now that my PC Racer isn't faulty after all and that noise I can hear through noise cancelling headphones while a car engine blares through them comes as standard with TS-PC Racers.

    So if you have a PC Racer don't worry folks, it's normal!! If you are thinking of buying one though you might have to wait a few weeks for this feature to appear.

    PS - I asked for a refund after this. I didn't get one so I'm left with a 500 faulty wheel they won't repair.
    PPS - morale of the story is don't buy direct from Thrustmaster as their support is awful and TBH don't buy a TS-PC Racer as in their words - a loud buzzing noise coming from the base is "normal".
    PPPS - apologies if you've already read this post elsewhere - I'm spreading the news
    The following 3 users likes this Post: Charger, gotdirt410sprintcar, JessicaWalter


  2. #2
    Moderator Roger Prynne's Avatar
    Join Date
    Oct 2011
    Location
    Newquay, Cornwall, UK
    Posts
    4,902
    Platform
    PC
    Sounds like the bearing on the fan is knackered to me.... bummer that they wont do anything about it though.

    Looks like you might have to take it apart to investigate.
    Addressing expectations on realism and simulation - Project CARS PC Leaderboards - Learn how to race properly - Forum Resources for Pcars
    -----------------------------------------------------------------------------------------------------------------------------------------------
    A good explanation of the different tyre types - FFB Guide - Official FFB Guide - A new home for all your setups - How to use the Advance Search
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Mobo: GIGABYTE GA-970A-DS3P AMD 970 ATX | CPU: AMD FX-8350 4.0 GHz (4.20 GHz Turbo) 8x Core | CPU Cooler: Cooler Master V8 | Memory: 8GB DDR3 (1600MHz) Crucial Ballistix Sport Memory
    Graphics: NVIDIA GeForce GTX 960 2GB GDDR5 - (Driver: 378.66)| Displays: 50" LCD TV 1920x1080 @ 60Hz - 24" Monitor 1920x1080 @ 60Hz | PSU: Sea Sonic X - 850 Watt
    Storage: SSD 250GB Samsung 850 EVO x2 - 2TB Western Digital Caviar Green Sata III x2 | Sound: X-FI Xtreme Gamer Fatality Pro + 400W Technics 7.1
    Wheel: G25 & Pedals with Nixim brake mod (NO PROFILER USED) | RIG: Playseat Challenge | OS: Windows 10 Pro 64 bit - Anniversary

  3. #3
    Superkart Pilot gotdirt410sprintcar's Avatar
    Join Date
    May 2015
    Location
    OHIO
    Posts
    739
    Platform
    PS4
    Good old thrustmaster i have a t500 and t300 used the t300 one time put back in the box t500 i like better . But i would of never bought thrustmaster stuff if it wasn't for console bs. But im happy with t500 thought wheel was broke at one point but it was the FFB bug lol after five months i figured that out. If they ever build a DD wheel the fan blade might blow out the thing scary. Hope it lasts for you all that money too do that already could of bought a g27 if you wanted a noisy wheel lol.
    The following user likes this Post: hkraft300


  4. #4
    Kart Driver
    Join Date
    Dec 2015
    Posts
    80
    Platform
    PC
    If anyone wants to see inside the TS-PC racer see this follow on vid https://youtu.be/-A-N1i-bmYo

    The noise is from a fan inside the motor itself.
    The following user likes this Post: gotdirt410sprintcar


  5. #5
    Kart Driver
    Join Date
    Dec 2015
    Posts
    80
    Platform
    PC
    Looks like I fixed the problem - done a full nights racing after applying it and no noise!!

    Turns out there is a spring of sorts on the central spindle of the motor which is anchored to the spindle at one end (so the spring turns as you turn the wheel) whose purpose appears to be to hold the fan in place and hence pushes against it. But it's just the open end of a coiled piece of wire basically and the cut part of the wire pushes on the fan and looked to have a slightly rough edge. Solution was to pull this end back over the spring so it was caught a rung down and kept away from the fan. Very tricky to do in such a small space but used the edge of a pointy knife and sneaked it. These 2 pics illustrate it better with a slinky BEFORE - http://imgur.com/a/Hc8WU AFTER - http://imgur.com/a/LyEKd

    Thrustmaster have a flaw in the design of this motor. I've had 2 other people come to me with the same problem which in combination with TM saying they can recreate the noise in their lab and in their words is normal, means until they accept this is an issue and make a design change, you can expect to get this issue with a PC-Racer and TM won't support it as a fault.

    I hope this helps anyone that has the wheel and puts others off from buying it until TM get their head out the sand and fix it.
    The following 2 users likes this Post: hkraft300, Mad Al


  6. #6
    Moderator Roger Prynne's Avatar
    Join Date
    Oct 2011
    Location
    Newquay, Cornwall, UK
    Posts
    4,902
    Platform
    PC
    Good find and fix mate..... the AFTER pic does not work by the way.
    Addressing expectations on realism and simulation - Project CARS PC Leaderboards - Learn how to race properly - Forum Resources for Pcars
    -----------------------------------------------------------------------------------------------------------------------------------------------
    A good explanation of the different tyre types - FFB Guide - Official FFB Guide - A new home for all your setups - How to use the Advance Search
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Mobo: GIGABYTE GA-970A-DS3P AMD 970 ATX | CPU: AMD FX-8350 4.0 GHz (4.20 GHz Turbo) 8x Core | CPU Cooler: Cooler Master V8 | Memory: 8GB DDR3 (1600MHz) Crucial Ballistix Sport Memory
    Graphics: NVIDIA GeForce GTX 960 2GB GDDR5 - (Driver: 378.66)| Displays: 50" LCD TV 1920x1080 @ 60Hz - 24" Monitor 1920x1080 @ 60Hz | PSU: Sea Sonic X - 850 Watt
    Storage: SSD 250GB Samsung 850 EVO x2 - 2TB Western Digital Caviar Green Sata III x2 | Sound: X-FI Xtreme Gamer Fatality Pro + 400W Technics 7.1
    Wheel: G25 & Pedals with Nixim brake mod (NO PROFILER USED) | RIG: Playseat Challenge | OS: Windows 10 Pro 64 bit - Anniversary

Similar Threads

  1. New T300 GTE Normal Behavior?
    By matt5687 in forum PS4 - Technical Help & Support
    Replies: 2
    Last Post: 24-08-2016, 09:58
  2. Normal when Raining?
    By seek in forum PC - Technical Help & Support
    Replies: 9
    Last Post: 13-08-2016, 00:23
  3. IS THIS NORMAL ?
    By Tobes in forum Project CARS on Playstation 4
    Replies: 1
    Last Post: 21-03-2016, 02:55
  4. Is this normal?
    By levoll11 in forum General Discussion
    Replies: 5
    Last Post: 18-09-2015, 19:21
  5. anyone else having mp problems more than normal
    By turbohondaej1 in forum XB1 - Technical Help & Support
    Replies: 1
    Last Post: 19-05-2015, 00:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •