Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: Crash while loading track: "async file object is destroyed whilst still in use"

  1. #21
    Super Moderator Remco Van Dijk's Avatar
    Join Date
    Sep 2011
    Location
    The Netherlands
    Posts
    5,842
    So you got the async error again after it was solved with a game cache integrity check? Did you do the check again? And are all crashes the same async error?
    CPU i7 7700K | RAM Corsair 16GB 2400MHz | GPU Asus GTX1080 Ti OC 11GB | Mobo Asus Strix Z270H | Audio SB Zx @ 5.1/AKG K401 | OS Win 10 x64 | Screen LG 27EA63V-P 27" 1920x1080 | Controllers Fanatec CSW v2.5 + UH, CSP v3, CSS SQ, CSH | Misc TrackIR 4 Pro, Playseat Revolution, DS button box
    Texture Res HIGH | AF 16x | VSync ON | AA MSAA Medium | Reflections HIGH | EnvMap HIGH | Vehicle ULTRA | Track ULTRA | Shadows HIGH | Motion Blur OFF | Particle Quality HIGH | Particle Density HIGH | Crepuscular Rays ON | Heat Haze OFF | Stretched Headlights ON | Detailed Grass OFF
    With the right to say what you think comes the obligation to think about what you say. || Don't take life too seriously. No-one gets out alive anyway.

  2. #22
    Superkart Pilot
    Join Date
    May 2015
    Posts
    153
    Platform
    PC
    Quote Originally Posted by Remco Van Dijk View Post
    So you got the async error again after it was solved with a game cache integrity check? Did you do the check again? And are all crashes the same async error?
    Yeah, I checked it again, but nothing was found. There isn't only the async error, but it's still an issue. It appears in three of the uploaded folders.

  3. #23
    Superkart Pilot
    Join Date
    May 2015
    Posts
    153
    Platform
    PC
    In the last few days, I got another error every time. I've planned to finish my career before the release of PC2, but this seems impossible now.

  4. #24
    Super Moderator Remco Van Dijk's Avatar
    Join Date
    Sep 2011
    Location
    The Netherlands
    Posts
    5,842
    I've quickly checked one of the log files, and it states:

    This async file object is being destroyed whilst still in use: 'pakfiles\tracks\sakitto[group].bff'

    This is very typical of a corrupt file, and can be solved by doing the file integrity check in Steam. The point is, however, that something on your system is breaking these files every time, and usually it's anti-virus or anti-malware software. BitDefender, Avast, ESET are known to cause such troubles. You may want to try and remove your AV from your system altogether (turning it off often doesn't really mean it's completely off) and see if that helps.

    Another approach could be to add the whole pCARS installation folder to the exception list of your AV/anti-malware program(s).
    CPU i7 7700K | RAM Corsair 16GB 2400MHz | GPU Asus GTX1080 Ti OC 11GB | Mobo Asus Strix Z270H | Audio SB Zx @ 5.1/AKG K401 | OS Win 10 x64 | Screen LG 27EA63V-P 27" 1920x1080 | Controllers Fanatec CSW v2.5 + UH, CSP v3, CSS SQ, CSH | Misc TrackIR 4 Pro, Playseat Revolution, DS button box
    Texture Res HIGH | AF 16x | VSync ON | AA MSAA Medium | Reflections HIGH | EnvMap HIGH | Vehicle ULTRA | Track ULTRA | Shadows HIGH | Motion Blur OFF | Particle Quality HIGH | Particle Density HIGH | Crepuscular Rays ON | Heat Haze OFF | Stretched Headlights ON | Detailed Grass OFF
    With the right to say what you think comes the obligation to think about what you say. || Don't take life too seriously. No-one gets out alive anyway.
    The following 2 users likes this Post: BullWinkle, Roger Prynne


  5. #25
    Superkart Pilot
    Join Date
    May 2015
    Posts
    153
    Platform
    PC
    A simple reboot of my computer will also repair the corrupted files. The Steam integrity check afterwards doesn't find anything. (Yes, I've checked it every time)

    So, I uninstalled my AntiVir program completely and it seems that the async error is gone. Nevertheless, yesterday, a similar error occurs when I try to start a session:

    Code:
    Source\Modules\AppLoader\BAppLoaderPhase.cpp(263): in function 'MWL::Base::BAppLoaderPhase::LoadError
    
    BAppLoaderPhase: File Error: 13 loading pakfiles\igphaseactivate.bff
    Attached Files Attached Files

  6. #26
    Super Moderator Remco Van Dijk's Avatar
    Join Date
    Sep 2011
    Location
    The Netherlands
    Posts
    5,842
    Quote Originally Posted by Mattze View Post
    A simple reboot of my computer will also repair the corrupted files. The Steam integrity check afterwards doesn't find anything. (Yes, I've checked it every time)

    So, I uninstalled my AntiVir program completely and it seems that the async error is gone. Nevertheless, yesterday, a similar error occurs when I try to start a session:

    Code:
    Source\Modules\AppLoader\BAppLoaderPhase.cpp(263): in function 'MWL::Base::BAppLoaderPhase::LoadError
    
    BAppLoaderPhase: File Error: 13 loading pakfiles\igphaseactivate.bff
    Does this happen every time you start the game?
    If yes, did you check whether the referenced pakfile is on your system, and if yes whether a Steam File Integrity check fixed the file (in either case)? In this case it still looks like something is corrupting/damaging/changing files on your system. What other applications do you have running in the background all the time?

    If no and it happens occasionally, then it sounds like something is sometimes preventing file access or something like that. Have you checked your HDD for issues recently?
    CPU i7 7700K | RAM Corsair 16GB 2400MHz | GPU Asus GTX1080 Ti OC 11GB | Mobo Asus Strix Z270H | Audio SB Zx @ 5.1/AKG K401 | OS Win 10 x64 | Screen LG 27EA63V-P 27" 1920x1080 | Controllers Fanatec CSW v2.5 + UH, CSP v3, CSS SQ, CSH | Misc TrackIR 4 Pro, Playseat Revolution, DS button box
    Texture Res HIGH | AF 16x | VSync ON | AA MSAA Medium | Reflections HIGH | EnvMap HIGH | Vehicle ULTRA | Track ULTRA | Shadows HIGH | Motion Blur OFF | Particle Quality HIGH | Particle Density HIGH | Crepuscular Rays ON | Heat Haze OFF | Stretched Headlights ON | Detailed Grass OFF
    With the right to say what you think comes the obligation to think about what you say. || Don't take life too seriously. No-one gets out alive anyway.

  7. #27
    Superkart Pilot
    Join Date
    May 2015
    Posts
    153
    Platform
    PC
    Quote Originally Posted by Remco Van Dijk View Post
    Does this happen every time you start the game?
    If yes, did you check whether the referenced pakfile is on your system, and if yes whether a Steam File Integrity check fixed the file (in either case)? In this case it still looks like something is corrupting/damaging/changing files on your system. What other applications do you have running in the background all the time?

    If no and it happens occasionally, then it sounds like something is sometimes preventing file access or something like that. Have you checked your HDD for issues recently?
    Sorry, I've been misleading. The error occurred when I started a race session (qualifying, if remember correctly), just like the async error before. Until now, it occurred only two days ago. I don't run any external programs in the background except Steam and have no issues with my HDD as far as I know. I cannot explain ...

    But thanks for your endurance!

  8. #28
    Super Moderator Remco Van Dijk's Avatar
    Join Date
    Sep 2011
    Location
    The Netherlands
    Posts
    5,842
    Quote Originally Posted by Mattze View Post
    Sorry, I've been misleading. The error occurred when I started a race session (qualifying, if remember correctly), just like the async error before. Until now, it occurred only two days ago. I don't run any external programs in the background except Steam and have no issues with my HDD as far as I know. I cannot explain ...

    But thanks for your endurance!
    If it only happened once and without changing/fixing anything it didn't happen again, it sounds like some sort of timing conflict leading to this file loading failure?
    CPU i7 7700K | RAM Corsair 16GB 2400MHz | GPU Asus GTX1080 Ti OC 11GB | Mobo Asus Strix Z270H | Audio SB Zx @ 5.1/AKG K401 | OS Win 10 x64 | Screen LG 27EA63V-P 27" 1920x1080 | Controllers Fanatec CSW v2.5 + UH, CSP v3, CSS SQ, CSH | Misc TrackIR 4 Pro, Playseat Revolution, DS button box
    Texture Res HIGH | AF 16x | VSync ON | AA MSAA Medium | Reflections HIGH | EnvMap HIGH | Vehicle ULTRA | Track ULTRA | Shadows HIGH | Motion Blur OFF | Particle Quality HIGH | Particle Density HIGH | Crepuscular Rays ON | Heat Haze OFF | Stretched Headlights ON | Detailed Grass OFF
    With the right to say what you think comes the obligation to think about what you say. || Don't take life too seriously. No-one gets out alive anyway.

  9. #29
    Superkart Pilot
    Join Date
    May 2015
    Posts
    153
    Platform
    PC
    Alright, I've got two "new" errors in one day this weekend. For those of you interested, I added the debug files to the attachment. But I don't feel like it anymore. It seems that the original async error was caused by the AntiVir program, so this thread can be marked as solved. Thank you all for your patience. Project CARS 1 remains a buggy game. Let's hope for the sequel.
    Attached Files Attached Files

Similar Threads

  1. Replies: 51
    Last Post: 04-11-2015, 10:00
  2. Replies: 27
    Last Post: 14-09-2015, 18:52
  3. Replies: 35
    Last Post: 24-07-2015, 09:30
  4. this async file object is being destroyed whilst still in use
    By Noksi in forum PC - Technical Help & Support
    Replies: 2
    Last Post: 30-06-2015, 21:59
  5. BDbgFatal Async File Object is being destroyed
    By DerStoffel in forum PC - Technical Help & Support
    Replies: 5
    Last Post: 26-05-2015, 08:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •