Results 1 to 9 of 9

Thread: [RESOLVED] Thrustmaster T 300 RS is unresponsive in game

  1. #1
    Rookie
    Join Date
    Jul 2017
    Posts
    4
    Platform
    PC

    [RESOLVED] Thrustmaster T 300 RS is unresponsive in game

    Hello.

    My Thrustmaster T 300 RS is unresponsive in game.
    The wheel works for my computer in the Windows/Thrustmaster configuration panel but the game stay unresponsive to it. It will not calibrate or work in game in any way.. Any ideas?

  2. #2
    WMD Member Mahjik's Avatar
    Join Date
    Oct 2011
    Location
    Kansas City, MO
    Posts
    8,232
    Platform
    PC
    Please provide full system specs including OS and Thrustmaster driver version.
    Intel i7-4790K @4.4GHz | 16gb ram | ZOTAC GeForce GTX 1080 | 5040x1050 | Windows 8.1 64-bit | Thrustmaster TX Servo Base | Thrustmaster TH8A Shifter
    ProtoSimTech PT-1 Pedals | rSeat Evo V2 | Front/Rear Transducers | SimVibe | Black Max II Button Controller | Sennheiser PC 360 Headset


    Forum Rules
    PC2 FAQ & Tips

  3. #3
    Rookie
    Join Date
    Jul 2017
    Posts
    4
    Platform
    PC
    Sure.

    System & OS :

    i7-6700K CPU 4.00GHz
    32 Go RAM
    GPU MSI gaming X GEFORCE GTX 1080 Ti
    Windows 10 familly edition
    SSD drives
    on MSI Z170A Gaming M5 motherboard

    Thrustmaster wheel driver version :

    Firmware: 25
    Driver: 2.9.1.0

  4. #4
    WMD Member Mahjik's Avatar
    Join Date
    Oct 2011
    Location
    Kansas City, MO
    Posts
    8,232
    Platform
    PC
    Hmm, I'm on the same driver version. I have a TX so my firmware is different. If you go into "EDIT ASSIGNMENTS", you cannot assign the steering axis to the wheel?

    Just to confirm, you don't have any other gaming controllers connected? Any older gaming devices that you might have had previously (but drivers still installed)?
    Intel i7-4790K @4.4GHz | 16gb ram | ZOTAC GeForce GTX 1080 | 5040x1050 | Windows 8.1 64-bit | Thrustmaster TX Servo Base | Thrustmaster TH8A Shifter
    ProtoSimTech PT-1 Pedals | rSeat Evo V2 | Front/Rear Transducers | SimVibe | Black Max II Button Controller | Sennheiser PC 360 Headset


    Forum Rules
    PC2 FAQ & Tips

  5. #5
    Rookie
    Join Date
    Jul 2017
    Posts
    4
    Platform
    PC
    Well i'm back with good news ! Wheel is alive and kicking again in Project cars !

    Since i can't be sure of what finally was causing this issue, here is what i did:

    - disabled Antivirus
    - disabled Nahimic 2+ (which was messing with other apps at times; mainly EU4)
    - switched to another input in Pcars control config
    - switched back to Thrusmaster T300 RS in same control panel
    - ran the steering calibration in game and that worked, finally !

    Other drivers i have is for a Saitek HOTAS which i unplug when i use the Wheel.
    Last edited by Ghanth; 09-07-2017 at 16:37.
    The following 2 users likes this Post: Mahjik, Roger Prynne


  6. #6
    Moderator +WMD 1/2 Member Roger Prynne's Avatar
    Join Date
    Oct 2011
    Location
    Newquay, Cornwall, UK
    Posts
    7,691
    Platform
    PC
    Now don't touch anything and get some track time in
    Mobo: GIGABYTE GA-970A-DS3P AMD 970 ATX | CPU: AMD FX-8350 4.0 GHz (4.20 GHz Turbo) 8x Core | CPU Cooler: Cooler Master V8 | Memory: 16GB DDR3 (1600MHz)
    Graphics: NVIDIA GeForce GTX 970 2GB GDDR5 - (Driver: 385.69)| Displays: 55" LG 4K UHD TV @ 60Hz - 24" Monitor 1920x1080 @ 60Hz | PSU: Sea Sonic X - 850 Watt
    Storage: SSD 250GB Samsung 850 EVO x2 - 2TB Western Digital Caviar Green Sata III x2 | Sound: X-FI Xtreme Gamer Fatality Pro + 400W Technics 7.1
    Wheel: G25 & Pedals with Nixim mod springs (NO PROFILER USED) | RIG: Playseat Challenge | OS: Windows 10 Pro 64 bit
    -----------------------------------------------------------------------------------------------------------------------------------------
    A few helpful links for you



  7. #7
    Rookie
    Join Date
    Jul 2017
    Posts
    4
    Platform
    PC
    Sure !

  8. #8
    GT3 Pilot dault3883's Avatar
    Join Date
    Apr 2017
    Location
    North Carolina
    Posts
    3,859
    Platform
    PC
    Quote Originally Posted by Ghanth View Post
    Well i'm back with good news ! Wheel is alive and kicking again in Project cars !

    Since i can't be sure of what finally was causing this issue, here is what i did:

    - disabled Antivirus
    - disabled Nahimic 2+ (which was messing with other apps at times; mainly EU4)
    - switched to another input in Pcars control config
    - switched back to Thrusmaster T300 RS in same control panel
    - ran the steering calibration in game and that worked, finally !

    Other drivers i have is for a Saitek HOTAS which i unplug when i use the Wheel.
    i doubt your anti virus would be interferring with your wheel
    Jackie Stewart - "Sometimes you need to ease off in order to go faster"
    Intel Core i7-8700k cpu @ 3.7GHz 3.70GHz Ram:16GB 64 bit operating system Nvidia Geforce GTX 1080
    Steam ID: Dault3883 If u add me on steam send message on forum with ur steam id. If i dont know who the steam friend request belongs to i will ignore it.

  9. #9
    Moderator +WMD 1/2 Member Roger Prynne's Avatar
    Join Date
    Oct 2011
    Location
    Newquay, Cornwall, UK
    Posts
    7,691
    Platform
    PC
    ^ Ha you'd be surprised what some AV's can do.
    Mobo: GIGABYTE GA-970A-DS3P AMD 970 ATX | CPU: AMD FX-8350 4.0 GHz (4.20 GHz Turbo) 8x Core | CPU Cooler: Cooler Master V8 | Memory: 16GB DDR3 (1600MHz)
    Graphics: NVIDIA GeForce GTX 970 2GB GDDR5 - (Driver: 385.69)| Displays: 55" LG 4K UHD TV @ 60Hz - 24" Monitor 1920x1080 @ 60Hz | PSU: Sea Sonic X - 850 Watt
    Storage: SSD 250GB Samsung 850 EVO x2 - 2TB Western Digital Caviar Green Sata III x2 | Sound: X-FI Xtreme Gamer Fatality Pro + 400W Technics 7.1
    Wheel: G25 & Pedals with Nixim mod springs (NO PROFILER USED) | RIG: Playseat Challenge | OS: Windows 10 Pro 64 bit
    -----------------------------------------------------------------------------------------------------------------------------------------
    A few helpful links for you



Similar Threads

  1. [RESOLVED] Fanatec CSR Wheel Base V2 + CSR V3 Pedals unresponsive
    By akirby1234 in forum PC - Technical Help & Support
    Replies: 4
    Last Post: 04-07-2017, 15:59
  2. [RESOLVED] Thrustmaster T150 Ferrari Racing Wheel not working?
    By Threal in forum PC - Technical Help & Support
    Replies: 2
    Last Post: 22-04-2017, 07:27
  3. Suddenly unresponsive when doing many setting changes offline
    By PongDong in forum XB1 - Technical Help & Support
    Replies: 4
    Last Post: 23-10-2016, 11:26
  4. [RESOLVED] Issues using Thrustmaster T80
    By joaoximenes92 in forum PS4 - Technical Help & Support
    Replies: 20
    Last Post: 21-07-2016, 21:55
  5. [RESOLVED] Can't set steering sensitivity high enough on Thrustmaster T300
    By Roaders in forum PC - Technical Help & Support
    Replies: 3
    Last Post: 24-06-2016, 12:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •