Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: T500RS View not correct

  1. #1
    Kart Driver
    Join Date
    Aug 2017
    Posts
    5
    Platform
    PC

    Question T500RS View not correct

    Hello people!

    I just joined this forum because i can not fix this damn issue i've been facing the whole last week since i got the Wheel.

    So here's what happens:
    1. I can NOT map buttons from the Wheel because "Multiple inputs were detected"
    2. The controller settings in Windows look like this: *Ugh, can not post links ....*
    Which to me looks like all buttons except 1+2 and 12+13 are pressed?!
    3. The camera ingame ALWAYS faces backwards to the left side. I can NOT change that in any f*cking way.
    The only buttons i can press ingame are 3 pedals, the 2 Shifters and "P" for pause on the keyboard.
    Funny thing is, when i press Pause he pauses me sitting in the cockpit looking ot the left.
    4. When i select automatik driving mode for some reason the clutch is always pressed (Why does automatic have a clutch?) so when i go full throttle the car doesnt move.

    Things i've done:
    1. Win10 and win7
    2. Old and New installation
    3. Newest drivers and Firmware for the wheel
    4. Waited for 5 days because waiting 1 Day fixed that brake and throttle where on the same pedal (whatever that was....?!)

    Input method is T500RS with seperate wheel but for some reason i feel T300 Seperat works better....


    PLEASE Help me solve this sh*t! I was so excited to finally drive with a good wheel and now all this shit wants me to throw it out the window and go back to my xbox controller.
    Last edited by FloRolf; 13-08-2017 at 09:25.

  2. #2
    WMD Member MaximusN's Avatar
    Join Date
    Oct 2011
    Location
    Close enough to enjoy the sounds of the TT-circuit
    Posts
    581
    Platform
    PC
    Is your xbox controller still connected? It's just a formal question becuase it shouldn't cause any problems. I had 2 xbox controllers + my t500 + th8(shifter) connected and it still worked. BUT I did notice Windows 10(or the Netflix app) going haywire after the latest update. I couldn't enjoy Netflix with my wheel connected because it would keep sending inputs which meant the onscreen controls wouldn't turn off. I had to disconnect my wheel. That problem has fixed itself though.

    But long story short, disconnect all other controllers for a test AND make sure no input device(keyboard mouse or anything else) is sending inputs. Also make sure it's not your wheel that's faulty because it sounds like your Windows control panel also sees inputs while you're not doing anything. And make sure your wheel drivers are up to date(maybe even reinstall). Also which wheel is on the T500? The GT(with PS buttons)? I asked this because I also have the 458 wheel and on that wheel in the past the POV didn't work in a lot of games.
    Last edited by MaximusN; 13-08-2017 at 09:48.
    If everything seems under control, you're just not going fast enough.

    -Mario Andretti

  3. #3
    Kart Driver
    Join Date
    Aug 2017
    Posts
    5
    Platform
    PC
    Quote Originally Posted by MaximusN View Post
    Is your xbox controller still connected? It's just a formal question becuase it shouldn't cause any problems. I had 2 xbox controllers + my t500 + th8(shifter) connected and it still worked. BUT I did notice Windows 10(or the Netflix app) going haywire after the latest update. I couldn't enjoy Netflix with my wheel connected because it would keep sending inputs which meant the onscreen controls wouldn't turn off. I had to disconnect my wheel. That problem has fixed itself though.

    But long story short, disconnect all other controllers for a test AND make sure no input device(keyboard mouse or anything else) is sending inputs. Also make sure it's not your wheel that's faulty because it sounds like your Windows control panel also sees inputs while you're not doing anything. And make sure your wheel drivers are up to date(maybe even reinstall). Also which wheel is on the T500? The GT(with PS buttons)? I asked this because I also have the 458 wheel and on that wheel in the past the POV didn't work in a lot of games.
    Hey thanks for answering!

    No i disconnected it after a few tries. it was also the wireless one.
    I still have my keyboard and mouse connected but i don't see them outputting anything. How can i check that?

    It's just the standard GT wheel with PS buttons, yeah. And how do you think i should check if the keyboard isnt faulty?

    The thing is, i don't really care too much about the buttons that are not working but more like the view i can't change. If they are connected (which they probably are) i need fix both though

  4. #4
    WMD Member Mad Al's Avatar
    Join Date
    Nov 2011
    Location
    Suffolk, England
    Posts
    1,547
    Go into Steam, settings, controller and check under general controller settings.. basically untick everything.. and see if that helps

    i7 4770K - ASUS Z87-A - 16Gig DDR3 (2x 8G Crucial Ballistix PC3-12800) - ZOTAC GTX1080Ti FE with EVGA Hybrid Cooler - iiiyama ProLite B2783QSU - Oculus Rift CV1 - Samsung 840 250G SSD , WD 320G Blue, WD 2T Black, OCZ 120G Vertex 2 SSD, LiteOn iHAS122 DVD-RW - Creative Audigy 4 - Creative 5.1 speaker system - Logitech G19 - MS HABU Gaming Mouse - Fanatec GT3 RS V2 + Clubsport pedals + shifter set - Windows 10 Home (64 bit).

    Second machine used for additional testing. i7-4790T - Asus H97-Plus - 16G DDR3 PC-12800 - Gigabyte GTX1060 - iiyama Prolite E2607WS - Oculus Rift CV1 - W10 Pro (64 bit) - xbox360 pad or Logitech DFP (all at stock speeds)

    HTPC - For testing of Steam Big Picture Mode (Hopefully from Media Portal 2) - i3-4130T - ASUS H81M-C - 8G DDR3 PC-10666 - Gigabyte GTX750Ti - Windows 10 Home (64 bit) - xbox360 pad

  5. #5
    WMD Member MaximusN's Avatar
    Join Date
    Oct 2011
    Location
    Close enough to enjoy the sounds of the TT-circuit
    Posts
    581
    Platform
    PC
    Quote Originally Posted by Mad Al View Post
    Go into Steam, settings, controller and check under general controller settings.. basically untick everything.. and see if that helps
    Hadn't thought of that. Easiest check to see if it's Steam is to exit Steam(with the exit option under Steam in the Steam menu) and see if the Windows/Thrustmaster control panel still sees button presses.
    If everything seems under control, you're just not going fast enough.

    -Mario Andretti

  6. #6
    Kart Driver
    Join Date
    Aug 2017
    Posts
    5
    Platform
    PC
    Quote Originally Posted by MaximusN View Post
    Hadn't thought of that. Easiest check to see if it's Steam is to exit Steam(with the exit option under Steam in the Steam menu) and see if the Windows/Thrustmaster control panel still sees button presses.
    Quote Originally Posted by Mad Al View Post
    Go into Steam, settings, controller and check under general controller settings.. basically untick everything.. and see if that helps
    Everything was already unchecked except the first one. But didn't help. Closing steam still shows most buttons as pressed as seen here:
    https:// imgur.com/mGKK7VP

    remove the " " before imgur.

    Also when i try to test the buttons in the "Test Forces"-Tab, they don't do anything. But it also doesnt go crazy as if all are pressed.

  7. #7
    WMD Member Mad Al's Avatar
    Join Date
    Nov 2011
    Location
    Suffolk, England
    Posts
    1,547
    Quote Originally Posted by FloRolf View Post
    Everything was already unchecked except the first one. But didn't help. Closing steam still shows most buttons as pressed as seen here:
    https:// imgur.com/mGKK7VP

    remove the " " before imgur.

    Also when i try to test the buttons in the "Test Forces"-Tab, they don't do anything. But it also doesnt go crazy as if all are pressed.
    That's a detachable wheel I assume, have you tried removing it and see what it thinks then (as it actually looks to me like that wheel is just broken)

    i7 4770K - ASUS Z87-A - 16Gig DDR3 (2x 8G Crucial Ballistix PC3-12800) - ZOTAC GTX1080Ti FE with EVGA Hybrid Cooler - iiiyama ProLite B2783QSU - Oculus Rift CV1 - Samsung 840 250G SSD , WD 320G Blue, WD 2T Black, OCZ 120G Vertex 2 SSD, LiteOn iHAS122 DVD-RW - Creative Audigy 4 - Creative 5.1 speaker system - Logitech G19 - MS HABU Gaming Mouse - Fanatec GT3 RS V2 + Clubsport pedals + shifter set - Windows 10 Home (64 bit).

    Second machine used for additional testing. i7-4790T - Asus H97-Plus - 16G DDR3 PC-12800 - Gigabyte GTX1060 - iiyama Prolite E2607WS - Oculus Rift CV1 - W10 Pro (64 bit) - xbox360 pad or Logitech DFP (all at stock speeds)

    HTPC - For testing of Steam Big Picture Mode (Hopefully from Media Portal 2) - i3-4130T - ASUS H81M-C - 8G DDR3 PC-10666 - Gigabyte GTX750Ti - Windows 10 Home (64 bit) - xbox360 pad

  8. #8
    WMD Member MaximusN's Avatar
    Join Date
    Oct 2011
    Location
    Close enough to enjoy the sounds of the TT-circuit
    Posts
    581
    Platform
    PC
    Quote Originally Posted by Mad Al View Post
    That's a detachable wheel I assume, have you tried removing it and see what it thinks then (as it actually looks to me like that wheel is just broken)
    I refrained from asking that because it uses the attached wheel to display the panel(a GT has another one than the 458, because they have different buttons)). So no wheel will probably show a 'no add-on wheel connected' message. But it is worth a try.

    You could also try a different USB port(if it's on a USB3 port try a USB2 port) and while you're add it, take the power plug off too, so it's completely powered down. Shut down your system before switching and taking the powerplug off just to be sure.
    Last edited by MaximusN; 13-08-2017 at 19:07.
    If everything seems under control, you're just not going fast enough.

    -Mario Andretti

  9. #9
    WMD Member MaximusN's Avatar
    Join Date
    Oct 2011
    Location
    Close enough to enjoy the sounds of the TT-circuit
    Posts
    581
    Platform
    PC
    Quote Originally Posted by FloRolf View Post
    https:// imgur.com/mGKK7VP

    remove the " " before imgur.
    What is weird is that it's at 49.6 degrees. At rest it should be at 50%(I just checked mine).
    If everything seems under control, you're just not going fast enough.

    -Mario Andretti

  10. #10
    Kart Driver
    Join Date
    Aug 2017
    Posts
    5
    Platform
    PC
    Quote Originally Posted by Mad Al View Post
    That's a detachable wheel I assume, have you tried removing it and see what it thinks then (as it actually looks to me like that wheel is just broken)
    Quote Originally Posted by MaximusN View Post
    I refrained from asking that because it uses the attached wheel to display the panel(a GT has another one than the 458, because they have different buttons)). So no wheel will probably show a 'no add-on wheel connected' message. But it is worth a try.

    You could also try a different USB port(if it's on a USB3 port try a USB2 port) and while you're add it, take the power plug off too, so it's completely powered down. Shut down your system before switching and taking the powerplug off just to be sure.
    Quote Originally Posted by MaximusN View Post
    What is weird is that it's at 49.6 degrees. At rest it should be at 50%(I just checked mine).
    First off, thank you guys for the quick response!

    I haven't tried taking the wheel off yet but i assume i'll have to try that tomorrow...

    I already tried all of my USB Ports and even two different computers with different OS's (w10 and w7) so that shouldn't be the issue :/
    The 49.6% is my fault, sorry! It actually calibrates on every startup to 50%. Twice to be exact lol.

Similar Threads

  1. Correct FOV calulater For PS4
    By Snake OilerX in forum Project CARS on Playstation 4
    Replies: 9
    Last Post: 10-07-2016, 23:45
  2. Night sky not correct
    By mister dog in forum General Discussion
    Replies: 171
    Last Post: 05-10-2015, 10:50
  3. REV Limiters of GT3 are Correct?
    By Renoldo1990 in forum General Discussion
    Replies: 27
    Last Post: 19-07-2015, 14:53
  4. So what is the correct way to hook up a tx ?
    By Silversn95 in forum Project CARS on Xbox One
    Replies: 15
    Last Post: 24-06-2015, 19:16
  5. 3rd view camera moving up/down changing angle of view while racing (fix pls)
    By s3annnn in forum PC - Technical Help & Support
    Replies: 6
    Last Post: 11-05-2015, 17:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •