Page 3 of 10 FirstFirst 12345 ... LastLast
Results 21 to 30 of 98

Thread: Stutter Fix

  1. #21
    Kart Driver
    Join Date
    Feb 2016
    Posts
    39
    Platform
    PC
    I tried to take a screenshot of the OSD graphs with the 60fps limiter on, but the steam screenshot process produced large bumps in the graph.
    Instead I've used the graphs in Afterburner.

    LEFT - Adaptive Sync
    RIGHT - Adaptive sync with 60fps limit in RivaTuner
    UPPER - Frame Time (0-100ms)
    LOWER - FPS (0-400fps)


    The lines on the graphs are at slightly different heights - just my poor cropping!
    The vertical scale of these graphs is very exaggerated, so the fluctuations in Frame Time in the right graph are tiny.

    Click image for larger version. 

Name:	Adaptive Sync - No FPS limitier.jpg 
Views:	1 
Size:	48.0 KB 
ID:	240408 [Click image for larger version. 

Name:	Adaptive Sync - 60fps limiter in RivaTuner.jpg 
Views:	0 
Size:	45.3 KB 
ID:	240409


    Since my first post, I noticed that the 60fps limit in RivaTuner doesn't cure the problem completely. There are sections of the Spa Historic track which still produce very slight bumps in the graphs, but these sections are still much smoother than without RivaTuner's fps limit.
    The graphs are flat for most of the track.
    Last edited by Richard83945; 24-09-2017 at 15:52.
    Asus Z170 ROG Hero VIII | Intel i7 6700K | 16GB memory | Samsung SSD 850 256GB SSD | Asus Strix GTX 970 | Asus PG279Q | Windows 10 Pro FCU
    Thrustmaster TX

  2. #22
    Kart Driver
    Join Date
    Feb 2016
    Posts
    39
    Platform
    PC
    Monitor PC Performance with Display and Graphs - MSI Afterburner/RivaTuner (Beta/v4.4.0 Update)

    Asus Z170 ROG Hero VIII | Intel i7 6700K | 16GB memory | Samsung SSD 850 256GB SSD | Asus Strix GTX 970 | Asus PG279Q | Windows 10 Pro FCU
    Thrustmaster TX

  3. #23
    Superkart Pilot
    Join Date
    May 2015
    Location
    Canada
    Posts
    155
    Platform
    PC
    Thank you for reposting this information. I had the same problem in PC1 and used this fix but completely forgot about it. Fired up PC2 for the first time last night and noticed the very SUBTLE microstutter in turns which gives the impression of a fps drop of 60 down to 30 (even though the counter is still showing 60). Tried this fix this morning and it's buttery smooth in turns now, I'm so happy! It may have something to do with how PC2 looks at the default resolution refresh rate (within the frontend settings) but doesn't actually use it in-game. My default PC monitor spec is 1920x1080@59, which PC2 displays correctly in the options, but in-game the frame counter is at 60 fps, instead of locked at 59 fps which it should be when vsync is used. When I use the nvidia adaptive vsync and go back into the game it correctly locks it at 59 fps.

    EDIT: I feel that this thread should be stickied
    Last edited by SpeedLimitUnknown; 24-09-2017 at 22:09.
    PC details for troubleshooting:
    * Intel i7-6700K (4.6GHz) with Asus Maximus Hero VIII MB * Asus GeForce GTX 1070 Turbo * 16GB RAM G.SKILL Ripjaws (3200 MHz) * 750W XFX Pro PSU * Win10 (64-bit) * LG 24" IPS Panel or Samsung 65" LED TV with Steam Link * Logitech G27 + XB360 gamepad * Current games installed on SSD *
    * Questions about any of the parts in my rig or setup? Just ask! *

  4. #24
    WMD Member
    Join Date
    Oct 2012
    Posts
    2
    Platform
    PC
    Thanks for everyone for the tips here. I tried all the steps but struggled with the Adaptive V-Sync (I couldn't find the setting). I think this is because I have GSync but not sure?
    Anyway, here's what I did to fix the stutters for me. I disabled v-sync in the game, forced it on in the NVidia driver. I then set the FPS flag to 59FPS on the startup option in Steam.

    Voila, smooth as butter!!

    p.s. I LOVE THIS GAME! Amazing so far!
    Origin PC - EON17-SLX i76600K @ 4.5 GHZ .. OC GTX1080
    17" Gsync Display 512GB m2 SSD 32GB RAM
    The following user likes this Post: SpeedLimitUnknown


  5. #25
    Superkart Pilot
    Join Date
    May 2015
    Posts
    373
    Here's more interesting stuff. I fired up NVidia Inspector and for Project Cars 2 profile it had these FPS limiters listed
    Click image for larger version. 

Name:	Untitled.jpg 
Views:	365 
Size:	185.0 KB 
ID:	240446

    Tried them all from 60.7 up, 62.8 worked the best, incidentally the closest to 63. So you can set it there in NVidia Inspector or still pass in command param in Steam Client launch option for Project Cars 2
    -fpscap 62.8

    Works the same and from my initial testing works even better than 63.

    Click image for larger version. 

Name:	Capture.JPG 
Views:	367 
Size:	32.6 KB 
ID:	240447
    The following 2 users likes this Post: Boskapongen, SpeedLimitUnknown


  6. #26
    Kart Driver
    Join Date
    Jul 2015
    Posts
    79
    Platform
    PC
    My experience is different. I had a bad stutter with V-Sync Off, even when Fraps showed about 80-120fps. I enabled V-Sync in-game and in drivers for pCars2.exe: V-Sync On and Triple Buffer On, as well as set the -fpscap 65. Now the game runs very smooth. Of course I had to set the graphics as low as possible to keep the fps at 60 in heavy weather conditions with full grid.
    Last edited by Tepp; 24-09-2017 at 23:30.
    System: i5-4690S, GTX 1070; Wheel: CSL Elite PS4.

  7. #27
    Kart Driver
    Join Date
    Jul 2015
    Posts
    79
    Platform
    PC
    Quote Originally Posted by pool101 View Post
    Thanks for everyone for the tips here. I tried all the steps but struggled with the Adaptive V-Sync (I couldn't find the setting). I think this is because I have GSync but not sure?
    Anyway, here's what I did to fix the stutters for me. I disabled v-sync in the game, forced it on in the NVidia driver. I then set the FPS flag to 59FPS on the startup option in Steam.

    Voila, smooth as butter!!
    This is strange. When I tried to set the -fpscap to 60, it keeps stable 59fps, so you have to add some value, for example: to get 60, you have to set -fpscap to something like 63 or 65. If you set the 59 in steam, which I suppose sets the option "-fpscap 59", so the game is cutting fps to about 58. If you set the V-Synk On in drivers, it will drop the fps to a nearest multiple of 30fps. Seems you are getting "smooth as butter" at 30fps !!! ... What the Fraps show?
    System: i5-4690S, GTX 1070; Wheel: CSL Elite PS4.

  8. #28
    Superkart Pilot
    Join Date
    May 2015
    Posts
    373
    Quote Originally Posted by Tepp View Post
    My experience is different. I had a bad stutter with V-Sync Off, even when Fraps showed about 80-120fps. I enabled V-Sync in-game and in drivers for pCars2.exe: V-Sync On and Triple Buffer On, as well as set the -fpscap 65. Now the game runs very smooth. Of course I had to set the graphics as low as possible to keep the fps at 60 in heavy weather conditions with full grid.
    You still need in driver vsync with fpscap.
    If you use fpscap command line param, it effectively disables in game vSync, this is why you need to set one in driver.
    And guys, do not use fpscap 60. I think you can safely go over 62.8 which is minimum for this to work, but you just make GPU work harder rendering extra frames with no real benefit as they get discarded by VSync.
    Last edited by Andrew_WOT; 24-09-2017 at 23:55.

  9. #29
    WMD Member
    Join Date
    Oct 2012
    Posts
    2
    Platform
    PC
    Quote Originally Posted by Tepp View Post
    This is strange. When I tried to set the -fpscap to 60, it keeps stable 59fps, so you have to add some value, for example: to get 60, you have to set -fpscap to something like 63 or 65. If you set the 59 in steam, which I suppose sets the option "-fpscap 59", so the game is cutting fps to about 58. If you set the V-Synk On in drivers, it will drop the fps to a nearest multiple of 30fps. Seems you are getting "smooth as butter" at 30fps !!! ... What the Fraps show?
    I'm not getting 30fps as I have a GSync screen (which was in my post and my signature). I'm getting a very smooth 58-59 FPS .. without any micro stutters at all.
    Origin PC - EON17-SLX i76600K @ 4.5 GHZ .. OC GTX1080
    17" Gsync Display 512GB m2 SSD 32GB RAM

  10. #30
    Kart Driver
    Join Date
    Sep 2017
    Posts
    46
    Platform
    PC
    What's the best solution for AMD?

    RadeonPro doesn't work with PCARS2 so I cannot force adaptive sync. No other nvidia inspector type equivalent. I've tried a few different things and capping the FPS to 60 via drivers or RTSS seems to provide the most consistent results, but I still notice the cars ahead of me stuttering a bit when turning corners despite the frame counter never faltering.

    I'll have to try graphing it like Richard83945 sometime to see the frame timings in greater detail.

Similar Threads

  1. sound stutter on upshift
    By ShimonART in forum General Discussion
    Replies: 12
    Last Post: 01-08-2017, 21:05
  2. AI Car stutter
    By Tex-Rec in forum PC - Technical Help & Support
    Replies: 17
    Last Post: 01-04-2017, 20:02
  3. Help = Stutter even 60 FPS ( Cornering Problem )
    By Tex-Rec in forum General Discussion
    Replies: 38
    Last Post: 27-12-2016, 00:30
  4. Replay Stutter
    By Ezuna in forum General Discussion
    Replies: 2
    Last Post: 21-01-2016, 06:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •