Page 1 of 28 12311 ... LastLast
Results 1 to 10 of 277

Thread: Dedicated Server configuration

  1. #1
    Kart Driver Visceral_Syn's Avatar
    Join Date
    May 2015
    Location
    Memphis, TN
    Posts
    93
    Platform
    PC

    Dedicated Server configuration

    What is the correct syntax, some lines end with a comma at the end, but not all. Also have a buncha AI in the server, when I have not specified in the flags to fill session with AI, gridsize and maxplayers is set to the same value. Have even attempted to use the sms_rotate script, and again not added FILL_SESSION_WITH_AI, flag, have used text and the value, still has AI in the session.


    Intel i7 4770S@3.1Ghz | eVGA GTX 1080 | Crucial Ballistix 2*8GB | Asus Z87-A Mainboard | BenQ Zowie XL2730 2560*1440@144Hz | Logitech G25 | Natural Point Track IR4 | Playseats Evolution

  2. #2
    Kart Driver Visceral_Syn's Avatar
    Join Date
    May 2015
    Location
    Memphis, TN
    Posts
    93
    Platform
    PC
    Ok, I see multiple options are all separated by comma's. But this still does not explain the AI in session, when AI should not be in session...


    Intel i7 4770S@3.1Ghz | eVGA GTX 1080 | Crucial Ballistix 2*8GB | Asus Z87-A Mainboard | BenQ Zowie XL2730 2560*1440@144Hz | Logitech G25 | Natural Point Track IR4 | Playseats Evolution

  3. #3
    Kart Driver
    Join Date
    Sep 2017
    Posts
    6
    Platform
    PC
    Quote Originally Posted by Visceral_Syn View Post
    Ok, I see multiple options are all separated by comma's. But this still does not explain the AI in session, when AI should not be in session...
    Most likely it is due to this configuration in server.cfg

    // Race flags - bitfield consisting of many flags, the default is set like this:
    // ALLOW_CUSTOM_VEHICLE_SETUP (8) + ABS_ALLOWED (32) + SC_ALLOWED (64) + TCS_ALLOWED (128) + "
    // FORCE_SAME_VEHICLE_CLASS (512) + FILL_SESSION_WITH_AI (131072) + AUTO_START_ENGINE (524288) = 656106"
    // See /api/list/flags/session in HTTP API, or globals "lists.flags.session" or "SessionFlags" in Lua API for the full list.
    "Flags" : 656106,

  4. #4
    WMD Member
    Join Date
    Oct 2011
    Location
    Germany
    Posts
    21
    Try to use 524520 instead.

  5. #5
    Kart Driver Shooter80's Avatar
    Join Date
    Sep 2017
    Posts
    61
    Platform
    PC
    Quote Originally Posted by Visceral_Syn View Post
    What is the correct syntax, some lines end with a comma at the end, but not all. Also have a buncha AI in the server, when I have not specified in the flags to fill session with AI, gridsize and maxplayers is set to the same value. Have even attempted to use the sms_rotate script, and again not added FILL_SESSION_WITH_AI, flag, have used text and the value, still has AI in the session.
    I have the same problem, tried every combination of settings there is (even just using Flags : 24 and not using the sms_rotate at all). The strange thing is, that it adds 14 AI, in a 24 slot server, on a 32 slot track (Spa) so the numbers dont add up, and it doesnt always do it. If I enter the lobby and 'Vote To Start' with just me in it, I'm pretty much guaranteed 14 AI, but most (all) of the time that there are others in the lobby and we 'Vote To Start' then it doesn't add any.

    It also maybe only does it the first session after the server has been started, not sure about that, will post back if I spot a pattern.
    Drive it like you own it

  6. #6
    Kart Driver Minolin's Avatar
    Join Date
    Dec 2015
    Posts
    34
    Platform
    PC
    Have the same problem with this (and many other combinations) flag sequence:

    // FORCE_REALISTIC_DRIVING_AIDS = 16
    // FORCE_SAME_VEHICLE_CLASS = 512
    // MECHANICAL_FAILURES = 262144
    // AUTO_START_ENGINE = 524288
    // TIMED_RACE = 1048576
    // ONLINE_REPUTATION_ENABLED = 8388608
    "Flags" : 10224144,
    Also GridSize=MaxPlayers, according to the comments I read that the server wouldn't add AIs even if configured.
    "GridSize" : 16,
    "MaxPlayers" : 16,
    Not using sms_rotate in this scenario.

  7. #7
    Kart Driver Visceral_Syn's Avatar
    Join Date
    May 2015
    Location
    Memphis, TN
    Posts
    93
    Platform
    PC
    Testing with a configured sms_rotate...


    Intel i7 4770S@3.1Ghz | eVGA GTX 1080 | Crucial Ballistix 2*8GB | Asus Z87-A Mainboard | BenQ Zowie XL2730 2560*1440@144Hz | Logitech G25 | Natural Point Track IR4 | Playseats Evolution

  8. #8
    Kart Driver Visceral_Syn's Avatar
    Join Date
    May 2015
    Location
    Memphis, TN
    Posts
    93
    Platform
    PC
    So, added all lines for all 3 sessions, Practice, Qualify, Race, with weather for each. Lobby shows some other date I did not specify, and the weather I specify. Not only is there STILL AI in the session its using weather from god only knows. Man, documentation goes a loooong way...


    Intel i7 4770S@3.1Ghz | eVGA GTX 1080 | Crucial Ballistix 2*8GB | Asus Z87-A Mainboard | BenQ Zowie XL2730 2560*1440@144Hz | Logitech G25 | Natural Point Track IR4 | Playseats Evolution
    The following user likes this Post: Marlborofranz


  9. #9
    Kart Driver Visceral_Syn's Avatar
    Join Date
    May 2015
    Location
    Memphis, TN
    Posts
    93
    Platform
    PC
    Unless I'm mistaken, if sms_rotate is configured, it also overrides the server.cfg session attributes section ?


    Intel i7 4770S@3.1Ghz | eVGA GTX 1080 | Crucial Ballistix 2*8GB | Asus Z87-A Mainboard | BenQ Zowie XL2730 2560*1440@144Hz | Logitech G25 | Natural Point Track IR4 | Playseats Evolution

  10. #10
    Kart Driver Shooter80's Avatar
    Join Date
    Sep 2017
    Posts
    61
    Platform
    PC
    I'm pretty convinced its not a configuration problem. I've even tried with Flags : 24 and enableLuaApi : false and it still usually (but not always) adds 14 AI.

    Seems its broken, and needs patched.


    EDIT: Yes, as I understand it the contents of sms_rotate_config.json override the sessionAttributes settings in server.cfg, with the (supposedly) added bonus of allowing you to use strings instead of enums or bitfield flags and being able to auto-rotate settings.
    Last edited by Shooter80; 23-09-2017 at 16:10.
    Drive it like you own it

Similar Threads

  1. Replies: 21
    Last Post: 03-10-2017, 19:42
  2. Ho do you setup a pCars2 server on a Dedicated server?
    By Ross Hawkey in forum Multiplayer
    Replies: 8
    Last Post: 23-09-2017, 07:08
  3. Replies: 8
    Last Post: 25-04-2017, 23:52
  4. Dedicated Server - server.cfg & LUA Rotate
    By KAMPFBIBER81 in forum Multiplayer
    Replies: 13
    Last Post: 21-02-2017, 10:37
  5. Replies: 12
    Last Post: 23-10-2015, 21:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •