Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 39

Thread: Crossfire not working.

  1. #21
    Kart Driver
    Join Date
    Jun 2015
    Location
    Cornwall
    Posts
    88
    Platform
    PC
    oh and I now get a 25-30 second blank screen before the Bandai logo comes up.

  2. #22
    Superkart Pilot
    Join Date
    Jul 2012
    Posts
    148
    Nice you got it to work ;-)

    I too see a delay before the Bandai logo sometimes ( it is not consistent curiously but I guess it feels more like a 3-5sec delay).

    When I have a system that runs stable I tend not to touch a thing and jynx it, so I am waiting until a real confirmed final fix from AMD / SMS is provided for the remaining graphics related issues.
    Crossfire works like a peach here now ( also in Assetto Corsa rock solid for long endurance races without a hitch).
    This 17.9.2 driver gave me a lot of peformance I did not ejoy before (about 10-15 more FPS in AC, so I can run all graphics settings there now on max and it runs pretty stable FPS wise in PC2 - only the shadow and reflection flickering is remaining).
    Asus ROG 370E Gaming | Intel i7 8700K | 32GB Kingston HyperX 3600 | Asus ROG Strix 1080 Ti | Win 10 64-bit | 5760 x 1080 @ 60 Hz | Triple Screen
    The following user likes this Post: Mattyd


  3. #23
    Kart Driver zbran's Avatar
    Join Date
    Jan 2017
    Location
    Earth
    Posts
    39
    Platform
    PC
    Quote Originally Posted by Mattyd View Post
    I have it! at least for my system.

    I basically followed menos instructions, although I had to find the 17.9.2 driver install package from the AMD folder on my boot drive as the only ones available from AMD are 17.7.2 and 17.9.3 which didn't seem to work. Also running the 4.4.0 msi AB version.

    I run the game from a shortcut on my desktop to the pcars2.exe in the steamapps folder because the crimson software doesn't seem to load the game profile if I run from the steam shortcut.

    When running the game I noticed that it was actually running the pcarsavx file from the steamapps folder.

    I browsed for that file through the crimson software, and set that to run the AMD Prefined profile in Crossfire Mode for Project Cars 2 and now it works.

    Thanks menos for your run through, I would not have got this working without you.

    Hey Mattyd, glad to see you have xfire working now, awesome . So 'I've been looking at what you and menos have done to try find a solution for me. I can do what menos has suggested i.e stripping out the drivers, as I don't run an overclock I assume I can ignore the AB steps?

    I'm struggling with what you have done, would it be possible to tell me what you did in

    *Simple

    *Idiot proof

    *Bullet point instructions?

    I have the 17.9.2 drivers. Can you just clarify what exactly you did here.


    "I run the game from a shortcut on my desktop to the pcars2.exe in the steamapps folder because the crimson software doesn't seem to load the game profile if I run from the steam shortcut."


    And here too please.


    "When running the game I noticed that it was actually running the pcarsavx file from the steamapps folder.

    I browsed for that file through the crimson software, and set that to run the AMD Prefined profile in Crossfire Mode for Project Cars 2 and now it works."


    If you could help me that would be great, I can't wait to play PC2 with crossfire! I've not played much as I've been waiting for a fix, still on the Ginetta Junior :-(

  4. #24
    Kart Driver zbran's Avatar
    Join Date
    Jan 2017
    Location
    Earth
    Posts
    39
    Platform
    PC
    Haha, ok you can forget my last post. I've got it working! I can confirm xfire works on the 17.9.3 drivers.

    All I did was.

    *Create a desktop shortcut for PC2

    *open Crimson

    *Click global settings and click on the PC2 profile

    *Click crossfire and then select "user pre defined profile"

    *In there I found the PC2 profile, clicked that, boom cross fire

    Thanks for the help guys.

    I'm not sure if I can mark this thread as solved.

  5. #25
    Superkart Pilot
    Join Date
    Jul 2012
    Posts
    148
    Quote Originally Posted by zbran View Post
    Hey Mattyd, glad to see you have xfire working now, awesome . So 'I've been looking at what you and menos have done to try find a solution for me. I can do what menos has suggested i.e stripping out the drivers, as I don't run an overclock I assume I can ignore the AB steps?

    I'm struggling with what you have done, would it be possible to tell me what you did in

    *Simple

    *Idiot proof

    *Bullet point instructions?

    I have the 17.9.2 drivers. Can you just clarify what exactly you did here.


    "I run the game from a shortcut on my desktop to the pcars2.exe in the steamapps folder because the crimson software doesn't seem to load the game profile if I run from the steam shortcut."


    And here too please.


    "When running the game I noticed that it was actually running the pcarsavx file from the steamapps folder.

    I browsed for that file through the crimson software, and set that to run the AMD Prefined profile in Crossfire Mode for Project Cars 2 and now it works."


    If you could help me that would be great, I can't wait to play PC2 with crossfire! I've not played much as I've been waiting for a fix, still on the Ginetta Junior :-(
    If the clean installation (clean means to remove ANY traces of AMD drivers from your computer by using DDU in safe mode) of v17.9.2 AMD driver software and the selection of AMDs Cars 2 crossfire profile is not working, your best choice to get crossfire to run is using MSI AB.

    You do not have to overclock your GPUs using MSI AB, it offers that just as an option next to it's other very handy tools.

    I found it critical to get crossfire to run stable to use the ULPS disable option in MSI AB and use their unofficial overclocking mode (without using these two options both GPUs would be used improperly).

    I have now a dead stable crossfire with both GPUs constantly at their full clock speed in 3D rendering and utilized well above 90% when stressed.

    As Cars 2 currently does not allow for restraining the GPUs when not rendering 3D, you have to use the Steam FPS limiter option to limit the FPS to a reasonable value, otherwise the GPUs will render the menu system with an excessive frame rate with no benefit at all, while cooking the GPUs.

    Again, if the AMD crossfire profile for Cars 2 is not working for you, reinstall the 17.9.3 driver again after cleaning AMD drivers with DDU in safe mode. If that is not working, try the approach of combining AMD v 17.9.2 + MSI AB as described earlier.

    Also, check your Windows energy profile settings, make sure any GPU related energy saving modes are set to OFF (Windows / AMD drivers will lower GPU clock to conserve energy, which is very buggy with some games and crossfire).
    Asus ROG 370E Gaming | Intel i7 8700K | 32GB Kingston HyperX 3600 | Asus ROG Strix 1080 Ti | Win 10 64-bit | 5760 x 1080 @ 60 Hz | Triple Screen

  6. #26
    Superkart Pilot
    Join Date
    Jul 2012
    Posts
    148
    As a heads up, the latest driver available to me 17.10.1 will break crossfire with Project Cars 2.
    I could not get proper GPU saturation on both GPUs but most importantly this driver broke the ability to overclock with MSI AB, leaving both GPUs to run at absolute base clock speed (resulting in overall frame rates below 10 FPS).

    I rolled back to 17.9.3 in combination with the latest MSI AB.

    Currently I only use Project Cars 2 with crossfire DISABLED as it does have severe flickering issues of reflection textures and in some cases the entire screen with crossfire.
    With crossfire disabled the image is stable without flickering but it results in about half the frame rate :-(

    I hope SMS + AMD can find a fix here ASAP. Currently it is barely usable.
    Asus ROG 370E Gaming | Intel i7 8700K | 32GB Kingston HyperX 3600 | Asus ROG Strix 1080 Ti | Win 10 64-bit | 5760 x 1080 @ 60 Hz | Triple Screen

  7. #27
    Kart Driver
    Join Date
    Jun 2017
    Posts
    64
    Platform
    PC
    I have two Vega 64's in my machine and now pcars2 crashes on load of race screen every time. I've never played with crossfire at all and don't need it so need to figure out how to disable it. I set EnableCrossFireAutoLink to 0 in registry for both cars hoping that would help but pcars2 still crashes. Guess I'll play with the amd utility ccc which I have never touched next. I don't need both cards working for pcars2 as the vega 64 is beefy enough for only one to do the job. I only have two of them in there for when a reboot to another windows install for some computing i have the machine doing when not playing games. Anyone else seen something like this? I don't want to have to remove one of the cards just to play games as that would suck.

  8. #28
    Superkart Pilot
    Join Date
    Jul 2012
    Posts
    148
    Quote Originally Posted by rpstar View Post
    I have two Vega 64's in my machine and now pcars2 crashes on load of race screen every time. I've never played with crossfire at all and don't need it so need to figure out how to disable it. I set EnableCrossFireAutoLink to 0 in registry for both cars hoping that would help but pcars2 still crashes. Guess I'll play with the amd utility ccc which I have never touched next. I don't need both cards working for pcars2 as the vega 64 is beefy enough for only one to do the job. I only have two of them in there for when a reboot to another windows install for some computing i have the machine doing when not playing games. Anyone else seen something like this? I don't want to have to remove one of the cards just to play games as that would suck.
    1. make a bug report in the proper forum section regarding your crash to desktop issue - this way you get the best help for this specific individual issue (it may very well not be related to X-fire at all), it is therefore not buried in a X-fire specific thread here
    2. for anything X-fire related (want to switch X-fire on/off, choose specific profiles, clock speeds, …) you ABSOLUTELY MUST enforce this either within the driver control center (as AMD has designed it) or use a third party tool that does essentially the same as the driver control center but does allow more freedom and additional features

    The best way to enable/disable X-Fire is to open your driver control center, create a game profile for Project Cars 2 (I simply usually click on add profile and click on "scan" - it will automatically find Project Cars 2).
    Now adjust what you like to enforce in the profile (I usually only disable texture optimization, choose the highest texture quality and choose the best working X-fire setting - on my system "1x1 optimized" works best with Project Cars 2).

    Now it is best you make sure that the settings you have changed will actually be used in the game - for this I use MSI AB to display relevant data while in 3D render (clock speeds, GPU usage, temperatures, …).
    This way you verify that X-fire is actually working as it should.

    Currently (since patch 1.3 or thereabouts) X-fire works reasonably well in terms of performance.
    The major issue I still have with Project Cars 2 is texture, reflection and shadow flickering - this shows at it's worst with all mirrors in the cockpit flickering (looks like Z-fighting). This is not happening all the time any more just about 50% of the time (once you enter a session and mirror flickering is there, it will be there for the entire session). Sometimes you get lucky and it isn't there and the session stays free from flickering - if you watch an instant replay it sometimes occurs after that again - it's very buggy.
    Asus ROG 370E Gaming | Intel i7 8700K | 32GB Kingston HyperX 3600 | Asus ROG Strix 1080 Ti | Win 10 64-bit | 5760 x 1080 @ 60 Hz | Triple Screen

  9. #29
    Kart Driver
    Join Date
    Jun 2017
    Posts
    64
    Platform
    PC
    Quote Originally Posted by menos View Post
    1. make a bug report in the proper forum section regarding your crash to desktop issue - this way you get the best help for this specific individual issue (it may very well not be related to X-fire at all), it is therefore not buried in a X-fire specific thread here
    2. for anything X-fire related (want to switch X-fire on/off, choose specific profiles, clock speeds, ) you ABSOLUTELY MUST enforce this either within the driver control center (as AMD has designed it) or use a third party tool that does essentially the same as the driver control center but does allow more freedom and additional features
    .
    Thank you so much for the help. I did not realize there was a control center. Went there, tried the 1x1 but still crashes. Then just punted and did disable Xfire for Pcars 2 and it's back up and running stellarly as before. I don't really need Xfire anyways with Vega 64's (at least with my VR and the 2560x1440 monitor). The two cards are there just for when I reboot into compute mode when not gaming.

    Thanks again. I might at some point play around to see if I can get xfire working but not much of a hurry given don't seem to need it. ( really should not with a freaking $700 video card after all )

  10. #30
    Superkart Pilot
    Join Date
    Jul 2012
    Posts
    148
    Thats great! I am happy it works for you now!
    Asus ROG 370E Gaming | Intel i7 8700K | 32GB Kingston HyperX 3600 | Asus ROG Strix 1080 Ti | Win 10 64-bit | 5760 x 1080 @ 60 Hz | Triple Screen

Similar Threads

  1. AMD R9-290 Crossfire still not working?! How to enable?
    By David Spacek in forum PC - Technical Help & Support
    Replies: 1
    Last Post: 07-05-2017, 14:55
  2. anyone crossfire with 2R9290 oc
    By Inkabodpain in forum PC - Technical Help & Support
    Replies: 2
    Last Post: 06-11-2015, 01:13
  3. Irregular crossfire usage
    By LooneyJuice in forum Virtual Reality Devices Support
    Replies: 12
    Last Post: 20-08-2015, 00:30
  4. Anyone running crossfire with windows 10?
    By doctharock in forum PC - Technical Help & Support
    Replies: 0
    Last Post: 11-06-2015, 18:05
  5. FPS problem with R9 290 Crossfire...
    By w4rell in forum PC - Technical Help & Support
    Replies: 13
    Last Post: 17-05-2015, 12:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •