Results 1 to 2 of 2

Thread: Multiple Inputs Thrustmaster TS-PC Fanatec V3 Pedals

  1. #1
    Rookie
    Join Date
    Mar 2020
    Posts
    1
    Platform
    PC

    Multiple Inputs Thrustmaster TS-PC Fanatec V3 Pedals

    Hi All - Help Needed Please

    I have a TS-PC Thrustmaster wheel with Fanatec V3 pedals. Platform is PC.

    Works fine on a couple of other platforms.

    Game wants to use same input for steer right & throttle.
    When I first accessed the controller screen it recogises the correct wheel, pedals are separate. Wheel calibrates fine but at this stage doesn't calibrate pedals
    When I first go to edit assignments it is as follows
    Steer Left Joy Axis -X
    Steer Right Joy Axis +X
    Throttle Joy Axis -RZ
    Brake Joy Axis -Y

    With these current setting there is no throttle when i go to a race.

    When I edit the throttle assignment it wants to use the same input as Steer Right +X but then it allows me to calibrate the pedals where it didn't whilst being -RZ. The throttle cuts out as soon as I turn right.

    I did notice in the Thrustmaster control panel page that for combined pedals for "Gas" it has an Axis of RZ. The pedal section is ticked as separate.

    To date I have
    uninstalled & reinstalled game
    Deleted controller settings file & started game back up numerous time
    Have Pedals as separate in game / tried as combined as well in game
    Tried different USB ports

    Many thanks

  2. #2
    WMD Member Mad Al's Avatar
    Join Date
    Nov 2011
    Location
    Suffolk, England
    Posts
    3,350
    delete the controller config.

    start the game, check it's picked the correct wheel, set seperate pedals and assign throttle, brake and clutch...

    Don't calibrate, just try driving.

    Ryzen R7 3800X - Gigabyte X570 Aorus Elite - 16Gig DDR4 (Ballistix Elite 3600) - ZOTAC GTX1080Ti FE with EVGA Hybrid Cooler - iiiyama ProLite B2783QSU - Oculus Rift CV1 - Samsung 860 250G SSD, WD 6T Black, WD 2T Black, OCZ 120G Vertex 2 SSD, LiteOn iHAS122 DVD-RW - Creative 5.1 speaker system - Logitech G19 - Gigabyte GM-M6880X Gaming Mouse - Fanatec GT3 RS V2 + CSP V3 + SSH Shifter - Windows 10 Pro (64 bit).

    Second machine used for additional testing. Ryzen R5 3600X - Asus Prime X570-P - 16G DDR4 (Crucial Ballistix 3200) - EVGA RTX2060 - iiyama Prolite E2607WS - Oculus Rift CV1 - W10 Pro (64 bit) - xbox360 pad or Logitech DFP (all at stock speeds)

    HTPC - For testing of Steam Big Picture Mode (Hopefully from Media Portal 2) - i5-4590S - ASUS H81M-C - 8G DDR3 PC-10666 - Gigabyte GTX1050Ti - Windows 10 Home (64 bit) - xbox360 pad

    YouTube channel - My attempt at a PC2 Career - a work in progress! - Trying other other racing content

Similar Threads

  1. Replies: 27
    Last Post: 24-01-2020, 21:08
  2. Multiple Inputs Were Assigned
    By JughedJones in forum Technical Help & Support (PC)
    Replies: 2
    Last Post: 22-09-2017, 19:32
  3. multiple inputs detected steering wheel thrustmaster trs 500
    By jafo0709 in forum PC - Technical Help & Support
    Replies: 1
    Last Post: 02-04-2017, 18:35
  4. Multiple key inputs
    By Sp4mD4gger in forum XB1 - Technical Help & Support
    Replies: 0
    Last Post: 22-07-2015, 14:10
  5. Multiple Inputs Detected - G27
    By kalay in forum PC - Technical Help & Support
    Replies: 14
    Last Post: 04-07-2015, 12:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •