Page 10 of 10 FirstFirst ... 8910
Results 91 to 92 of 92

Thread: Dedicated Server Configuration - Sample - Weather + MultiClass REALLY FIXED! -2/25/18

  1. #91
    Kart Driver Rodgorth's Avatar
    Join Date
    Sep 2017
    Location
    Moscow
    Posts
    18
    Platform
    PC
    Hey guys,

    Having some troubles launching dedicated server under linux VM.
    The setup is pretty much default.

    Done the following steps:

    1) Installed Linux Mint MATE x64 on a VM
    2) Installed SteamCMD with 32bit libraries as per the DS instructions
    3) Installed Dedicated Server app
    4) Got the server.cfg from sample folder, placed it in root DS folder. Modified it a bit - changed server name, pass, disabled lua addons for now

    But the server fails to start (debug log is below).
    The VM does have the access to internet. Port forward is set-up on the router-side.
    I've disabled the Firewall completely. Checked if any other app uses the ports.

    Any thoughts on where shall I dig for the cause?
    Thanks!

    Code:
    //#########################################################
    
    [Session][Log] dbgsession/dbg 2019-06-05 @ 10.31.29/dedicatedserver.log
    
    [Session][ID] 02f0-7e36-2a9f-766d
    
    [Session][Platform] Linux
    
    [Session][Config] Release
    
    [Session][Exe] /home/steam/PCars2DS/DedicatedServerCmd.elf
    
    [Session][ExeBit] 64
    
    [Session][Date] 05/06/2019
    
    [Session][Time] 10:31:29
    
    [Session][Exe Built] Unknown
    
    [Session][Machine] Unknown
    
    [Session][GCC Version] 4.8.2
    
    [Session][Toolset] x86_64-pc-linux-gnu.GCC.4.8.2
    
    [Session][Title]
    
    [Session][BuildVer]
    
    [Session][BuildVerInt] 0
    
    [Session][BuildVerUnmod]
    
    [Session][BuildVerSimple]
    
    [Session][BuildVerInject]
    
    [Session][BuildVerInjSim]
    
    [Session][BaseVer] v1.5.946.0
    
    //#########################################################
    
    [10:31:29:625][0x9a359740] [Info ] [BLogBase::Init] [Internal] Initialised Log
    
    [10:31:29:630][0x9a359740] [Info ] [void NativeLogCallback] [General] Starting up the Dedicated Server Library.
    
    [10:31:29:631][0x9a359740] [Info ] [void NativeLogCallback] [General] Server configuration loaded:
    
    - server build version: 1
    
    - protocol version: 64 (1.0.0.64)
    
    - server name: TestyTest
    
    - max session size: 26
    
    - details: secure, bind IP INADDR_ANY, Steam port 8766, host port 27015, query port 27016, password protected yes
    
    - whitelist size: 0
    
    - blacklist size: 0
    
    - lua api: disabled
    
    - http api: disabled
    
    - allow empty join: enabled
    
    - game setup control: disabled
    
    - sports play : disabled
    
    [10:31:29:682][0x9a359740] [ERROR] [void NativeLogCallback] [General] SteamGameServer_Init failed
    
    [10:31:29:682][0x9a359740] [ERROR] [void NativeLogCallback] [General] Dedicated Server startup failed
    
    [10:31:29:682][0x9a359740] [Info ] [BLogBase::Term] [Internal] Terminating Log

  2. #92
    Rookie
    Join Date
    Jun 2019
    Posts
    1
    Platform
    PC
    Thanks for share. I seen your post and i resolv my problem.

Similar Threads

  1. Replies: 6
    Last Post: 09-05-2019, 01:21
  2. Dedicated Server configuration
    By Visceral_Syn in forum Multiplayer
    Replies: 330
    Last Post: 12-10-2018, 21:09
  3. Replies: 21
    Last Post: 03-10-2017, 19:42
  4. Replies: 8
    Last Post: 25-04-2017, 23:52
  5. Replies: 12
    Last Post: 23-10-2015, 21:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •