Results 1 to 10 of 10

Thread: Trouble hosting DS at LAN

  1. #1
    Kart Driver
    Join Date
    Dec 2017
    Posts
    6
    Platform
    PC

    Trouble hosting DS at LAN

    Hi everyone,
    got some trouble hosting a (offline) dedicated server...

    With "sports play: false" my dedicate server starts fine, it shows up on all connected engines in steam -> servers view.
    I also can join, host,... games on it. But of course its only working with an internet connection.

    If I enable sports play the dedicated server gets stuck at "[2017-12-25 01:23:45] INFO: Dedicated server is starting..." - no matter if theres an online connection.
    Followed by a warning, everytime if I refresh the steam LAN servers list on any network device.
    [2017-12-25 01:25:59] WARNING: Failed to parse incoming p2p packet from 8462073849389776895, size 17 - unknown message kind 114 set



    Ports are free to use at the firewall settings, also tried various server.cfgs.
    Always the same, all get stuck at starting on LAN mode.

    Any ideas? Did I get something wrong?

    greetings/regards
    Ce

  2. #2
    Superkart Pilot Visceral_Syn's Avatar
    Join Date
    May 2015
    Location
    Memphis, TN
    Posts
    202
    Platform
    PC
    I got the failed to parse incoming P2P, when the LAN server was an older version, than the client. Also you must use the -sportsplay commandline for the client to see that server ingame.
    Game-Rig: Intel i7 4770S | eVGA GTX 1080 | 16GB Crucial Ballistix | Asus Z87-A | BenQ Zowie XL2730 | Microsoft Windows 10 | Logitech z5500 5.1 Digital | Thrustmaster TS-PC | Thrustmaster T3PA-Pro | Thrustmaster TH8A | Natural Point Track IR 4 | Playseats Evolution
    Server: Intel L5639 Xeon | Asus P6T | 12GB Corsair Vengeance | 128GB Crucial SSD | CentOS 7.4 | Linux Kernel 4.14 | pCars˛ Dedicated Server: Beale St. Blues | Steam: Visceral_Syn


  3. #3
    Superkart Pilot Rodders's Avatar
    Join Date
    Dec 2015
    Posts
    517
    Platform
    PC
    I run a dedi from my house but have noticed that when I connect via the in game lobby, just as I would any other MP server, my ping is about 5ms to everyone else’s 20 to whatever. From this it looks like I am connecting over the lan to the server. I never took any steps to make the server a LAN one.

    So my suggestion would be to make sure there is an internet connection available on your LAN then just have everyone connect in the normal way via the lobby and it might auto connect everyone over the LAN.

    If that doesn’t work it might just be I’m connecting over the net on a very short route as I have FTTP and an extremely good internet connection (many in the UK get 15-30ms ping times when connected to my server). I’d need to run a trace route to see how few hops I’m taking.

  4. #4
    Kart Driver
    Join Date
    Dec 2017
    Posts
    6
    Platform
    PC
    Thats happening on almost any dedicated server in almost amy type of game - or may say, thats what DS are made for.
    Hosting games without connecting to offical server.
    If you run the server on your local network ofcourse you connect via LAN, theres no reason to communicate to it via internet, since you create a direct connection to the server.

    In case of pCars2 it's just a lil different, the dedicated server connects to Steam to show up in public lists, also may some kind of anti piracy stuff.
    Thats the point my DS is failing on LAN mode, even if there's an internet connection it gets stuck at starting.

    Also a normal DS works in LAN for some time if you cut down the internet connection, just until the next data-update-whatever ping to steam, or wherever, gets no response and the DS shuts down.

    Quote Originally Posted by Visceral_Syn View Post
    I got the failed to parse incoming P2P, when the LAN server was an older version, than the client. Also you must use the -sportsplay commandline for the client to see that server ingame.
    Since the server doesn't even start I guess the client version doesn't even matter.
    And also, as said, I can connect to it on internet mode.



    Getting a good working internetconnection there would be bumpy as hell or almost impossible, since we'd need about 2-3 wlan repeaters of a few hundred meters cable.
    So we decided to f* that and playing a LAN like in the late 90s.
    Last edited by .cee.; 25-12-2017 at 13:01.

  5. #5
    Superkart Pilot Visceral_Syn's Avatar
    Join Date
    May 2015
    Location
    Memphis, TN
    Posts
    202
    Platform
    PC
    pCars˛ multiplayer is provided by Steamworks. What I've not tried to do is launch steam in offline mode to see if the LAN server lists. What I did do, was enable sportsplay on my LAN server, and added -sportsplay to my client commandline. When I launched client, then go to servers, I can then see the LAN server to connect to it. Otherwise without the -sportsplay commandline parameter, the client never finds the server.

    When I had forgotten to update the LAN server, the client preety much stays up to date, i got the failed to parse incoming P2P error.

    And if I remember right, if you attempt to connect to any internet server, with the -sportsplay commandline parameter in place, pCars˛ poops itself, sideways...
    Last edited by Visceral_Syn; 25-12-2017 at 14:25. Reason: added some more stuffs...
    Game-Rig: Intel i7 4770S | eVGA GTX 1080 | 16GB Crucial Ballistix | Asus Z87-A | BenQ Zowie XL2730 | Microsoft Windows 10 | Logitech z5500 5.1 Digital | Thrustmaster TS-PC | Thrustmaster T3PA-Pro | Thrustmaster TH8A | Natural Point Track IR 4 | Playseats Evolution
    Server: Intel L5639 Xeon | Asus P6T | 12GB Corsair Vengeance | 128GB Crucial SSD | CentOS 7.4 | Linux Kernel 4.14 | pCars˛ Dedicated Server: Beale St. Blues | Steam: Visceral_Syn


  6. #6
    Kart Driver
    Join Date
    Dec 2017
    Posts
    6
    Platform
    PC
    And once again...
    The client has absolutly nothing to do with it. So optional starting commands are way more than optional at this point.
    Or in other words, doesn't matter what I do, the server will never show up to the client / steam overviews, since there is no server running.
    The DS itself gets stuck on LAN mode / sportsplay and never switches to a running state.

    also there should be no internet connection needed by the sportsplay description itself
    "Recommended for offline LAN-only events."

  7. #7
    Superkart Pilot Visceral_Syn's Avatar
    Join Date
    May 2015
    Location
    Memphis, TN
    Posts
    202
    Platform
    PC
    and once again, pCars˛ multiplayer is provided by Steamworks. For the DS to not uplink to the master server, sportsplay must be enabled in the DS configuration. For a client to see the server in LAN, must have the -sportsplay commandline parameter added. If you have actually done this, you'd know. And if the server is not the most recent version, the client can't see the server.
    Game-Rig: Intel i7 4770S | eVGA GTX 1080 | 16GB Crucial Ballistix | Asus Z87-A | BenQ Zowie XL2730 | Microsoft Windows 10 | Logitech z5500 5.1 Digital | Thrustmaster TS-PC | Thrustmaster T3PA-Pro | Thrustmaster TH8A | Natural Point Track IR 4 | Playseats Evolution
    Server: Intel L5639 Xeon | Asus P6T | 12GB Corsair Vengeance | 128GB Crucial SSD | CentOS 7.4 | Linux Kernel 4.14 | pCars˛ Dedicated Server: Beale St. Blues | Steam: Visceral_Syn


  8. #8
    Kart Driver
    Join Date
    Dec 2017
    Posts
    6
    Platform
    PC
    Dont get me wrong, I'm happy someone is willing to help, but the problem is not finding my server, the problem is getting the server running at all - so it should have nothing to do with clients settings.

    Sportsplay disabled: it starts, it runs, I find it, I can host games on it, it runs for hours.
    Sportsplay eabled: DS getting stuck in starting and generating fails if I check for LAN Servers.

    Also the DS should be latest, since I redownloaded and reinstalled it a couple times

  9. #9
    Superkart Pilot Visceral_Syn's Avatar
    Join Date
    May 2015
    Location
    Memphis, TN
    Posts
    202
    Platform
    PC
    Uninstall the LAN DS, reinstall it. Ensure to enable sportsplay in the server.cfg. For testing purposes, only configure the server.cfg, so comment out the rotation lua script.

    Sadly, reinstalling the DS has made it work for one other person I was helping.

    SMS also did release an update for the DS on like the 20th of December. With little to no fanfare, I updated my DS, but not my LAN DS. Will update it soon... I think, I have not been using my LAN DS very much lately.
    Last edited by Visceral_Syn; 25-12-2017 at 16:25.
    Game-Rig: Intel i7 4770S | eVGA GTX 1080 | 16GB Crucial Ballistix | Asus Z87-A | BenQ Zowie XL2730 | Microsoft Windows 10 | Logitech z5500 5.1 Digital | Thrustmaster TS-PC | Thrustmaster T3PA-Pro | Thrustmaster TH8A | Natural Point Track IR 4 | Playseats Evolution
    Server: Intel L5639 Xeon | Asus P6T | 12GB Corsair Vengeance | 128GB Crucial SSD | CentOS 7.4 | Linux Kernel 4.14 | pCars˛ Dedicated Server: Beale St. Blues | Steam: Visceral_Syn


  10. #10
    Kart Driver
    Join Date
    Dec 2017
    Posts
    6
    Platform
    PC
    Couple reinstalls and new configs later...
    Seems to work now.
    The following user likes this Post: Visceral_Syn


Similar Threads

  1. Server Hosting Vendors
    By DoctorKajita in forum Multiplayer
    Replies: 13
    Last Post: 15-02-2017, 00:50
  2. QoS and Hosting/Playing Pcars
    By Saloei in forum General Discussion
    Replies: 2
    Last Post: 05-11-2016, 02:43
  3. UK Lobby Hosting
    By TheBobbyTee in forum Multiplayer
    Replies: 0
    Last Post: 18-09-2016, 12:38
  4. Low FPS when hosting a Race
    By kidcurry in forum PC - Technical Help & Support
    Replies: 0
    Last Post: 08-10-2015, 04:07
  5. I'm Hosting a Series
    By STaLLiOnO in forum PS4 - Multiplayer Event Planning
    Replies: 4
    Last Post: 08-06-2015, 12:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •