Results 1 to 7 of 7

Thread: Logitech Driving force pro worked for about 2 hours then i messed it up somehow.Help!

  1. #1
    Kart Driver
    Join Date
    Dec 2017
    Posts
    5
    Platform
    PC

    Logitech Driving force pro worked for about 2 hours then i messed it up somehow.Help!

    Ok so im sorry but i actually dont own this game but i have no where else to ask this. I got this wheel at a goodwill for $20 like 2 days ago and it was working great but i plugged it into my PC just fine and it was working but 900 degree turning wasnt on and neither was forcefeedback. After downloading the Driver and doing a button combination (R3, Select, Left paddle shifter) it switched between 200 and 900 degree turning. but THEN i decided to be a ♥♥♥♥up and decide to do (R3,Select,Right paddleshifter) and after doing that my wheel only turns all the way to the right and wont turn to the left when it calibrates and now both LED lights are blinking green at the same time and no buttons are working. ANY help would be appreciated. Also im on windows 10. and i tried to delete the drivers and redownload them but it didnt work the first time. i might do it again. any suggestions? Im at my wits end here.
    Do you think its a broken encoder? but even if it was it would still work a little bit right? i mean NOTHING works. at all. Its being detected in windows i think but thats about it. I just got this like a day ago
    Oh and i just found out that when i plug it into other USB sockets the lights dont blink at the same time but at different times.
    I just wanna go go back to how it was before

  2. #2
    WMD Member Mad Al's Avatar
    Join Date
    Nov 2011
    Location
    Suffolk, England
    Posts
    2,564
    It should be R3, select, right paddle to swap 900/200 mode, left paddle should set 100% FFB (not that I ever remember doing that?)

    blinking leds mean the calibration failed

    You may need to take the top off and check it is moving correctly
    https://www.youtube.com/watch?v=ibUxmxI9SJ4

    most problems seem to come from the mechanism that swaps between modes, which is driven by a second small motor
    https://www.youtube.com/watch?v=WDwQEPt6Wv8

    i7 4770K - ASUS Z87-A - 16Gig DDR3 (2x 8G Crucial Ballistix PC3-12800) - ZOTAC GTX1080Ti FE with EVGA Hybrid Cooler - iiiyama ProLite B2783QSU - Oculus Rift CV1 - Samsung 840 250G SSD , WD 320G Blue, WD 2T Black, OCZ 120G Vertex 2 SSD, LiteOn iHAS122 DVD-RW - Creative Audigy 4 - Creative 5.1 speaker system - Logitech G19 - MS HABU Gaming Mouse - Fanatec GT3 RS V2 + CSP V3 + SSH Shifter - Windows 10 Home (64 bit).

    Second machine used for additional testing. i7-4790T - Asus H97-Plus - 16G DDR3 PC-12800 - Gigabyte GTX1060 - iiyama Prolite E2607WS - Oculus Rift CV1 - W10 Pro (64 bit) - xbox360 pad or Logitech DFP (all at stock speeds)

    HTPC - For testing of Steam Big Picture Mode (Hopefully from Media Portal 2) - i5-4590S - ASUS H81M-C - 8G DDR3 PC-10666 - Gigabyte GTX1050Ti - Windows 10 Home (64 bit) - xbox360 pad

  3. #3
    Kart Driver
    Join Date
    Dec 2017
    Posts
    5
    Platform
    PC
    If I take off the backplate can I reattach my shifter? I really like it. Also the second video seems to be my problem actually. But mines doing something a bit different. After the failed calibration it just goes stays there and blinking and no buttons work. Thank you for your help. But again can I reattach my shifter without too much trouble?

  4. #4
    Kart Driver
    Join Date
    Dec 2017
    Posts
    5
    Platform
    PC
    Quote Originally Posted by Mad Al View Post
    It should be R3, select, right paddle to swap 900/200 mode, left paddle should set 100% FFB (not that I ever remember doing that?)

    blinking leds mean the calibration failed

    You may need to take the top off and check it is moving correctly

    most problems seem to come from the mechanism that swaps between modes, which is driven by a second small motor
    . If I take off the backplate can I reattach my shifter? I really like it. Also the second video seems to be my problem actually. But mines doing something a bit different. After the failed calibration it just goes stays there and blinking and no buttons work. Thank you for your help. But again can I reattach my shifter without too much trouble? Also sorry for quoting and all that im not sure how forum posting goes im new here

  5. #5
    WMD Member Mad Al's Avatar
    Join Date
    Nov 2011
    Location
    Suffolk, England
    Posts
    2,564
    Not sure what you mean, but I suspect the shifter is attached to the casing so you would have to reassemble the casing to get it working. Have a check on youtube, you will find a few other videos of different failures which may lead you to a more complete answer... but the main failure appears to be the 900/200 switch mechanism and the way to fix it is to make a way to move it manually with a lever or rod passing through the casing (detaching the return spring first). It might be possible to replace the small motor (if you could find the make and model), if you have the right tools for the job

    i7 4770K - ASUS Z87-A - 16Gig DDR3 (2x 8G Crucial Ballistix PC3-12800) - ZOTAC GTX1080Ti FE with EVGA Hybrid Cooler - iiiyama ProLite B2783QSU - Oculus Rift CV1 - Samsung 840 250G SSD , WD 320G Blue, WD 2T Black, OCZ 120G Vertex 2 SSD, LiteOn iHAS122 DVD-RW - Creative Audigy 4 - Creative 5.1 speaker system - Logitech G19 - MS HABU Gaming Mouse - Fanatec GT3 RS V2 + CSP V3 + SSH Shifter - Windows 10 Home (64 bit).

    Second machine used for additional testing. i7-4790T - Asus H97-Plus - 16G DDR3 PC-12800 - Gigabyte GTX1060 - iiyama Prolite E2607WS - Oculus Rift CV1 - W10 Pro (64 bit) - xbox360 pad or Logitech DFP (all at stock speeds)

    HTPC - For testing of Steam Big Picture Mode (Hopefully from Media Portal 2) - i5-4590S - ASUS H81M-C - 8G DDR3 PC-10666 - Gigabyte GTX1050Ti - Windows 10 Home (64 bit) - xbox360 pad

  6. #6
    Kart Driver
    Join Date
    Dec 2017
    Posts
    5
    Platform
    PC
    Quote Originally Posted by Mad Al View Post
    Not sure what you mean, but I suspect the shifter is attached to the casing so you would have to reassemble the casing to get it working. Have a check on youtube, you will find a few other videos of different failures which may lead you to a more complete answer... but the main failure appears to be the 900/200 switch mechanism and the way to fix it is to make a way to move it manually with a lever or rod passing through the casing (detaching the return spring first). It might be possible to replace the small motor (if you could find the make and model), if you have the right tools for the job
    I mean is it easy enough to reattach the casing? i dont have much tools aside from a few screwdrivers lying around. and im not replacing the motor. I think its the 900/200 switch causing my issues. Thanks for your help i really appreciate it

  7. #7
    Kart Driver
    Join Date
    Dec 2017
    Posts
    5
    Platform
    PC
    Quote Originally Posted by Mad Al View Post
    Not sure what you mean, but I suspect the shifter is attached to the casing so you would have to reassemble the casing to get it working. Have a check on youtube, you will find a few other videos of different failures which may lead you to a more complete answer... but the main failure appears to be the 900/200 switch mechanism and the way to fix it is to make a way to move it manually with a lever or rod passing through the casing (detaching the return spring first). It might be possible to replace the small motor (if you could find the make and model), if you have the right tools for the job
    Just wanted to say thanks because thanks to you i managed to fix my wheel and its working fantastic now! also happy new years
    The following 2 users likes this Post: Mad Al, Mahjik


Similar Threads

  1. Logitech Driving Force GT not working
    By Gotoxy in forum PC - Technical Help & Support
    Replies: 19
    Last Post: 16-01-2017, 08:34
  2. [RESOLVED] No Force Feedback on Logitech Driving Force Pro
    By Physalisfresser in forum PC - Technical Help & Support
    Replies: 3
    Last Post: 25-11-2016, 13:16
  3. Logitech Driving Force GT compatibility
    By akstirling in forum General Discussion
    Replies: 17
    Last Post: 20-08-2015, 02:31
  4. Logitech Driving force GT
    By fallendusrt in forum PC - Technical Help & Support
    Replies: 3
    Last Post: 14-06-2015, 10:18
  5. Logitech driving force pro GT
    By flovr6 in forum PC - Technical Help & Support
    Replies: 0
    Last Post: 12-05-2015, 21:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •