Results 1 to 3 of 3

Thread: Xbox One X - Low FPS and other issues

  1. #1
    Kart Driver
    Join Date
    Oct 2015
    Posts
    12
    Platform
    XBOX1

    Xbox One X - Low FPS and other issues

    Good Morning.

    During our championship(Last week) we have bugs with some players:

    - 3 players, including myself, time were not saved during qualify and race. I could see my time in my screen. But host were always seeing 00:00:00.
    - Without time during the qualify, i was moved to the end of grid.
    - During the race, without the time, i received the blue flag constantly.
    - In the end of the race, i didn't appear in the finish list.


    Just on my xbox X:
    - My FPS during the entire race/qualify was 20 FPS or below. This is not the first time and it's not related to the number of cars on the grid/weather(was summer/clear day). Even during my training sessions on the same track(Brands Hatch) and without IA/Opponents i had this issue. I can fix this as soon i restart the game.

    Marcelo

  2. #2
    Superkart Pilot
    Join Date
    Apr 2016
    Posts
    550
    Platform
    XBOX1 X
    The issue with the frame rate...It's happened to me twice, always playing single player. In bothe occasions I quit the race and went back to race central. I notice then that the menus were very slow and crancky as well. I quit the game back to the dashboard and upon restart everything was back to normal. Weird. Patch 4 will be out soon and there are a couple of things to improve performance on the X so fingers crossed.
    Xbox One X!
    The following 4 users likes this Post: alegunner68, marcelok, Nint, Roushman624


  3. #3
    Kart Driver
    Join Date
    Sep 2017
    Posts
    37
    Platform
    XBOX1
    Quote Originally Posted by marcelok View Post
    Just on my xbox X:
    - My FPS during the entire race/qualify was 20 FPS or below. This is not the first time and it's not related to the number of cars on the grid/weather(was summer/clear day). Even during my training sessions on the same track(Brands Hatch) and without IA/Opponents i had this issue. I can fix this as soon i restart the game.
    I think that happens if you quit to the main menu right after qualifying, before you even load the race itself.
    Hope it's fixed for patch 4, because I forgot to report this bug when it happened to me!
    The following 2 users likes this Post: marcelok, OddTimer


Similar Threads

  1. Xbox One Performance Issues?
    By Gav88888 in forum Project CARS 2 on XBOX One
    Replies: 24
    Last Post: 15-01-2018, 10:22
  2. Xbox One X issues
    By Narrisch in forum Project CARS 2 on XBOX One
    Replies: 5
    Last Post: 18-11-2017, 11:37
  3. Various issues in Xbox
    By wolfstoker in forum Technical Help & Support (XBOX1)
    Replies: 3
    Last Post: 30-09-2017, 03:39
  4. Xbox One issues
    By Orinoco in forum Project CARS on Xbox One
    Replies: 9
    Last Post: 16-05-2015, 02:20
  5. Xbox Sound Issues
    By stevenr167 in forum XB1 - Technical Help & Support
    Replies: 3
    Last Post: 10-05-2015, 16:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •