Results 1 to 3 of 3

Thread: Wheel and pedals stop working while still in game

  1. #1
    Join Date
    Sep 2015

    Wheel and pedals stop working while still in game

    Hey, all. I'm hoping someone has a way to fix this or can let me know whether this is a known issue or not.

    My setup:

    • Win7 (x86-64); 16GB RAM; GTX 980
    • Other apps running: Steam client, Avast AV (Free edition)
    • PCars 2 (via Steam) with patch 4.
    • Fanatec CSR wheel; Fanatec CSPv3 pedals; DSD button box.

    My problem:

    I will occasionally find that my wheel and pedals stop working while the game is still running. There doesn't seem to be any rhyme or reason to when or how it happens. As an example, I was playing last night. I ran a race in career mode, exited career mode, and then went to run the community event that uses the Aston at Bannochbrae. After starting my session, once the countdown to manual mode hits 0 and I am supposed to get control of the car, I find that none of my inputs (pedals or steering wheel) work. Mapped buttons on the wheel don't work either. The game acts as though I disconnected the wheel, pedals, and button box from my system but I have not. If I exit out of the game and bring up the Fanatec configuration utility, it shows everything is still connected and recognized by the system. Works fine if I start up an iRacing session.

    The only way I can get my wheel and pedals working again is to exit the game completely and restart it. This seems to be a problem specifically with this game. Has anyone else encountered this (regardless of wheel or pedals used)?

    Any suggestions on what I could do to fix this (if a long-term fix exists)?

    I tried to search for a similar problem but didn't see one that was similar to what I'm experiencing.

    Thanks in advance!

  2. #2
    GT4 Pilot AbeWoz's Avatar
    Join Date
    May 2015
    New York
    are the wheel/pedals/DSD hooked up to the computer via a USB Hub or directly to the towers USB ports? If using a HUB, it might not be getting enough power from the computer. Try hooking them up directly to the tower, or get a HUB with an external (wall) power supply.

    If already using a powered HUB, I'm out of ideas at this time.
    PC Rig: intel i7-6700k @ 1.21 gigawatts of electricity | Gigabyte Z170X G1 Gaming | EVGA 1080 Ti SC2 Gaming | Fanatec CSL Elite Base | CSL Elite Load-Cell Pedals | McLaren GT3 Rim
    Other endeavours: lacrosse, hockey, snowboarding, DCS (mostly A-10)

  3. #3
    Join Date
    Sep 2015
    Yeah, they're all hooked up to a USB hub but it's a hub with external power. Definitely one of the things I would have considered too.

Similar Threads

  1. Fanatec Wheel and Pedals Not working
    By grizz714 in forum Technical Help & Support (PC)
    Replies: 3
    Last Post: 29-10-2017, 15:02
  2. [ Resolved ] Logitech DFGT wheel and G25 pedals not working
    By HecaRT in forum Technical Help & Support (PC)
    Replies: 2
    Last Post: 22-09-2017, 16:18
  3. Fanatec CSR Wheel - pedals not working properly
    By Ranger1 in forum PC - Technical Help & Support
    Replies: 7
    Last Post: 03-07-2016, 15:39
  4. PCARS and OSW Wheel now completely stop working
    By Drukhi in forum PC - Technical Help & Support
    Replies: 36
    Last Post: 29-11-2015, 16:57
  5. Logitech G25 accel and brake pedals stop working middle game
    By Mephisto_POA in forum PC - Technical Help & Support
    Replies: 13
    Last Post: 25-06-2015, 20:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts