Results 1 to 7 of 7

Thread: Weird "Shadows"

  1. #1
    Kart Driver markypea's Avatar
    Join Date
    May 2016
    Location
    Mids, UK
    Posts
    14
    Platform
    PC

    Weird "Shadows"

    youtu.be/wJjfYkm-Wi0

    From the pit crew, wheels near a wall, lost body work, there is this crazy howevering shadow, almost looks like smoke. In the video because it is 2d it doesn't look so bad, but in vr you can see that the "shadow" is attached to the guy's leg and is protruding on a plane perpedicular to the player, really breaks immersion. There is also a pixel gap between the pit guy and the shadow making it super obvious, I have also seen this one pixel halo when driving behind other cars in the wet.

    I have no idea why this "shadow" is even there as you can see the proper shadow on the wall behind. It's like some awful shadow map being added as well as the ray-traced shadows. I have only noticed this since 1.4 update.

    Is there a config setting to remove it?

  2. #2
    Kart Driver
    Join Date
    Jun 2015
    Posts
    32
    Platform
    PC
    This is a DX 10/11 Feature named ambient occlusion. You can disable this ingame or in your nvidia driver.

    BTW: If this is your only problem then the game is perfect, if you have to search for errors with the magnifying glass.
    Last edited by Gaspedal; 14-02-2018 at 10:15.

  3. #3
    Superkart Pilot RobPhoboS's Avatar
    Join Date
    Sep 2017
    Location
    Surrey
    Posts
    280
    Platform
    XBOX1 X
    Quote Originally Posted by markypea View Post
    really breaks immersion


    This is really nitpicking now, respectfully.
    But on the plus side if this is your only complaint then they've done an awesome job on patch 4 !
    The following user likes this Post: Gaspedal


  4. #4
    Kart Driver markypea's Avatar
    Join Date
    May 2016
    Location
    Mids, UK
    Posts
    14
    Platform
    PC
    Quote Originally Posted by RobPhoboS View Post


    This is really nitpicking now, respectfully.
    But on the plus side if this is your only complaint then they've done an awesome job on patch 4 !
    In VR it's awful looking, the guy looks like he's smouldering. This is far from my only compaint on 1.4, I would forego online to get back to 1.3. Pre 1.4 loved the game, now with the low frame rate it's not an enjoyable experience.

    Nitpicking would be things like, go to next session when wipers are on, in the next session the wipers are not on, but the wiper noise is and no rain ever appears on the windscreen until you turn them off and on again, or that the gear indicator in the same scenario will display 1st, when the car is in neutral, or that I can see a reflection of the dash on the front of the car, like the dash is hovering some 10 feet down the track, or changing the screen resolution actually changes the menu resolution in the Rift! I just accept these things as quirks of the game. When something looked good, and then a patch makes it look worse, is that nitpicking?

    I will search out this ambient occlusion. Perhaps it was something that was enabled when the patch or graphics drivers updated.
    (edit: so I searched it out, in my Nvidia control panel, it is disabled globally, and if I attempt to create a PC2 specific configuration ambient occlusion is listed as "Not Supported", or similar, therefore I cannot disable it. Perhaps this is also why the frame rate sucks now, no matter what graphics settings I use.

    Having searched, I see that somebody else is a nitpicker as well. http://forum.projectcarsgame.com/sho...mple-in-reply)
    Last edited by markypea; 14-02-2018 at 10:50.

  5. #5
    Kart Driver markypea's Avatar
    Join Date
    May 2016
    Location
    Mids, UK
    Posts
    14
    Platform
    PC
    I also note that Pcars1 you can define whether Ambient Occlusion is disabled or not. I wager that losing the frames to this "feature" is what is causing the slow down that I am suffering, as well as looking bloody ridiculous in VR with floating shadows. Would not shock me if it was the cause of the audio stutter, and even global warming.

  6. #6
    WMD Member Mad Al's Avatar
    Join Date
    Nov 2011
    Location
    Suffolk, England
    Posts
    2,638
    Quote Originally Posted by markypea View Post
    I also note that Pcars1 you can define whether Ambient Occlusion is disabled or not. I wager that losing the frames to this "feature" is what is causing the slow down that I am suffering, as well as looking bloody ridiculous in VR with floating shadows. Would not shock me if it was the cause of the audio stutter, and even global warming.
    AO is baked in and has not changed at all since release.. if you have lost anything, you might want to start by saying just what hardware you have (best to add some specs to your signature) and what sort of settings you are running at.

    There have been a lot of issues with various windows/NVidia/oculus updates of late..

    Click image for larger version. 

Name:	oculuswarning.jpg 
Views:	0 
Size:	57.7 KB 
ID:	250139

    i7 4770K - ASUS Z87-A - 16Gig DDR3 (2x 8G Crucial Ballistix PC3-12800) - ZOTAC GTX1080Ti FE with EVGA Hybrid Cooler - iiiyama ProLite B2783QSU - Oculus Rift CV1 - Samsung 840 250G SSD , WD 320G Blue, WD 2T Black, OCZ 120G Vertex 2 SSD, LiteOn iHAS122 DVD-RW - Creative Audigy 4 - Creative 5.1 speaker system - Logitech G19 - MS HABU Gaming Mouse - Fanatec GT3 RS V2 + CSP V3 + SSH Shifter - Windows 10 Home (64 bit).

    Second machine used for additional testing. i7-4790T - Asus H97-Plus - 16G DDR3 PC-12800 - Gigabyte GTX1060 - iiyama Prolite E2607WS - Oculus Rift CV1 - W10 Pro (64 bit) - xbox360 pad or Logitech DFP (all at stock speeds)

    HTPC - For testing of Steam Big Picture Mode (Hopefully from Media Portal 2) - i5-4590S - ASUS H81M-C - 8G DDR3 PC-10666 - Gigabyte GTX1050Ti - Windows 10 Home (64 bit) - xbox360 pad

  7. #7
    Kart Driver markypea's Avatar
    Join Date
    May 2016
    Location
    Mids, UK
    Posts
    14
    Platform
    PC
    Are you saying that the game previously did not obey the Nvidia control panel configuration to disable AO as well?

    The night the patch came out I noticed the effects of AO in several places, whereas I had never noticed them before. The shadows stand out a mile in VR as they are hovering in mid air, it might not look too bad in 2d as there is definite depth, but in a 3d view they do not work at all. Literally the first pit stop I made after installing the patch I was shocked by them, to the point I showed my wife. I have also seen a 1 pixel halo around cars when following them in the rain, I belive that this is AO as well, as the shadows have a 1 pixel game from the pitguy, wheel, etc. These shadow appear in other places of course hanging off any trailing edge of the car when driving in the wet, or near a wall.

    I have any 120 hours in VR on the game as I bought it in January, so all of the experience has been with 1.3. I was slow to move from Project Cars 1 until the bugs had been cleared up as I value my evening couple of hours game time.

    Project Cars 1 obeys the Nvidia AO setting, why would PC2 not? Why would a game that has been designed to take VR into consideration include something that looks awful in VR and also takes up precious frame rate?


    Is there any way to get hold of the previous exe to test this? I looked and my Windows does not store a previous version. It is only 38mb iirc, would the 1.3 exe be compatible with the 1.4 files?

    Whether AO is the culprit or not, the game has become too low a frame rate for me to play now. Prior to 1.4 I was extremely pleased with the beautiful graphics and how much better it performed than PC1.

    Since 1.4 I can set low across the board and still get lower frame rates.

    Before I was low on most things apart from, track: medium, cars: medium, reflections: medium, shadows:ultra, and the game was lovely and smooth.
    AMD FX-8350, 8GB Ram, MSI 1070, Oculus Rift, Sony DualShock 3, Win10 64.

Similar Threads

  1. Flickering tree shadows - caused by the "wind"?
    By Richard83945 in forum General Discussion
    Replies: 14
    Last Post: 29-06-2016, 16:07
  2. Replies: 2
    Last Post: 14-11-2015, 10:10
  3. Replies: 51
    Last Post: 04-11-2015, 09:00
  4. TX making a weird "clicking noise"
    By Quentin in forum XB1 - Technical Help & Support
    Replies: 10
    Last Post: 16-10-2015, 02:22
  5. Replies: 27
    Last Post: 14-09-2015, 18:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •