Results 1 to 2 of 2

Thread: MP unplayable after 1.4 Patch

  1. #1
    WMD Member Carlos Eduardo Araujo's Avatar
    Join Date
    Oct 2012
    Posse - GO

    MP unplayable after 1.4 Patch

    Dear friend, I've always played and was a fan of pCars 1 (over 3000 hours played) and pCars 2 (over 250 hours), but after the release of Patch 1.4 it's simply impossible to play on public servers. are usually empty or have a password). I have small lags in practically every race and lags incredible in some races, where the game simply hangs for 10 seconds, that's even 10 seconds, and when I'm back in a tire barrier !!! I've made several attempts in vain (formatting the PC, reinstalling windows, swapping windows, swapping modem, router, etc) but all I get is in the middle of a run these giant lags and sometimes being disconnected.

    To cool down a bit I tested War Thunder, Assetto Corsa, Motorist, Battlefield, etc. and had no problems with these games. AC played yesterday for more than 3 straight hours without these problems.

    At the moment I'm seriously considering stopping for a new patch or some solution to this annoying problem I'm having.

    Sorry for the long text, but I always liked it and played this game a lot!
    AMD 8350 @3.6 GHz, Asus M5a78l Le, 16 Gb, GTX 970 4Gb, Win 10 Pro 64 bits, G920 Logitech, Fiber 10D/3U
    Steam ID: AraujoCarlosEdu

  2. #2
    WMD Member Asturbo's Avatar
    Join Date
    Jun 2012
    Asturias / Spain
    There were reported some P2P issues after patch 4, specially disconections. I think that there're a little bit more lag, but not a problem for me ATM

    Take a look this thread, whre we are trying to find the cause:
    CPU: Intel i7-8700K | GPU: Asus GTX 1060 | RAM: Gskill 2x8GB DDR4 3200 | MB: Asus ROG Strix Z370 | SSD: Samsung 951 PCI 250GB | Monitor: Asus VG248 144Hz | Wheel: Fanatec CSL | SO: Windows 10 Pro 64bits
    WMD1 & WMD2 Gold Member
    The following 2 users likes this Post: Carlos Eduardo Araujo, rocho

Similar Threads

  1. I need a lot of help - unplayable for me right now
    By Alfisti in forum General Discussion
    Replies: 104
    Last Post: 26-01-2018, 02:50
  2. Game unplayable after patch with G27 wheel
    By Crazycanuck1985 in forum PC - Technical Help & Support
    Replies: 0
    Last Post: 16-08-2015, 20:18
  3. Still unplayable.
    By leithnow in forum XB1 - Technical Help & Support
    Replies: 11
    Last Post: 22-06-2015, 07:07
  4. unplayable xb1 pad
    By RetroNooB in forum Project CARS on Xbox One
    Replies: 2
    Last Post: 09-05-2015, 20:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts