Page 1 of 19 12311 ... LastLast
Results 1 to 10 of 184

Thread: Patch 5.0 Ruined my Fanatec FFB

  1. #1
    Kart Driver
    Join Date
    May 2015
    Posts
    22
    Platform
    XBOX1

    Angry Patch 5.0 Ruined my Fanatec FFB

    Project Cars 2 has been my go to game for months after months. Numerous Youtube videos I have created and hours of fun. Today I have even purchased the Xbox One X.

    Having spent Thousands of pounds buying a full 80/40 rig and all Fanatec sim racing gear I have enjoyed hours of sim racing at its best.

    Many people suggested trying Assetto Corsa which I did, only to find FFB problems with my wheel running the 317 018 Firmware. I am currently using the V2.5 base with the Xbox One universal hub and inverted V3 pedals.

    Todays 5.0 patch update has absolutely ruined the whole driving experience. Loads of centre wheel vibration which isn't needed and just ruins the feel. There was absolutely nothing wrong with how the Fanatec wheel was performing before this update....

    Please Please Please rectify this... This is a total game changer and will no doubt ruin my wheel.

    You have completely ruined this game with this update with regards to Fanatec gear.

    Gutted.

  2. #2
    Superkart Pilot odemode's Avatar
    Join Date
    Jun 2015
    Location
    Stoke
    Posts
    338
    Platform
    XBOX1
    We have a Fanatec user in our group who has stated patch 5.0 has made his wheel the best it's ever felt
    XBOX One X - Thrustmaster TX - Evo 599 Alcantara - T3PA Pedals - Wheel stand pro - Comfy beanbag
    SRL (Sim Racing League) - https://discord.gg/b4QSpaA

    We're here for a good time not a long time

  3. #3
    WMD Member eracerhead's Avatar
    Join Date
    Dec 2011
    Location
    Chicago, IL
    Posts
    374
    Platform
    PC
    On PC here: whatever you're feeling, it must be limited to Xbox because I've seen no change since patch 5
    ...because simcar

    Rig: Intel i7-8770k @ 3.7GHz | MSI Z370 GAMING M5 | MSI GTX1080ti GAMING 11G | G.SKILL TridentZ 32Gb DDR4 | NZXT H400 case w/ Kraken x62 AIO cooler | Oculus Rift CV1 | LG 34UC88-B ultrawide (3440x1440 @ 60Hz) | Windows 10 Pro

    Gear: Fanatec CSW v2.5 w/ Universal Hub, Clubsport GT rim | Fanatec CSR Elite pedals & shifter

  4. #4
    Superkart Pilot Juiced46's Avatar
    Join Date
    Mar 2017
    Location
    CT
    Posts
    487
    Platform
    XBOX1 X
    Quote Originally Posted by Jay sysum View Post
    Project Cars 2 has been my go to game for months after months. Numerous Youtube videos I have created and hours of fun. Today I have even purchased the Xbox One X.

    Having spent Thousands of pounds buying a full 80/40 rig and all Fanatec sim racing gear I have enjoyed hours of sim racing at its best.

    Many people suggested trying Assetto Corsa which I did, only to find FFB problems with my wheel running the 317 018 Firmware. I am currently using the V2.5 base with the Xbox One universal hub and inverted V3 pedals.

    Todays 5.0 patch update has absolutely ruined the whole driving experience. Loads of centre wheel vibration which isn't needed and just ruins the feel. There was absolutely nothing wrong with how the Fanatec wheel was performing before this update....

    Please Please Please rectify this... This is a total game changer and will no doubt ruin my wheel.

    You have completely ruined this game with this update with regards to Fanatec gear.

    Gutted.
    Since patch 3.0. Fanatec V2.5 users have had issues. ALL users with a V2.5. There was no kerb or bump feeling at all. We have been complaining about this issue since December. I am sorry to say, but whatever you felt pre patch 5, was not correct. You may have thought it was, but you were missing FFB for sure. What you are feeling now is the fix. You most likely need to tweak your settings to dial them in correctly. What are your current settings?

    Also, why are you using a Universal hub?
    FOR SALE: Thrustmaster TX 458 Italia Wheel w/pedals. PM me for info

  5. #5
    Kart Driver
    Join Date
    May 2015
    Posts
    22
    Platform
    XBOX1
    Quote Originally Posted by Juiced46 View Post
    Since patch 3.0. Fanatec V2.5 users have had issues. ALL users with a V2.5. There was no kerb or bump feeling at all. We have been complaining about this issue since December. I am sorry to say, but whatever you felt pre patch 5, was not correct. You may have thought it was, but you were missing FFB for sure. What you are feeling now is the fix. You most likely need to tweak your settings to dial them in correctly. What are your current settings?

    Also, why are you using a Universal hub?
    https://youtu.be/bXAiM2lQRRQ

    Iím using the Xbox hub because Iím playing on Xbox one X.

    Like I mentioned Iíve produced many videos on YouTube like the one above which explains just how good the v2.5 has felt for the past 4-5 months... i have plenty of feed back believe me... thereís been nothing wrong with the settings Iíve had. Todayís patch has ruined things for me.

  6. #6
    Superkart Pilot Juiced46's Avatar
    Join Date
    Mar 2017
    Location
    CT
    Posts
    487
    Platform
    XBOX1 X
    Quote Originally Posted by Jay sysum View Post
    https://youtu.be/bXAiM2lQRRQ

    I’m using the Xbox hub because I’m playing on Xbox one X.

    Like I mentioned I’ve produced many videos on YouTube like the one above which explains just how good the v2.5 has felt for the past 4-5 months... i have plenty of feed back believe me... there’s been nothing wrong with the settings I’ve had. Today’s patch has ruined things for me.
    Sorry, I was confused about that hub, I thought it was something else.

    Anyhow, what are you running for wheel settings? Are you running it on RAW? Since you said you are getting too much shaking, did you lower FX?

    Please do not take this the wrong way, but if it felt fine to you before patch 5, you are literally the only person it was working for. Every single V2.5 Fanatec user has been complaining about the issues since patch 3. Patch 5 has FINALLY fixed our issues. I just ran a few laps on Red Bull, Knockhill and Nurbug GP and the wheel feels better then ever. It is working properly. The wheel prior to the patch felt good but it was clearly missing, road and kerb feel. You are telling me in Patch 4 you felt kerbs just fine?

    SMS even acknowledged there was a clear issue and fixed it in patch 5. I am not doubting your knowledge at all but I feel you are now feeling the proper FFB and it is just different to you now. You most likely need to make some setting tweaks. In Patch 3 and 4. You could change the TONE and FX sliders either way to each extreme and it would make no change to the wheel feel. All road and kerb feel was non existent. There was not one person on any forum with a V2.5 that said theirs was working. You are the first one I have seen report this which is odd....... Like I said, do not take this the wrong way, I am not bashing you.
    FOR SALE: Thrustmaster TX 458 Italia Wheel w/pedals. PM me for info
    The following user likes this Post: Gymnast


  7. #7
    Superkart Pilot Juiced46's Avatar
    Join Date
    Mar 2017
    Location
    CT
    Posts
    487
    Platform
    XBOX1 X
    I just checked out one of your Youtube videos. I noticed you were running FX on 100. During patch 3 and 4, FX was literally doing nothing regardless if it was 0 or 100. If you still have it at 100, then I bet this is your issue. Turn it down, way down. I just tried turning it to 80 and it was too much, I am currently running it around 30-40......

    This is the vid I watched of yours.

    https://www.youtube.com/watch?v=KtrHlrvGC9E
    FOR SALE: Thrustmaster TX 458 Italia Wheel w/pedals. PM me for info
    The following user likes this Post: Zaskarspants


  8. #8
    Superkart Pilot Juiced46's Avatar
    Join Date
    Mar 2017
    Location
    CT
    Posts
    487
    Platform
    XBOX1 X
    Continued from your post in the patch thread

    These are my settings.

    XB1X V2.5 Base CSL Elite pedals with LC. I am running the same firmware as you.

    Raw
    Gain 100
    Volume 60
    Tone 70
    FX 30

    Wheel
    Sen 900
    Sho Off
    ABS Off
    Brf 50
    FF 45
    Dri -05

    You need to turn FX down I bet. Im guessing you also run a real strong wheel because FF at 100 with volume at 60 that you run is pretty heavy.

    I have a really hard time believing you were feeling curbs in Patch4. That is most likely why you had FX at 100, because you could barely feel them. Like I said, FX changes in Patch 4 did nothing to wheel feel. You need to turn it down since it is now working properly.....
    FOR SALE: Thrustmaster TX 458 Italia Wheel w/pedals. PM me for info

  9. #9
    Kart Driver
    Join Date
    May 2015
    Posts
    22
    Platform
    XBOX1
    Quote Originally Posted by Juiced46 View Post
    Continued from your post in the patch thread

    These are my settings.

    XB1X V2.5 Base CSL Elite pedals with LC. I am running the same firmware as you.

    Raw
    Gain 100
    Volume 60
    Tone 70
    FX 30

    Wheel
    Sen 900
    Sho Off
    ABS Off
    Brf 50
    FF 45
    Dri -05

    You need to turn FX down I bet. Im guessing you also run a real strong wheel because FF at 100 with volume at 60 that you run is pretty heavy.

    I have a really hard time believing you were feeling curbs in Patch4. That is most likely why you had FX at 100, because you could barely feel them. Like I said, FX changes in Patch 4 did nothing to wheel feel. You need to turn it down since it is now working properly.....
    Ive tried your settings and that feels so weak.... Yes i like a heavy wheel but the notchy feeling is just horrible.. Grip doesn't feel like that and if it does well its just wrong.

    The wheel has been amazing since setting it up right.

    After speaking with Fanatec many months again they suggested setting the wheel at FF =100 and turning the FF in the game menu down.

    Let the equipment do what its designed to do and tone down the settings in the game menus not the wheel settings.

    To get rid of the horrible cluncky feel the wheel now has i have to set everything other than gain at 5 %

    No point in owning a wheel like this with those settings.

    You seriously needed to be using the settings I had before this patch to truely appreciate how good this wheel is. If you think its good now you have no idea.

    There is no clipping on the wheel with it set the way I had it, as per the in game telemetry.

  10. #10
    Kart Driver
    Join Date
    May 2015
    Posts
    22
    Platform
    XBOX1
    Quote Originally Posted by Jay sysum View Post
    Ive tried your settings and that feels so weak.... Yes i like a heavy wheel but the notchy feeling is just horrible.. Grip doesn't feel like that and if it does well its just wrong.

    The wheel has been amazing since setting it up right.

    After speaking with Fanatec many months again they suggested setting the wheel at FF =100 and turning the FF in the game menu down.

    Let the equipment do what its designed to do and tone down the settings in the game menus not the wheel settings.

    To get rid of the horrible cluncky feel the wheel now has i have to set everything other than gain at 5 %

    No point in owning a wheel like this with those settings.

    You seriously needed to be using the settings I had before this patch to truely appreciate how good this wheel is. If you think its good now you have no idea.

    There is no clipping on the wheel with it set the way I had it, as per the in game telemetry.
    What OS version are you using on the Xbox one?

    Iím running 10.0.17133.2019
    (rs4_release_xbox_dev_1804.180409-1751)

    Iím wondering if the new update is messing with other firmware. The one that allows you to run 1440p display.

Similar Threads

  1. Fanatec ffb issue with patch 3
    By inthebagbud in forum Technical Help & Support (XBOX1)
    Replies: 11
    Last Post: 10-12-2017, 19:03
  2. Fanatec v2.5: Higher fan usage with patch 3?
    By eracerhead in forum Technical Help & Support (PC)
    Replies: 0
    Last Post: 30-11-2017, 16:08
  3. Fanatec CSW V2 Issue after Patch 6.0
    By Hotty in forum Project CARS on Playstation 4
    Replies: 82
    Last Post: 02-12-2015, 21:13
  4. [It didn't] Patch ruined the game!
    By Bufftheowl in forum Project CARS on Xbox One
    Replies: 55
    Last Post: 05-06-2015, 11:47
  5. Fanatec support patch?
    By Soundmangt4 in forum Project CARS on Playstation 4
    Replies: 1
    Last Post: 17-05-2015, 10:26

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •