Results 1 to 4 of 4

Thread: Serious LOST CONNECTION issue in multiplayer

  1. #1
    Rookie
    Join Date
    Jan 2018
    Posts
    2
    Platform
    PC

    Unhappy Serious LOST CONNECTION issue in multiplayer

    Hello and we need help....

    Our server had suffered a serious lost connection issue for months since we start a racing league in China.

    When a driver have the following action, the serial lost connection would usually happen:

    1.host driver migration(host driver disconnect and move to another driver as a host)
    2.client driver disconnect(normaly disconnect from server due to any DNF)
    3.lost connection from server(ping issue)

    With bellowing action happen, any other 3 to 5 driver may receive the "lost connection" message in the same time.

    In the dedi server cmd stats it showd "sync timeout".


    While we race more than 12 people, it will be a 100% chance that finish rate under 60% due to serial disconnection issue.

    It will also chancely cause steam offline and need to restart steam to solve problem.(weird huh?).

    We have yet to find out what was caused the issue, but server connection seems not as strong as it should.
    (Both Dedicate Server and in-game multiplayer room issued it)

    What should we do? Use sportsplay mode temporary?

  2. #2
    WMD Member Asturbo's Avatar
    Join Date
    Jun 2012
    Location
    Asturias / Spain
    Posts
    453
    Platform
    PC
    Nobody dares to answer you because there’re many many factors that could cause your problems, and is hard to determine if your problems are the server, the clients or other issues.

    I don’t know how are the internet connections in China, but I such a huge country I can imagine that is very different to Europe where we are many countries, but all together and with similar internet infrastructure. In my servers I don't remember when was the last time that somebody lost connection (other issues, every week...).

    The first thing you have to check is if the problem is your DS, or the clients. You can try to create a lobby in P2P and check how it works. The benefits of a DS are with many players, so with 5-6 it must work similar, enough to check if the communications between the clients are good to play. Be sure to activate the label of the players, because there appears the latency. Good values are those below 100ms. Over 200ms you probably have problems.

    If with P2P works fine, then you have to check the communications from the clients to the DS. The players can ping your server, or you can create a lobby in the server and check again the pings during the game. It could be increased a little bit when you use the DS, but not a lot. A DS with a high latency is worse than P2P. You don't need a huge bandwidth, but yes a low and stable ping that allows players a low latency communication with the server. Also in the server (specially in Windows), pay attention to the energy saving options, that could reduce the performance of the server after a while causing disconnections.

    Other thing you can try is moving the server to another computer of a friend with good internet connection to check if the problem is the line/router where the DS is hosted. You only have to copy the DS folder and open the ports in the new location. You can also try with another DS in your county, to check if it works well. If it works, you have the check your routers, ports and configuration file.

    The last thing, 1 or 2 players with bad connection could ruin your lobby causing lag to the rest. It’s hard, but sometimes you have to ban someone in benefit of the community (Konan knows...).



    PS: I've read again your OP, and what does it mean?

    Quote Originally Posted by kagurazakayukari View Post
    It will also chancely cause steam offline and need to restart steam to solve problem.(weird huh?).
    You lose the connection to Steam on both computers? In the server only? In client only? Looks some conflict or link issue there...
    Last edited by Asturbo; 14-05-2018 at 21:26.
    CPU: Intel i7-8700K | GPU: nVidia GTX 1080 | RAM: Gskill 2x8GB DDR4 3200 | MB: Asus ROG Strix Z370 | SSD: Samsung 951 PCI 250GB | Monitor: Asus VG248 144Hz | Wheel: Fanatec CSL | SO: Windows 10 Pro 64bits
    WMD1 & WMD2 Gold Member /// Steam Profile /// Unofficial Issue List /// Button Box Label Template /// DS Flags Calculator
    The following user likes this Post: Mad Al


  3. #3
    Rookie
    Join Date
    Jan 2018
    Posts
    2
    Platform
    PC
    Thanks for your kindly reply.

    We have tested several configuration, and result are as follows:

    A.Connect to another DS server (serial lost to 8-9 people and stable, some heavy lag on the host side but no one lost due to that)
    B.Connect to P2P server on one's computer (lost connection within several minutes, even host itself)
    C.Connect to a server in Europe (there is some lag but stable even in 30 people in the server, little chance lost due to lag)

    We prefer DS server because it can create the race results that we could document a nice results on our website by sms_stats _data.json.
    We even wondered use a foreign server or a Linux server to open DS server.


    Quote Originally Posted by Asturbo View Post
    PS: I've read again your OP, and what does it mean?

    You lose the connection to Steam on both computers? In the server only? In client only? Looks some conflict or link issue there...


    The steam connection in China is not as welcome as before(gov issue) so this might be one of cases.

    The problem I mentioned was,when someone lost connection, whom will chancely experience the gery menu in game (all
    online function unclickable).And when he quit the game he will found his steam is in offline mode, and when he restart the steam, the steam can online nicely. With all that, the host side is 100% normal, and no steam offline.

    We also have AC and RF2 server but none of those lost connection crazy like it (If I'm right these are not via steam?)


    Project cars 2 community in China is very new and, just grown few month. There are still some complain like too expensive(500+ CNY seems little more than expected in Chinese racers' mind), not that realistic (Some misunderstand from Project Cars 1), etc. The community leaderboard in game are just few people create laptime and these people are all I well known. We really like to extend our community and ask more people to join this game, but these horror connection quality are just wear down our passions.

    Last week we tried an Spirit race and even 15min qualifying is not finished, the serial lost connection made us very passive.

    I think we still need to try more, but thanks for answering
    Last edited by kagurazakayukari; 15-05-2018 at 06:09.

  4. #4
    GT5 Pilot
    Join Date
    Jul 2017
    Posts
    1,427
    Platform
    PC
    Quote Originally Posted by kagurazakayukari View Post
    The problem I mentioned was,when someone lost connection, whom will chancely experience the gery menu in game (all
    Multiplayer funtion unclickable).And when he quit the game he will found his steam is in offline mode,and when he restart the steam,the steam can online nicely. And with all that the host side is normal, no steam offline.
    The exact same thing happened to me once, I had suddenly a freeze for 5 seconds during qualifying online which didn't hurt, then later during the race suddenly I got disconnected from it. Same thing as you said, I realized I had lost connection to Steam, online options were grayed out, while my internet connection otherwise seemed ok, as I could browse sites. After a while Steam got back up and I could resume online racing normally.

    I thought it was some kind of Steam maintenance, global for everyone, but apparently the rest of the drivers had continued and finished the race without any issues. I am wondering if the problem had/has to do with sometimes unstable connection to Steam for some reason, or maybe the game transmits too much data and at times that causes the Steam server to refuse connection?

Similar Threads

  1. Connection dropped last lap of 7 I was in lead and lost 51 points ?
    By SlowBloke in forum Technical Help & Support (PC)
    Replies: 2
    Last Post: 21-03-2018, 08:10
  2. Lost Connection to the Multiplayer Session
    By Vitesse in forum PC - Technical Help & Support
    Replies: 1
    Last Post: 13-01-2016, 14:14
  3. Replies: 17
    Last Post: 22-09-2015, 11:38
  4. Lost connection during time trial
    By rosko in forum PC - Technical Help & Support
    Replies: 1
    Last Post: 18-08-2015, 23:41
  5. Connection Lost issue during time trial
    By Kruleworld in forum PC - Technical Help & Support
    Replies: 3
    Last Post: 03-06-2015, 01:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •