Results 1 to 6 of 6

Thread: Visuals/Sound freezing for a second or two then resuming

  1. #1
    WMD Member
    Join Date
    May 2015
    Location
    Manchester
    Posts
    8
    Platform
    XBOX1 X

    Visuals/Sound freezing for a second or two then resuming

    Hi all,

    Long time lurker of these forums as generally i'm very happy with Pcars and its my 'go to' game over anything else.

    i've been fortunate that i've had very little in the way of bugs to deal with myself so never had a reason to post and i enjoy reading all the tidbits, info and advice given out by the community and the Devs!

    Only in this past week or 2 (not 100% sure if since the most recent patch as my play time has been limited recently) i've noticed that the game will hang for a second or 2, visually and audibly, before resuming with the car some distance down the track,
    it seems that controller input is still recognised during these hangs as i've been able to navigate some of the simpler corners by guessing where my car will be during these moments.

    I have seen some similar threads to this but they seem to be mostly concentrating on multiplayer and connection issue's, particularly with 'people joinig a server whilst your driving round' type of situations.
    I only play offline and whilst i have seen that the internet connectivity can have an effect, it seems to only have become an issue recently.

    - First tried a full re-boot, i have my X as always on but close all other games/apps manually before starting Pcars and never had a problem before. issue was still there.
    - Tried a fresh install, first one i've done since initially downloading it as never had any problems, or felt the need to. threw the car around a bit using a pad instead of my wheel, issue still there

    Loaded up a race i'd made that presented the problem (although it does seem to happen even in free practice and time trial as well, regardless of settings)

    Track: Oulton park full
    Class: TCC - using the BMW
    Date: Default summer date
    Time: 16:00 start, time progression x20
    Race length: 30m
    Other cars: Max grid (i think)
    Weather: 3 slots - light cloud - light rain - random, sync to race (or x5 or something, i can't remember)

    For the most part it is manageable, only minor hangs and over the course of the 30 min race i had maybe 4-5 of these,
    The last one though being big enough that it ended up in a big off and ended my race with about 5 min to go, but i'm not that fussed its only an offline race.

    Just wondering if anyone else with an X is experiencing anything similar or if i need to start looking elsewhere for the culprit, i.e. delving into my router.

    Many thanks




    Updated my Sig but its not showing: here it is

    Xbox 1 X - Game saved on Internal AND external drive
    TX 458 base - 28 GT Leather Rim, - T3PA - TH8A
    Samsung 40" 1080p
    Enhanced Graphics option
    Last edited by mcevoym; 17-07-2018 at 10:25. Reason: Added specs

  2. #2
    GT5 Pilot Zaskarspants's Avatar
    Join Date
    Oct 2017
    Location
    Bristol
    Posts
    1,484
    Platform
    XBOX1 X
    Totally stable for me since patch 6.

    Befor patch 6 I had a glitch once every few days playing 2 to 4 hours a day, but none since patch 6.

    My router/modem is set up as it came from my ISP. My xbx is on a wifi connection.
    Cockpit view. 32 inch distance to 58 inch 4k HDR TV. Proper fov, 78. World movement 30, all other camera movement, 0. G920, shifter, Raw, 100, 40-60, 15-35, 0. Assists, all off. Currently play 90-120/100 AI. 10-20 lap quick races, some tt. Decent hifi, big speakers. Home made rig.
    You Tube Channel, recording my attempts to beat the AI at 120/100.
    https://www.youtube.com/channel/UCAW...nmkXnpurVpNxzQ

  3. #3
    WMD Member
    Join Date
    May 2015
    Location
    Manchester
    Posts
    8
    Platform
    XBOX1 X
    So i did a quick test by simply setting my 1X to offline and doing a race.
    A few laps in and it was apparent it is my router. As going back online resumed the issue.

    Never done port forwarding as my online gaming days are behind me but figured i'd give it a try.

    Visiting the xbox site here
    And set that all up, also went to my Xbox network settings and obtained the port number, stuck that in too.
    I saw in another thread that it can be a 'Teredo' filter, searched high and low in my router options to find this but to no avail.

    Using a Bright box 2 router from EE, does anyone have any suggestions?
    Xbox 1 X - Game saved on Internal AND external drive
    TX 458 base - 28 GT Leather Rim - T3PA - TH8A
    Samsung 40" 1080p
    Enhanced Graphics option

  4. #4
    WMD Member
    Join Date
    May 2015
    Location
    Manchester
    Posts
    8
    Platform
    XBOX1 X
    Ok, so messing around tonight i found the culprit.

    I have been using UDP since it was first enabled on PCARS1.
    When PCARS 2 came out i continued using the apps i previously had and using the PCARS 1 protocol.

    I recently changed the apps i use and changed it to the PCARS 2 protocol. Having used it for so long it was the last thing on my mind that it would be this (even though it obviously uses my network).

    Changed it back to the PCARS 1 protocol and hey presto.
    No hanging, nice and smooth even with the 4 devices i have displaying stuff.

    I've not seen anything else about this being an issue anywhere. So thought i'd add it in case someone else was wondering what was up with their game.

    As i understand it the newer protocol puts out more information but even with my devices turned off it was still clogging up my internet to the point that it was effecting the game.

    Or could it have been the fact that it was even running the PCARS 2 protocol itself? Does anyone with an X use the PCARS 2 protocol, or have you stuck with the PCARS 1 protocol?
    Xbox 1 X - Game saved on Internal AND external drive
    TX 458 base - 28 GT Leather Rim - T3PA - TH8A
    Samsung 40" 1080p
    Enhanced Graphics option

  5. #5
    WMD Member Sampo's Avatar
    Join Date
    Jun 2012
    Location
    Finland
    Posts
    641
    Platform
    PC
    Could you try PC2 protocol again and see if having the udp rate at 1 and at 9 is any different? What did you have it when you had the problems?
    CPU Intel i5 3570K @ 4.2 GHz | Motherboard Asus P8Z77-V LK | RAM 16GB 1600MHz DDR3 | GPU nVidia GTX980 4GB (390.77) | Audio Realtek 5.1 on MB | Screen AOC U3477PQU | OS Windows 7 Pro 64-bit | Wheel Logitech G27
    In-game settings: 2560x1080 / 3440x1440 | Texture Resolution HIGH | AF 16x | VSync ON | AA None | Reflections MED | Envmap MED | Vehicle HIGH | World HIGH | Shadows MED | Motion Blur NO | Render Frames Ahead 1 | Particles MED/MED/MED

    PC2Info, a PC program that shows most stats the game provides over UDP

  6. #6
    WMD Member
    Join Date
    May 2015
    Location
    Manchester
    Posts
    8
    Platform
    XBOX1 X
    I had it on 1

    If i remember correctly the lower the number the better on PCARS 1
    so i just stuck it on 1 in PCARS 2 without even looking at the text

    But this seems to be the opposite on PCARS 2, the wording seems to indicate the higher the number the better.
    i will try at both extremes tonight and see if it makes a difference and if there is a possible middle ground to be found, but the update rate seemed to be nice and smooth even on 1
    Xbox 1 X - Game saved on Internal AND external drive
    TX 458 base - 28 GT Leather Rim - T3PA - TH8A
    Samsung 40" 1080p
    Enhanced Graphics option

Similar Threads

  1. Easy way to improve visuals (not only for PS4).
    By JasperBowels in forum Project CARS 2 on Playstation 4
    Replies: 0
    Last Post: 04-03-2018, 16:57
  2. controller settings updating when resuming current session
    By luckyluca in forum Technical Help & Support (PS4)
    Replies: 0
    Last Post: 13-01-2018, 18:45
  3. Game keeps freezing up my PC with loud buzzing sound
    By Big Blue Jerry in forum Technical Help & Support (PC)
    Replies: 8
    Last Post: 07-10-2017, 12:44
  4. Intermitted Freezing video (sound continues). Can anyone help please?
    By Distracted in forum PC - Technical Help & Support
    Replies: 18
    Last Post: 16-11-2016, 17:47
  5. The menu freezing issue is back? freezing every 2 seconds
    By TopAirspace in forum Project CARS on Xbox One
    Replies: 5
    Last Post: 27-07-2015, 01:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •