Page 7 of 8 FirstFirst ... 5678 LastLast
Results 61 to 70 of 77

Thread: OpenWeather [Testing]: A proposal to fix weather issues

  1. #61
    WMD Member Asturbo's Avatar
    Join Date
    Jun 2012
    Location
    Asturias / Spain
    Posts
    782
    Platform
    PC
    A BATCH file (BAT extension) is a text file that includes a secuence of commands. If you write that commands in plaint text (with notepad) and save with BAT extension (also CMD works), you could execute from the explorer that file to avoid typing long commands.
    CPU: Intel i7-8700K | GPU: nVidia GTX 1080 | RAM: Gskill 2x8GB DDR4 3200 | MB: Asus ROG Strix Z370 | SSD: Samsung 951 PCI 250GB | Monitor: Asus VG248 144Hz | Wheel: Fanatec CSL | SO: Windows 10 Pro 64bits
    WMD1 & WMD2 Gold Member /// Steam Profile /// Unofficial Issue List /// Button Box Label Template /// DS Flags Calculator/// Open Weather App
    The following user likes this Post: morpwr


  2. #62
    GT3 Pilot morpwr's Avatar
    Join Date
    May 2015
    Location
    new york
    Posts
    3,920
    Platform
    PC
    Quote Originally Posted by Asturbo View Post
    A BATCH file (BAT extension) is a text file that includes a secuence of commands. If you write that commands in plaint text (with notepad) and save with BAT extension (also CMD works), you could execute from the explorer that file to avoid typing long commands.
    Ok im pretty sure I did that part right. It looks like yours in the video except with my ip and key. So any ideas why it cant open OW? My header at the top looks like yours with the cmd line. Is there something I need to do with the open weather download? It tries to work when I click on the start file but doesn't. I really appreciate the help too.
    MOBO: asus rog maximus x hero / CPU: intel i7 8700k 5.1ghz / RAM:corsair platinum 32GB DDR4 3866-ocd4000 / COOLING: thermaltake floe 360 / GPU: asus GeForce gtx1080ti oc / PSU: evga super nova 850g2 / STORAGE: Samsung evo 500gb- Samsung evo 1tb / CASE: thermaltake core x71 / RIG:Gt omega /SimRacing Bay 30nm OSW / Heusinkveld pro pedals / Fanatec shifter /VR:rift / BACKUP: ps4 http://pcars.oscarolim.pt/

  3. #63
    WMD Member Asturbo's Avatar
    Join Date
    Jun 2012
    Location
    Asturias / Spain
    Posts
    782
    Platform
    PC
    Post your BAT file to try it in my computer. Any error in the CMD screen when launch? If the BAT file closes to fast to see the error, add a final line with "pause" to wait for any key.
    CPU: Intel i7-8700K | GPU: nVidia GTX 1080 | RAM: Gskill 2x8GB DDR4 3200 | MB: Asus ROG Strix Z370 | SSD: Samsung 951 PCI 250GB | Monitor: Asus VG248 144Hz | Wheel: Fanatec CSL | SO: Windows 10 Pro 64bits
    WMD1 & WMD2 Gold Member /// Steam Profile /// Unofficial Issue List /// Button Box Label Template /// DS Flags Calculator/// Open Weather App

  4. #64
    GT3 Pilot morpwr's Avatar
    Join Date
    May 2015
    Location
    new york
    Posts
    3,920
    Platform
    PC
    Quote Originally Posted by Asturbo View Post
    Post your BAT file to try it in my computer. Any error in the CMD screen when launch? If the BAT file closes to fast to see the error, add a final line with "pause" to wait for any key.
    Yes it says it cant open the Openweather file. I tried with and without the pause. Without the pause it doesn't do anything. Im sure its something stupid I did wrong.

    I cant post the BAT file now im at work.
    MOBO: asus rog maximus x hero / CPU: intel i7 8700k 5.1ghz / RAM:corsair platinum 32GB DDR4 3866-ocd4000 / COOLING: thermaltake floe 360 / GPU: asus GeForce gtx1080ti oc / PSU: evga super nova 850g2 / STORAGE: Samsung evo 500gb- Samsung evo 1tb / CASE: thermaltake core x71 / RIG:Gt omega /SimRacing Bay 30nm OSW / Heusinkveld pro pedals / Fanatec shifter /VR:rift / BACKUP: ps4 http://pcars.oscarolim.pt/

  5. #65
    WMD Member Asturbo's Avatar
    Join Date
    Jun 2012
    Location
    Asturias / Spain
    Posts
    782
    Platform
    PC
    Quote Originally Posted by morpwr View Post
    Yes it says it cant open the Openweather file. I tried with and without the pause. Without the pause it doesn't do anything. Im sure its something stupid I did wrong.
    Probably it's a problem with the location / name of the java file. In my BAT file, it's in the same folder, so no route needed. If your BAT is in a different location than the java file, you need to specify the folder.
    Last edited by Asturbo; 09-11-2018 at 14:07.
    CPU: Intel i7-8700K | GPU: nVidia GTX 1080 | RAM: Gskill 2x8GB DDR4 3200 | MB: Asus ROG Strix Z370 | SSD: Samsung 951 PCI 250GB | Monitor: Asus VG248 144Hz | Wheel: Fanatec CSL | SO: Windows 10 Pro 64bits
    WMD1 & WMD2 Gold Member /// Steam Profile /// Unofficial Issue List /// Button Box Label Template /// DS Flags Calculator/// Open Weather App

  6. #66
    GT3 Pilot morpwr's Avatar
    Join Date
    May 2015
    Location
    new york
    Posts
    3,920
    Platform
    PC
    Quote Originally Posted by Asturbo View Post
    Probably it's a problem with the location / name of the java file. In my BAT file, it's in the same folder, so no route needed. If your BAT is in a different location than the java file, you need to specify the folder.
    Do I need to take the open weather java file out of the download? I just have the download in the file with the BAT file.
    MOBO: asus rog maximus x hero / CPU: intel i7 8700k 5.1ghz / RAM:corsair platinum 32GB DDR4 3866-ocd4000 / COOLING: thermaltake floe 360 / GPU: asus GeForce gtx1080ti oc / PSU: evga super nova 850g2 / STORAGE: Samsung evo 500gb- Samsung evo 1tb / CASE: thermaltake core x71 / RIG:Gt omega /SimRacing Bay 30nm OSW / Heusinkveld pro pedals / Fanatec shifter /VR:rift / BACKUP: ps4 http://pcars.oscarolim.pt/

  7. #67
    WMD Member Asturbo's Avatar
    Join Date
    Jun 2012
    Location
    Asturias / Spain
    Posts
    782
    Platform
    PC
    You only need the JAR file from here https://github.com/mrbelowski/PCars2...e/master/build

    And the .BAT in same folder as the .JAR file. You can move the BAT to your download folder. In the video both files are in my desktop.

    When together, execute the BAT and you should see a DOS window scrolling with a message of "started in XX seconds" at the end. Then it's ready waiting for querys from the game.

    You can test also from your browser connecting to http://127.0.0.1 and you'll receive a message of invalid parameters, but that confirms that the server is listening and waiting for a correct query.
    Last edited by Asturbo; 09-11-2018 at 17:56.
    CPU: Intel i7-8700K | GPU: nVidia GTX 1080 | RAM: Gskill 2x8GB DDR4 3200 | MB: Asus ROG Strix Z370 | SSD: Samsung 951 PCI 250GB | Monitor: Asus VG248 144Hz | Wheel: Fanatec CSL | SO: Windows 10 Pro 64bits
    WMD1 & WMD2 Gold Member /// Steam Profile /// Unofficial Issue List /// Button Box Label Template /// DS Flags Calculator/// Open Weather App

  8. #68
    GT3 Pilot morpwr's Avatar
    Join Date
    May 2015
    Location
    new york
    Posts
    3,920
    Platform
    PC
    Quote Originally Posted by Asturbo View Post
    You only need the JAR file from here https://github.com/mrbelowski/PCars2...e/master/build

    And the .BAT in same folder as the .JAR file. You can move the BAT to your download folder. In the video both files are in my desktop.

    When together, execute the BAT and you should see a DOS window scrolling with a message of "started in XX seconds" at the end. Then it's ready waiting for querys from the game.

    You can test also from your browser connecting to http://127.0.0.1 and you'll receive a message of invalid parameters, but that confirms that the server is listening and waiting for a correct query.

    I think that's my issue I didn't take the jar file out of the download file.
    MOBO: asus rog maximus x hero / CPU: intel i7 8700k 5.1ghz / RAM:corsair platinum 32GB DDR4 3866-ocd4000 / COOLING: thermaltake floe 360 / GPU: asus GeForce gtx1080ti oc / PSU: evga super nova 850g2 / STORAGE: Samsung evo 500gb- Samsung evo 1tb / CASE: thermaltake core x71 / RIG:Gt omega /SimRacing Bay 30nm OSW / Heusinkveld pro pedals / Fanatec shifter /VR:rift / BACKUP: ps4 http://pcars.oscarolim.pt/

  9. #69
    Superkart Pilot
    Join Date
    May 2015
    Posts
    197
    Platform
    PC
    Im experimenting with the proxy modeand have my api working.

    using accelerated time.

    1. Weather is different from clear but dont fit location weather/time according to openweathermap.
    2. I dont get any weather change over time (weather slots).

    Example:

    At redbull, openweather says light rain.
    in the java output it says

    2018-11-09 20:48:48.596 INFO 9304 --- [p-nio-80-exec-6] o.b.w.controller.WeatherController : <?xml version="1.0" encoding="UTF-8"?>
    <weatherdata>
    <location>
    <name>Flatschach</name>
    <type></type>
    <country>AT</country>
    <timezone></timezone>
    <location altitude="0.0" latitude="47.2167" longitude="14.75" geobase="geonames" geobaseid="2779506"></location>
    </location>
    <credit></credit>
    <meta>
    <lastupdate></lastupdate>
    <calctime>0.0034</calctime>
    <nextupdate></nextupdate>
    </meta>
    <sun rise="2018-11-09T05:56:58" set="2018-11-09T15:32:09"></sun>
    <forecast>
    <time from="2018-11-09T18:00:00" to="2018-11-09T21:00:00">
    <symbol name="light rain" number="500" var="10n"></symbol>
    <precipitation unit="3h" value="0.13" type="rain"></precipitation>
    <windDirection deg="160.002" code="SSE" name="South-southeast"></windDirection>
    <windSpeed mps="0.89" name="Calm"></windSpeed>
    <temperature unit="kelvin" value="281.32" min="279.219" max="281.32"></temperature>
    <pressure value="906.19" unit="hPa"></pressure>
    <humidity value="100" unit="%"></humidity>
    <clouds value="overcast clouds" all="88" unit="%"></clouds>
    </time>
    <time from="2018-11-09T21:00:00" to="2018-11-10T00:00:00">
    <symbol name="light rain" number="500" var="10n"></symbol>
    <precipitation unit="3h" value="0.105" type="rain"></precipitation>
    <windDirection deg="187.507" code="S" name="South"></windDirection>
    <windSpeed mps="0.73" name="Calm"></windSpeed>
    <temperature unit="kelvin" value="280.46" min="278.879" max="280.46"></temperature>
    <pressure value="905.43" unit="hPa"></pressure>
    <humidity value="100" unit="%"></humidity>
    <clouds value="overcast clouds" all="88" unit="%"></clouds>
    </time>
    <time from="2018-11-10T00:00:00" to="2018-11-10T03:00:00">
    <symbol name="light rain" number="500" var="10n"></symbol>
    <precipitation unit="3h" value="0.07" type="rain"></precipitation>
    <windDirection deg="197.5" code="SSW" name="South-southwest"></windDirection>
    <windSpeed mps="0.81" name="Calm"></windSpeed>
    <temperature unit="kelvin" value="279.18" min="278.125" max="279.18"></temperature>
    <pressure value="904.76" unit="hPa"></pressure>
    <humidity value="100" unit="%"></humidity>
    <clouds value="broken clouds" all="64" unit="%"></clouds>
    </time>
    <time from="2018-11-10T03:00:00" to="2018-11-10T06:00:00">
    <symbol name="light rain" number="500" var="10d"></symbol>
    <precipitation unit="3h" value="0.045" type="rain"></precipitation>
    <windDirection deg="218.016" code="SW" name="Southwest"></windDirection>
    <windSpeed mps="0.88" name="Calm"></windSpeed>
    <temperature unit="kelvin" value="277.45" min="276.92" max="277.45"></temperature>
    <pressure value="904.24" unit="hPa"></pressure>
    <humidity value="100" unit="%"></humidity>
    <clouds value="broken clouds" all="68" unit="%"></clouds>
    </time>
    <time from="2018-11-10T06:00:00" to="2018-11-10T09:00:00">
    <symbol name="light rain" number="500" var="10d"></symbol>
    <precipitation unit="3h" value="0.03" type="rain"></precipitation>
    <windDirection deg="217.501" code="SW" name="Southwest"></windDirection>
    <windSpeed mps="0.99" name="Calm"></windSpeed>
    <temperature unit="kelvin" value="278.87" min="278.87" max="278.87"></temperature>
    <pressure value="904.5" unit="hPa"></pressure>
    <humidity value="93" unit="%"></humidity>
    <clouds value="few clouds" all="20" unit="%"></clouds>
    </time>
    <time from="2018-11-10T09:00:00" to="2018-11-10T12:00:00">
    <symbol name="light rain" number="500" var="10d"></symbol>
    <precipitation unit="3h" value="0.01" type="rain"></precipitation>
    <windDirection deg="179.001" code="S" name="South"></windDirection>
    <windSpeed mps="0.99" name="Calm"></windSpeed>
    <temperature unit="kelvin" value="282.866" min="282.866" max="282.866"></temperature>
    <pressure value="903.63" unit="hPa"></pressure>
    <humidity value="79" unit="%"></humidity>
    <clouds value="clear sky" all="0" unit="%"></clouds>
    </time>
    <time from="2018-11-10T12:00:00" to="2018-11-10T15:00:00">
    <symbol name="clear sky" number="800" var="01d"></symbol>
    <precipitation unit="3h" value="0.0"></precipitation>
    <windDirection deg="168.001" code="SSE" name="South-southeast"></windDirection>
    <windSpeed mps="0.78" name="Calm"></windSpeed>
    <temperature unit="kelvin" value="281.528" min="281.528" max="281.528"></temperature>
    <pressure value="903.49" unit="hPa"></pressure>
    <humidity value="85" unit="%"></humidity>
    <clouds value="clear sky" all="0" unit="%"></clouds>
    </time>
    <time from="2018-11-10T15:00:00" to="2018-11-10T18:00:00">
    <symbol name="clear sky" number="800" var="01n"></symbol>
    <precipitation unit="3h" value="0.0"></precipitation>
    <windDirection deg="164.5" code="SSE" name="South-southeast"></windDirection>
    <windSpeed mps="0.71" name="Calm"></windSpeed>
    <temperature unit="kelvin" value="275.719" min="275.719" max="275.719"></temperature>
    <pressure value="903.59" unit="hPa"></pressure>
    <humidity value="96" unit="%"></humidity>
    <clouds value="clear sky" all="0" unit="%"></clouds>
    </time>
    </forecast>
    </weatherdata>


    I have set the race to start at 10. nov 2018 at 9.00 am

    P.cars2 sets the weather to be foggy!

    whats wrong here?
    By the way in denmark where I am now, openweather says its foggy atm, is it a coincidence?


    how is the weather slots affected over time when using accelerated time?
    Last edited by thomasjohansen; 09-11-2018 at 20:00.
    My Simraceway SRW-S1 mod on G27: http://forum.projectcarsgame.com/sho...ay-wheel/page3
    My DIY Raceseat and Wheel http://www.vgraphics.dk
    Using Mr. Belowski's fantastic program CrewChief - an alternative race engineer http://forum.projectcarsgame.com/sho...r-for-PC-users
    The following user likes this Post: Sean_S36


  10. #70
    GT3 Pilot morpwr's Avatar
    Join Date
    May 2015
    Location
    new york
    Posts
    3,920
    Platform
    PC
    Quote Originally Posted by Asturbo View Post
    You only need the JAR file from here https://github.com/mrbelowski/PCars2...e/master/build

    And the .BAT in same folder as the .JAR file. You can move the BAT to your download folder. In the video both files are in my desktop.

    When together, execute the BAT and you should see a DOS window scrolling with a message of "started in XX seconds" at the end. Then it's ready waiting for querys from the game.

    You can test also from your browser connecting to http://127.0.0.1 and you'll receive a message of invalid parameters, but that confirms that the server is listening and waiting for a correct query.
    ok that was the major problem. I didn't take the jar file out but now its telling me the tomcat configured to listen to port 80 failed to start. The port may be in use already or misconfigured. Again thanks for all the help.
    MOBO: asus rog maximus x hero / CPU: intel i7 8700k 5.1ghz / RAM:corsair platinum 32GB DDR4 3866-ocd4000 / COOLING: thermaltake floe 360 / GPU: asus GeForce gtx1080ti oc / PSU: evga super nova 850g2 / STORAGE: Samsung evo 500gb- Samsung evo 1tb / CASE: thermaltake core x71 / RIG:Gt omega /SimRacing Bay 30nm OSW / Heusinkveld pro pedals / Fanatec shifter /VR:rift / BACKUP: ps4 http://pcars.oscarolim.pt/

Similar Threads

  1. Change request on weather system when you use random slots
    By Scott1904 in forum General Discussion
    Replies: 1
    Last Post: 28-12-2017, 17:21
  2. Request: Random seasonal weather
    By ZulfoDK in forum General Discussion
    Replies: 4
    Last Post: 27-09-2017, 12:35
  3. Request: Weather API
    By palm3r in forum Third-Party Apps & API Discussion
    Replies: 1
    Last Post: 23-09-2017, 23:30
  4. Replies: 32
    Last Post: 19-07-2017, 14:38
  5. Weather Settings change request
    By Scott1904 in forum Multiplayer
    Replies: 0
    Last Post: 16-12-2015, 11:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •