Results 1 to 8 of 8

Thread: Error Message When Trying to Set Up a Custom Wheel

  1. #1
    Rookie
    Join Date
    Jun 2012
    Posts
    4

    Error Message When Trying to Set Up a Custom Wheel

    First time PC2 user. I have an OSW and CST pedals. When I go into the controller set up section I choose "Custom" for the wheel make and "Custom Wheel" for the wheel model, and finally I choose "Separate" for pedals. Then when I try to calibrate I get an error message that says "Not all required controls are assigned. Please assign these before continuing." I've also selected "Legacy" for the wheel thinking that might somehow fix things, but I get the same error message. I feel like I am missing something here but for the life of me I cannot figure out what it is. Any thoughts?

  2. #2
    Rookie
    Join Date
    Jun 2012
    Posts
    4
    Update: I've gone in and tried editing assignments which gives me pedals and paddles shifters but still cannot get steering left/right to work.

  3. #3
    Moderator Mahjik's Avatar
    Join Date
    Oct 2011
    Location
    Kansas City, MO
    Posts
    7,939
    Platform
    PC
    Did you have another wheel before the OSW?

    Also, here's a thread with some discussion that may help: http://forum.projectcarsgame.com/sho...e-OSW-settings
    Intel i7-4790K @4.4GHz | 16gb ram | ZOTAC GeForce GTX 1080 | 5040x1050 | Windows 8.1 64-bit | Thrustmaster TX Servo Base | Thrustmaster TH8A Shifter
    ProtoSimTech PT-1 Pedals | rSeat Evo V2 | Front/Rear Transducers | SimVibe | Black Max II Button Controller | Sennheiser PC 360 Headset


    Forum Rules
    PC2 FAQ & Tips

  4. #4
    Moderator Sankyo's Avatar
    Join Date
    Sep 2011
    Location
    The Netherlands
    Posts
    7,566
    Platform
    PC
    Quote Originally Posted by Skavage View Post
    Update: I've gone in and tried editing assignments which gives me pedals and paddles shifters but still cannot get steering left/right to work.
    After assigning wheel and pedal controls, do you still get the same error message, or does something else not work?
    CPU i7 7700K | RAM Corsair 16GB 2400MHz | GPU Asus GTX1080 Ti OC 11GB | Mobo Asus Strix Z270H | Audio SB Zx @ 5.1/AKG K401 | OS Win 10 x64 | Screen LG 27EA63V-P 27" 1920x1080 | Controllers Fanatec CSW v2.5 + UH, CSP v3, CSS SQ, CSH | Misc TrackIR 4 Pro, Playseat Revolution, DS button box

    With the right to say what you think comes the obligation to think about what you say.
    Don't take life too seriously. No-one gets out alive anyway.

  5. #5
    Banned
    Join Date
    May 2015
    Posts
    1,718
    Platform
    PC
    How far are you actually turning the wheel left and right? On my Accuforce DD I have to turn it lock to lock.

  6. #6
    Rookie
    Join Date
    Jun 2012
    Posts
    4
    I am able to assign my pedals, button box, paddle shifters but not the actual analog movements of the steering (left/right). In the SimuCUBE Configuration tool I have my wheel set to 900 degrees with 100% maximum strength bumpstops. I've turned the wheel all the way to the bumpstops and still nothing. I can set everything up just fine in PC1, but not in PC2. I went into the Windows Game Controllers applet and calibrated the wheel there thinking that might do the trick, but still nothing.

  7. #7
    Rookie
    Join Date
    Jun 2012
    Posts
    4
    Welp, not sure how or why but finally it decided to recognize the assignments once. So I am now able to steer. I tried doing it a 2nd time and it will not capture them again. So no idea how it did the one time. But that said, I now have two other issues.

    First, I have zero FFB. Not a stinking sniff of FFB. A quick search and I see others have had this on OSW's also and no one has any repeatable ways of fixing it. Much like my steering it just magically starts working for some people. One guy has like a 28 step approach he took to get FFB working. Flipping amazing they kick out a sim like this and it won't run high end gear worth a shit.

    Second problem...My accelerator pedal defaults to full power. I've calibrated it multiple times but if I stop on the track and go into neutral it slams the gas on full. If I pop it in gear and let off the brake it slowly goes to full gas. Pretty stupid imo. But yes, I am frustrated to no end after 3 days screwing with things.

  8. #8
    Banned
    Join Date
    May 2015
    Posts
    1,718
    Platform
    PC
    Quote Originally Posted by Skavage View Post
    Welp, not sure how or why but finally it decided to recognize the assignments once. So I am now able to steer. I tried doing it a 2nd time and it will not capture them again. So no idea how it did the one time. But that said, I now have two other issues.

    First, I have zero FFB. Not a stinking sniff of FFB. A quick search and I see others have had this on OSW's also and no one has any repeatable ways of fixing it. Much like my steering it just magically starts working for some people. One guy has like a 28 step approach he took to get FFB working. Flipping amazing they kick out a sim like this and it won't run high end gear worth a shit.

    Second problem...My accelerator pedal defaults to full power. I've calibrated it multiple times but if I stop on the track and go into neutral it slams the gas on full. If I pop it in gear and let off the brake it slowly goes to full gas. Pretty stupid imo. But yes, I am frustrated to no end after 3 days screwing with things.
    Plenty of people with OSW's have no issues, it's not the sims fault, you have some issues your end.

Similar Threads

  1. Data Upload Error message on PS4 Notification
    By Rosinbag1 in forum Technical Help & Support (PS4)
    Replies: 1
    Last Post: 03-12-2017, 21:18
  2. Error message since 3 moths, i write fb on company, no answer !!!!
    By wakeman in forum XB1 - Technical Help & Support
    Replies: 3
    Last Post: 06-09-2017, 09:07
  3. [RESOLVED] Error message on startup
    By CarBitGTSaxen in forum PC - Technical Help & Support
    Replies: 10
    Last Post: 04-07-2016, 13:27
  4. Game crashes with no error message
    By Barracudka in forum PC - Technical Help & Support
    Replies: 9
    Last Post: 27-05-2015, 18:44
  5. project cars error message access exemption violation
    By Inkabodpain in forum PC - Technical Help & Support
    Replies: 3
    Last Post: 25-05-2015, 09:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •