Results 1 to 5 of 5

Thread: Thrustmaster T300RS F1 Wheel

  1. #1
    WMD Member Kwazi Pig's Avatar
    Join Date
    Feb 2012
    Location
    Banbury,but from Hove actually ;@)
    Posts
    21

    Thrustmaster T300RS F1 Wheel

    Halo folks
    Fun and games here. NOT
    After a long time of not playing, and finally getting my New Home made Sim Chair working.
    Not finished yet. But will post pics if i get my wheel working again.

    Any who, back to my problem.
    Reinstalled windows for a fresh install. Even tried an old backup image to sort this out.
    Updated my wheel to latest firmware 29.00 driver 2.10.9.0

    When setting up my steering wheel, all goes well. Or at least it seems to.
    But when i drive, Hmmm not so good.

    Start driving, all ok. Turn left ok. Until i turn right, no input at first then the wheel suddenly turns and wants to keep turning.
    Drag the wheel back the other way, and nothing then suddenly it wants to turn. Ive usually crashed by now and lost a wheel
    or 2 if not. Drag it back again, nothing then suddenly it wants to turn etc etc.
    Watching the animation, the wheels on the car suddenly turn. I mean, instantly turn a little, then instantly turn again. then again.
    Turn the other way and same thing.
    Stop the car and let go of the wheel it does the above mentioned action, but speeds up and gets more violent as it does. Then stops.
    sadgkmasdkfhbmbhmdfsp[lb,dsaf]lewpo fv,.plbgkor'cd gbjsoepaerw

    Ahhh Whiskey, i hate whiskey. But hay ho much nicer than this.

    Was ok till i installed the Firmware, Oh burger buns and beer. HA HA Don't ask too much Whiskey by now. And it's still morning. LOL

    I think the Firmware borked my wheel.

    I've sent a Support request to Thrustmaster so hopefully they can help.

    Any one else had a similiar problem ? Any clues at all ?

    May take me awhile to get back here. Whiskey Galore.
    Jack Daniels Tennessee Honey with a Dash of Tullamore Dew and a Dash of Glenfarlas 105 Cask strength 60%

    I may be some time

    PS: 3 hrs of trying different ways to set things up, how many are there.
    No games work at all, same thing. AC + pCARS2


    EDIT No 1
    Tried again.
    Control panel settings ALL at 100% it works ok for the first few corners then goes pear shaped.

    Turn Constant to Zero it is all fine, just feels dead and lifeless. But i can drive ok.
    Talking by Email with Thrustmaster at the moment, so fingers crossed.
    Last edited by Kwazi Pig; 23-11-2018 at 12:31.
    CPU: AMD 1800x GPU: AMD R9 280 3GBMOBO: ASROCK KILLER SLI MEM: 32GB DDR4 @2133MHz
    SOUND
    : Onboard OS: 10 Pro 64-bit WHEEL: TM T300 GTE + F1 Addon + G27 Bodnar Cable FFB: Ingame: 100 Profiler: 85 TF: 33
    SPEAKERS Z5500 TV/MONITOR: SAMSUNG LCD 46" & Viewsonic VX2260WM
    In-game settings: | 1920X1080 | Post Process ON | Lens Flare ON | Bloom ON | Motion Blur OFF | Heat Haze ON | RAIN ON | Particles HIGH | Vignet OFF | Rays ON | Detailed Grass OFF | GSI ON | Texture HIGH | AA MSAA | VSync OFF | ANIS 16X| Reflections LOW| EnvMap MED | Vehicle LOW| World HIGH | Shadows MED |

  2. #2
    WMD Member Wolfzz's Avatar
    Join Date
    Jan 2012
    Location
    Perth W.Australia
    Posts
    84
    Hey mate new Thrustmaster drivers and firmware have just come out give them a try it may fix your issues.
    (Package 2018_TTRS_3) + Firmware
    ASUS ROG RAMPAGE V Edition 10, Intel Core i7-6850K 3.60GHz, Corsair Vengeance 32GB DDR4 2666MHz, Corsair AX1200i, Samsung 970 EVO M.2 250GB, Samsung 860 EVO 500GB, Samsung 860 EVO 2TB, ASUS ROG Strix GeForce GTX 1080 Ti OC 11GB, HP ZR30W 2560x1600, Win7 Pro (x64), Thrustmaster TS-PC Racer, Thrustmaster 599XX EVO 30 Alcantara Edition, CSL Elite LC Pedals.

  3. #3
    WMD Member satco1066's Avatar
    Join Date
    May 2015
    Location
    Graz, Austria
    Posts
    1,322
    Platform
    PC
    is your wheel connected to USB3? If yes, try an USB2 port.
    Every car could be a race car, as long as you have the balls to drive it like that !

    System Shuttle SX79 | CPU i7 4930k @ 3.4 GHz | RAM 16GB 1600MHz | GPU GTX1080ti 11GB | OS Win 10 pro x64 V1709 | Screen Samsung KU6179 4k 49"
    Base Thrustmaster TS-PC Racer | Rim 458TX, GTE, T500RS Rim, TS-PC | Pedals Fanatec CSPv3 | Gearshifter TM T8HA | Button Box BBJ SimRacing 30F pro series
    HMD Oculus CV1
    Devil's Core Project Cars Team ( german language )
    Facebook: https://www.facebook.com/devilscorede/
    Closed Facebook Group: https://www.facebook.com/groups/941216635916992/
    STEAM: http://steamcommunity.com/groups/devils-core/

    The following user likes this Post: Kwazi Pig


  4. #4
    WMD Member Kwazi Pig's Avatar
    Join Date
    Feb 2012
    Location
    Banbury,but from Hove actually ;@)
    Posts
    21


    Ok i bought a PCIe card because 2 USB slots were broken.
    I had Xbox pad and Wheel plugged into it, and the Xbox pad was interfering with my Wheel.

    It all went wrong right after the Firmware updated and had not used the wheel for awhile.
    Pulled my Pc out a few weeks ago, blew all the Dust and Dog hairs out. No wonder my pc was toasty, it had a winter coat on.

    Put all my cables back in. Of course i had forgotten about the broken USB slots.
    Things went wrong as it was plugged into one of them, put it into the other one. Still no joy.

    Then plugged into the PCIe card it worked. Cool, just it did not work when trying to Drive any game.
    Because it was now plugged into the PCIe slot next to the Game pad, it seemed ok as it configured ok.

    All i had to do was get drunk, take a break and i got there eventually.

    PS: I wasn't drunk but the Whiskey was nice
    CPU: AMD 1800x GPU: AMD R9 280 3GBMOBO: ASROCK KILLER SLI MEM: 32GB DDR4 @2133MHz
    SOUND
    : Onboard OS: 10 Pro 64-bit WHEEL: TM T300 GTE + F1 Addon + G27 Bodnar Cable FFB: Ingame: 100 Profiler: 85 TF: 33
    SPEAKERS Z5500 TV/MONITOR: SAMSUNG LCD 46" & Viewsonic VX2260WM
    In-game settings: | 1920X1080 | Post Process ON | Lens Flare ON | Bloom ON | Motion Blur OFF | Heat Haze ON | RAIN ON | Particles HIGH | Vignet OFF | Rays ON | Detailed Grass OFF | GSI ON | Texture HIGH | AA MSAA | VSync OFF | ANIS 16X| Reflections LOW| EnvMap MED | Vehicle LOW| World HIGH | Shadows MED |

  5. #5
    WMD Member satco1066's Avatar
    Join Date
    May 2015
    Location
    Graz, Austria
    Posts
    1,322
    Platform
    PC
    normally this board should also have 2 USB2 slots onboard. There you can connect some cheap external adapters

    Click image for larger version. 

Name:	killerUSB2.jpg 
Views:	0 
Size:	111.3 KB 
ID:	262417

    Click image for larger version. 

Name:	usbblende.jpg 
Views:	22 
Size:	18.2 KB 
ID:	262418
    Every car could be a race car, as long as you have the balls to drive it like that !

    System Shuttle SX79 | CPU i7 4930k @ 3.4 GHz | RAM 16GB 1600MHz | GPU GTX1080ti 11GB | OS Win 10 pro x64 V1709 | Screen Samsung KU6179 4k 49"
    Base Thrustmaster TS-PC Racer | Rim 458TX, GTE, T500RS Rim, TS-PC | Pedals Fanatec CSPv3 | Gearshifter TM T8HA | Button Box BBJ SimRacing 30F pro series
    HMD Oculus CV1
    Devil's Core Project Cars Team ( german language )
    Facebook: https://www.facebook.com/devilscorede/
    Closed Facebook Group: https://www.facebook.com/groups/941216635916992/
    STEAM: http://steamcommunity.com/groups/devils-core/


Similar Threads

  1. Thrustmaster Ferrari F1 Wheel Add-on for T300RS not working by default
    By Peblin in forum Technical Help & Support (PC)
    Replies: 0
    Last Post: 26-09-2017, 12:46
  2. Thrustmaster T300RS
    By foxy31pl in forum Technical Help & Support (PC)
    Replies: 8
    Last Post: 24-09-2017, 17:29
  3. Want To Purchase: Thrustmaster T300RS Rim (wheel only)
    By Maplesauce9 in forum Off Topic Discussion
    Replies: 0
    Last Post: 25-07-2016, 20:23
  4. Win a Thrustmaster T300RS.
    By Jack van Hees in forum The Garage - Car Setup Talk
    Replies: 6
    Last Post: 18-06-2015, 17:33
  5. Thrustmaster T300RS PS4
    By Danno in forum PS4 - Technical Help & Support
    Replies: 33
    Last Post: 15-05-2015, 22:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •