Results 1 to 9 of 9

Thread: Logitech G29 + Pedals issue

  1. #1
    Kart Driver
    Join Date
    Jun 2019
    Posts
    25
    Platform
    PC

    Logitech G29 + Pedals issue

    Hi,

    Maybe someone in this forum can help me find a solution.
    Everything on my system seemed to work fine up untill 1.5 weeks ago.

    Description: When i am pressing my Throttle pedal then at the same time it randomly starts applying brakes.
    It is not always and not really 100% but the video explains a bit more what goes on.
    Happens on all the games (Assetto Corsa, Dirt Rally 2.0 and Project Cars 2)
    https://files.fm/u/mp6tneqy - Video of what exactly goes on.

    What i have done myself so far:
    1. Reinstall of drivers
    2. Opened up the pedals and cleaned them from dust + checked the wireing - all seems fine, after i put pedals back together all seems to work for like 1-2 hours and then the weirdness starts again.
    3. Rebinding stuff for example Brake to Clutch pedal and then all works, so its just related with Throttle + Brake pedal.

  2. #2
    GT5 Pilot Zaskarspants's Avatar
    Join Date
    Oct 2017
    Location
    Bristol
    Posts
    1,839
    Platform
    XBOX1 X
    You may have noisy potentiometers caused by wear and or dust, this is a common issue with these pedals.

    This can usually be fixed by cleaning the pots with contact cleaner. I fixed mine by spraying cleaner into the pots, I didn't remove them I just opened the case. I found I needed to repeat every six months.

    There are videos on yt that show the issue and fix.
    Xboxx, 58 inch TV, real fov 80, Sim Labs GT1 evo rig, Fanatec csw2.5, Shifter, v3 pedals, Mclaren Gt3 rim, Sparco Grid q seat.
    Join stoopid time trial challenges for satisfaction https://www.stoopidchallenges.com
    The following user likes this Post: cpcdem


  3. #3
    Kart Driver
    Join Date
    Jun 2019
    Posts
    25
    Platform
    PC
    Quote Originally Posted by Zaskarspants View Post
    You may have noisy potentiometers caused by wear and or dust, this is a common issue with these pedals.

    This can usually be fixed by cleaning the pots with contact cleaner. I fixed mine by spraying cleaner into the pots, I didn't remove them I just opened the case. I found I needed to repeat every six months.

    There are videos on yt that show the issue and fix.
    Thank you for the reply, i have not done the spraying yet as during weekends in my country its nearly impossible to get stuff from stores.
    every six months you say? Hmm this is the first issue i have this pedal and ive had them nearly 2.5 years now.

    I will try cleaning the pots with contact cleaner once i get the cleaner(i hope i do not have to take the pot apart completely as im a bit scared of doing that tbh), if that also fails then i suspect something has gone bad with the wireing as i don't have the tools to check wireing completely just visual inspection i do not see any faults.

    Hope this does fix it as new wheel+pedals do cost like 250 Euros if i go for Logitech G29 again even tho am not sure if its the best choice from wheels to just play PC2/Dirt Rally 2.0 n so on as i do not have a shifter anyway.
    Last edited by AsuraDeva; 15-09-2019 at 09:21.

  4. #4
    GT5 Pilot Zaskarspants's Avatar
    Join Date
    Oct 2017
    Location
    Bristol
    Posts
    1,839
    Platform
    XBOX1 X
    Mine were ok for a year before I needed to clean them, but then every six to nine months. Usage patterns vary so these numbers will too. I also had a cat who slept on the pedals so I am sure that didn't help.
    Xboxx, 58 inch TV, real fov 80, Sim Labs GT1 evo rig, Fanatec csw2.5, Shifter, v3 pedals, Mclaren Gt3 rim, Sparco Grid q seat.
    Join stoopid time trial challenges for satisfaction https://www.stoopidchallenges.com

  5. #5
    GT3 Pilot
    Join Date
    Jul 2017
    Posts
    3,754
    Platform
    PC
    Mine went bad just 2-3 months after I bought them, I followed Zaskarspants's advice back then who saved me and they were fine, then had to do it again after 6 months, and since then (more than a year has passed), I did no need to spray them anymore, they've been working fine.
    The following user likes this Post: Zaskarspants


  6. #6
    Kart Driver
    Join Date
    Oct 2017
    Location
    Waiuku
    Posts
    12
    Platform
    XBOX1 X
    Recommend taking the plunge and pulling the pot apart. That way you can wipe the contacts. You will be amazed how much grime gets on the contacts. It's not too difficult. If you have a camera take photos as you pull it apart so you know what went where. Followed the youtube guides the first time then did it myself the second time. And yes about every six months seems to be the case.
    Xbox1 X, Logitech G920 + Shifter with GTEYE Clutch/Brake/Accelerator pedal mods, Next Racing Wheel Stand, LG 43inch 1080P dedicated.
    The following user likes this Post: DaWorstPlaya


  7. #7
    Kart Driver
    Join Date
    Jun 2019
    Posts
    25
    Platform
    PC
    I think for now i will do it like this.

    1. Use the WD-40 contact cleaner to spray them to see if that fixes it - as it seems the most easiest way to do it
    2. If it does not then considering taking the POT-s apart even tho kinda nervous about it and cleaning it then
    3. If that does not work buying a new pot kit from https://www.3drap.it/product/potenti...gitech-pedals/ or somewhere else where i can find it and replace them completely. (makes me even more nervous then the 2nd point tho)

    Sadly i have not had the time yet to do it as ive been very busy with work.
    Will do it probably on saturday and then test it throughout the weekend, will write the results here which option has worked or has not worked.
    I would say that its kinda silly such info is nowhere on Logitech own site with their own product... Would make it much easier to find of what to do or how to fix and so on i guess their style is "if it isn't working, give us 400 euros or so and we give u new"
    Last edited by AsuraDeva; 18-09-2019 at 19:41.

  8. #8
    LMP2 Pilot hkraft300's Avatar
    Join Date
    May 2015
    Location
    Melbourne, AU
    Posts
    8,754
    Platform
    PS4
    Ricmotech load cell upgrade.
    G29 FFB RAW 100-40-5-10

  9. #9
    Kart Driver
    Join Date
    Jun 2019
    Posts
    25
    Platform
    PC
    So far 2 hours driven after sprayed WD-40 into Pot,s and i have not had the issue so far.
    The following 3 users likes this Post: cpcdem, hkraft300, Zaskarspants


Similar Threads

  1. Logitech g29 pedals not working right.
    By EV3RY in forum Technical Help & Support (PC)
    Replies: 5
    Last Post: 23-09-2017, 16:09
  2. Logitech G920 pedals issues
    By Maximilianum in forum PC - Technical Help & Support
    Replies: 2
    Last Post: 30-06-2016, 06:09
  3. Logitech DF GT pedals not working
    By nog in forum PC - Technical Help & Support
    Replies: 6
    Last Post: 11-03-2016, 07:33
  4. Logitech G25 combined axis issue throttle/brake issue
    By haydnbuzz in forum PC - Technical Help & Support
    Replies: 2
    Last Post: 02-07-2015, 17:18
  5. Logitech G27 Issue With Pedals
    By Twiggy145 in forum PC - Technical Help & Support
    Replies: 7
    Last Post: 20-06-2015, 15:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •