Results 1 to 6 of 6

Thread: Fanatec Clubsport

  1. #1
    Rookie
    Join Date
    Oct 2019
    Posts
    1
    Platform
    PC

    Fanatec Clubsport

    Hope you don't mind me posting here about Fanatec Steering wheel issues.

    I just ordered a new wheel, the clubsport v2.5 and v3 pedals with the xbox/pc universal hub. But I can't get it to work, it's very frustrating being such a premium product and they don't even send instructions (coming from plug and play logitech and thrustmaster controllers my rage is very high).

    Steps taken;
    Plugged everything in, wheel to pedals, wheel to power, pedal and wheel to pc.
    Launched Pro Cars 2 nothing worked
    Dowloaded 64bit v328 drivers.
    Launched game xbox button on wheel hub worked but nothing else.
    Opened win 10 game controller window, v3 pedals recognised and properties window opens, pedal tests work.
    Double clicking either of the fanatec v2.5 is unresponsive.
    Update wheel firmware, red start button changes to green
    Launched game nothing works
    Opened win 10 game controller window, v3 pedals recognised, fantatec v2.5 controllers disappeared
    'Cal' flashing on wheel, found instructions to recal wheel, all they said was press black button then press 2 buttons. Did that, cal no longer flashing although wheel is not center aligned
    Launched game nothing works
    Opened win 10 game controller window, v3 pedals recognised still missing fantatec v2.5 controllers
    Posted here.

    Can anyone help with my rage, so very tempted to return and get the t300.

  2. #2
    GT3 Pilot Olijke Poffer's Avatar
    Join Date
    May 2015
    Location
    Netherlands
    Posts
    3,505
    Platform
    PC
    You can download the manuals on the Fanatec website. Follow the instructions and you’re good to go. I did not experienced any problems when I got my wheel.
    Steam: Bull Shark CPU: Intel i7 8700k 6 cores @ 4.9 Ghz | RAM: 16GB G-Skill Trident Z RGB DDR4 @ 3000 Mhz | GPU: MSI GTX 1080 Ti 11 GB Mobo: MSI Z370 Krait Gaming | SSD: Samsung 850 EVO 250GB | OS: Win 10 x64 | Screen:Triple IIyama PROLITE XUB2792QSU-B1 7680x1440 | Controller:Fanatec CSW v2.5, ClubSport Shifter SQ V 1.5, CSL Elite pedals & loadcell brake| Misc: Oculus Rift , Simlab GT1 EVO Rig , Wife for serving Coffee and Beer.

  3. #3
    GT5 Pilot Zaskarspants's Avatar
    Join Date
    Oct 2017
    Location
    Bristol
    Posts
    1,862
    Platform
    XBOX1 X
    I had no problems on Xbox X with same kit.

    If you are on pc you need to be in pc mode, red power light, not green as you suggest above, that is for Xbox. On my GT3 McLaren wheel I press the big n button and y to swap modes between xbox, green, and pc, red.
    Xboxx, 58 inch TV, real fov 80, Sim Labs GT1 evo rig, Fanatec csw2.5, Shifter, v3 pedals, Mclaren Gt3 rim, Sparco Grid q seat.
    Join stoopid time trial challenges for satisfaction https://www.stoopidchallenges.com
    The following user likes this Post: DaWorstPlaya


  4. #4
    Kart Driver
    Join Date
    May 2015
    Posts
    11
    Platform
    PC
    Fanatec is sensitive with usb port quality (with some usb3 ports it don't works on some motherboard).
    Try to use usb2 or usb1 port, direct to the motherboard, no usb hubb nor front usb

  5. #5
    WMD Member Mad Al's Avatar
    Join Date
    Nov 2011
    Location
    Suffolk, England
    Posts
    3,211
    Quote Originally Posted by 5318008 View Post
    Plugged everything in, wheel to pedals, wheel to power, pedal and wheel to pc.
    Do you mean you have plugged the pedals into the wheel base using the RJ12 connetor AND the pedals into the PC using USB, so you have two USB connections?
    If the pedals are connected to the wheel base then they should not be connect via USB to the PC as well.

    i7 4770K - ASUS Z87-A - 16Gig DDR3 (2x 8G Crucial Ballistix PC3-12800) - ZOTAC GTX1080Ti FE with EVGA Hybrid Cooler - iiiyama ProLite B2783QSU - Oculus Rift CV1 - Samsung 840 250G SSD , WD 320G Blue, WD 6T Black, WD 2T Black, OCZ 120G Vertex 2 SSD, LiteOn iHAS122 DVD-RW - Creative Audigy 4 - Creative 5.1 speaker system - Logitech G19 - Gigabyte GM-M6880X Gaming Mouse - Fanatec GT3 RS V2 + CSP V3 + SSH Shifter - Windows 10 Home (64 bit).

    Second machine used for additional testing. i7-4790T - Asus H97-Plus - 16G DDR3 PC-12800 - EVGA RTX2060 - iiyama Prolite E2607WS - Oculus Rift CV1 - W10 Pro (64 bit) - xbox360 pad or Logitech DFP (all at stock speeds)

    HTPC - For testing of Steam Big Picture Mode (Hopefully from Media Portal 2) - i5-4590S - ASUS H81M-C - 8G DDR3 PC-10666 - Gigabyte GTX1050Ti - Windows 10 Home (64 bit) - xbox360 pad

  6. #6
    Superkart Pilot DaWorstPlaya's Avatar
    Join Date
    Jan 2017
    Location
    Denver
    Posts
    139
    Platform
    PC
    I agree with Zaskarspants, sounds like your wheel is in Xbox mode instead of PC mode. To switch modes you need to press the menu button (looks like a bunch of rectangles) and Y button together (I think). As others have suggested you can download the Fanatec manual on their website and double check. Good luck.
    What line?
    PC: Ryzen7 2700x, RTX 2080 Ti, 16GB RAM, 512GB SSD HD, Oculus Rift, Vive Pro and HP Reverb
    Wheel/Pedal: Fanatec Clubsport wheel, pedal, shifter and handbrake

Similar Threads

  1. Fanatec Clubsport V1
    By ApexAerta in forum Technical Help & Support (PC)
    Replies: 3
    Last Post: 16-11-2017, 02:13
  2. Fanatec Clubsport V2 on PS4
    By Haiden in forum Project CARS on Playstation 4
    Replies: 48
    Last Post: 01-02-2016, 00:25
  3. Fanatec Clubsport V2
    By FederalHercules in forum Project CARS on Xbox One
    Replies: 7
    Last Post: 28-11-2015, 03:18
  4. Fanatec Clubsport V2 FFB
    By Gavin Thomas in forum PC - Technical Help & Support
    Replies: 6
    Last Post: 14-09-2015, 19:51
  5. PS4 - T300RS and Fanatec ClubSport Pedals V2 plus ClubSport Shifter SQ V 1.5
    By TakMan in forum PS4 - Technical Help & Support
    Replies: 1
    Last Post: 01-06-2015, 12:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •