Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: G29, PS4. FFB WORKING ONLY IN THE MENUS, NOT WHILE DRIVING. PLS HELP!!

  1. #1
    Kart Driver
    Join Date
    Oct 2019
    Posts
    5
    Platform
    PC

    Exclamation G29, PS4. FFB WORKING ONLY IN THE MENUS, NOT WHILE DRIVING. PLS HELP!!

    Everytime I turn the game on, the FFB is smooth and proper in all the menus. As soon as I start an event and reach the screen where you are in the pits (just before start of race, after loading has taken place), the FFB disappears and the wheel becomes very light. And then as I enter the race/event again there is no FFB while driving.

    I use to play for a month and everything was fine, then one fine day it's been like this with no FFB in the race. PLS HELP

  2. #2
    Moderator Sankyo's Avatar
    Join Date
    Sep 2011
    Location
    The Netherlands
    Posts
    8,203
    Platform
    PC
    When did this behaviour start? Was it after a PS4 update?
    CPU i7 7700K | RAM Corsair 16GB 2400MHz | GPU Asus GTX1080 Ti OC 11GB | Mobo Asus Strix Z270H | Audio SB Zx @ 5.1/AKG K401 | OS Win 10 x64 | Screen LG 27EA63V-P 27" 1920x1080 | Controllers Fanatec CSW v2.5 + UH, CSP v3, CSS SQ, CSH | Misc TrackIR 4 Pro, Playseat Revolution, DS button box

    With the right to say what you think comes the obligation to think about what you say.
    I'd rather have questions that cannot be answered than answers that cannot be questioned - Richard Feynman
    Teach how to think, not what to think

  3. #3
    Kart Driver
    Join Date
    Oct 2019
    Posts
    5
    Platform
    PC
    Bought the wheel about a month ago, been using it for two weeks completely alright, then one fine day I start noticing this.

    I am not specifically sure if the PS4 has been updated but in that given period I would assume that it has.
    I don't think it is a problem of the wheel or the PS4 because the wheel, the FFB, and the recentering force all seem strong and proper in the standard PS4 menus before starting the game as well as all the PC2 menus in game.

    Only when the game loads into a race and I am in the pre-race screen does the wheel go limp. No FFB, No recentering forces either. And this is true as I drive a race.

    As soon as I quit the race and go back to the main menu of PC2 the FFB is back and the wheel feels heavy while also recentering itself if I rotate it.

    The wheel is only a month old and I'm at my wit's end especially given the amount of money it cost me.

  4. #4
    Moderator Sankyo's Avatar
    Join Date
    Sep 2011
    Location
    The Netherlands
    Posts
    8,203
    Platform
    PC
    I'm pretty sure that the wheel is OK, it's just that the communication between game and wheel has gone wrong. I'd say that a re-install or something like that could fix the problem, but someone with experience with a PS4 should come with a better proposal if there is one.
    CPU i7 7700K | RAM Corsair 16GB 2400MHz | GPU Asus GTX1080 Ti OC 11GB | Mobo Asus Strix Z270H | Audio SB Zx @ 5.1/AKG K401 | OS Win 10 x64 | Screen LG 27EA63V-P 27" 1920x1080 | Controllers Fanatec CSW v2.5 + UH, CSP v3, CSS SQ, CSH | Misc TrackIR 4 Pro, Playseat Revolution, DS button box

    With the right to say what you think comes the obligation to think about what you say.
    I'd rather have questions that cannot be answered than answers that cannot be questioned - Richard Feynman
    Teach how to think, not what to think

  5. #5
    Moderator Bealdor's Avatar
    Join Date
    Apr 2012
    Location
    Leipzig
    Posts
    9,580
    Platform
    PC
    Did you check the controller options ingame? Maybe the FFB settings bugged out and you need to reset them.

    If this doesn't work, I'd create another (guest) account on the PS4 and try the game with a fresh profile and check if the FFB is woking as intended there.
    If yes, you probably need to reset your game profile on your main account. I can delete the controller profile separately on a PC but I don't know if that's possible on PS4 I'm afraid.
    Main Rig: CPU I7 4790K@Stock | GPU Nvidia GTX 1060 6GB | RAM 16GB DDR3 1866Mhz | MB Gigabyte GA-Z97X Gaming 3 | SSD Samsung 850 EVO 120GB | HDD Seagate SATA 1TB | O.S. Win 10 Pro 64bit | Wheel Logitech G27
    Second Rig: CPU Q6600@2,80GHz | GPU Nvidia GTX 460 1GB | RAM 4GB DDR2 800Mhz | MB ASUS P5Q SE2 | HDD WD SATA 320GB | O.S. Win 7 64bit
    STEAM ID: Bealdor

    The forum search is a powerful tool, if you know how to use it...

    Please check out our Project CARS 2 FAQ and Tips

    PCARS 1 Known Issues threads: PC / PS4 / XB1

  6. #6
    Kart Driver
    Join Date
    Oct 2019
    Posts
    5
    Platform
    PC
    Reply to Bealdor: What controller options might that be specifically, please? When I go into the settings, everything seems alright as well. I've recalibrated a bunch of times to be sure and got nothing. As for the FFB settings, they are all on whatever settings that they have been on before the issue happened. The values also seem to work in the sense that if I go into the settings and say change the FFB Volume from 40 to 80, I can feel the wheel get stiffer and tighter even in the game BUT that stiffness or tightness is just like a peripheral stiffness/tightness. What I mean is that the FFB is definitely missing and I can just feel the wheel tighten slightly but it's not the same difference in tightening that I would experience if there was actual FFB and I increased the Volume from 40-80.
    So my question is what do you mean when you say to reset the FFB settings?
    The guest profile suggestion is a good idea, thanks I will try that and give an update.

    Unrelated, is there a way to factory reset the wheel? Or perhaps clear and re-install drivers or anything of the sort that wipes the slate clean. I do not know how to go about doing this procedure and any help on the same would be appreciated.


    Reply to Sankyo: As suggested maybe I can try uninstalling and reinstalling the entire game data and seeing what that does as well, thanks.
    Last edited by markose7991; 29-10-2019 at 10:10.

  7. #7
    Moderator Sankyo's Avatar
    Join Date
    Sep 2011
    Location
    The Netherlands
    Posts
    8,203
    Platform
    PC
    Quote Originally Posted by markose7991 View Post
    Unrelated, is there a way to factory reset the wheel? Or perhaps clear and re-install drivers or anything of the sort that wipes the slate clean. I do not know how to go about doing this procedure and any help on the same would be appreciated.
    On PS4 there's no such thing as a generic device driver as on a PC, full device support is in the game itself. The only options in that area are resetting the controller options within the game, or re-install the game.

    The wheel itself does not have anything like a factory reset AFAIK, I don't even think the G29 has upgradable firmware so such a feature would not do anything anyway.
    CPU i7 7700K | RAM Corsair 16GB 2400MHz | GPU Asus GTX1080 Ti OC 11GB | Mobo Asus Strix Z270H | Audio SB Zx @ 5.1/AKG K401 | OS Win 10 x64 | Screen LG 27EA63V-P 27" 1920x1080 | Controllers Fanatec CSW v2.5 + UH, CSP v3, CSS SQ, CSH | Misc TrackIR 4 Pro, Playseat Revolution, DS button box

    With the right to say what you think comes the obligation to think about what you say.
    I'd rather have questions that cannot be answered than answers that cannot be questioned - Richard Feynman
    Teach how to think, not what to think

  8. #8
    Kart Driver
    Join Date
    Oct 2019
    Posts
    5
    Platform
    PC
    UPDATE: I tried using a guest profile and that seems to have partially solved the problem. Using the guest profile I felt like the FFB wasn't quite what it used to be (maybe 85% of what it was, or maybe this is all just in my head), but it has definitely re-appeared and it does not feel that there is no FFB. The wheel was recentering in the pre-race screen as well. While experimenting with this I kept my original profile as well as the guest profile logged in and would switch between the two, with the FFB working on both. Unfortunately, after I was done experimenting I switched to my profile and proceeded to delete the guest profile after which it once again stopped working on my profile. Quite exasperating if this is how I'm going to have to play in the future.
    I'm re-installing the game and seeing if it makes any difference now.

    Reply to Sankyo: Ah okay, did not know about the non-upgradeable firmware of the G29, so looks like there is no option to try and sort of resetting of the drivers.

  9. #9
    Superkart Pilot gotdirt410sprintcar's Avatar
    Join Date
    May 2015
    Location
    OHIO
    Posts
    883
    Platform
    PS4
    Don't no what your settings are but if you have menus FFB check your settings I never run that setting high no reason to have that on in menus. That would be your last FFB setting in the profile you pick could cause wheel too maybe get hot not sure. But why have a force on the wheel like that. What are your FFB settings

  10. #10
    Kart Driver
    Join Date
    Oct 2019
    Posts
    5
    Platform
    PC
    Quote Originally Posted by gotdirt410sprintcar View Post
    Don't no what your settings are but if you have menus FFB check your settings I never run that setting high no reason to have that on in menus. That would be your last FFB setting in the profile you pick could cause wheel too maybe get hot not sure. But why have a force on the wheel like that. What are your FFB settings
    I'm not fussed about the menu settings, I only bring it up because that is a clear indicator that the FFB isn't working. Given the fact that the wheel does not recenter in the pre-race screen, I know that something is wrong and the FFB is indeed not working. And I don't think it's the wheel getting hot, I've noticed this 2 minutes into turning the PS4 on when I'm trying to get into my first race itself. Moreover, the wheel is working fine whilst in the main menus of the game.
    Pre-race screen and the race itself there is no FFB. The minute I quit the race and it returns to the main menu the FFB and recentering returns.

    I keep tweaking my FFB settings and adjusting them for the car I drive, as well as during the session whilst driving by mapping the FFB adjustment controls to the wheel. But typically my settings are around these ranges:
    Gain - 100
    Vol - 45
    Tone - 60
    FX - 40

Similar Threads

  1. [KNOWN] MP Force realistic driving aids not working at all.
    By ProDriver in forum Project CARS 2 on Playstation 4
    Replies: 2
    Last Post: 10-01-2018, 11:01
  2. AI driving when in the menus
    By David Slute in forum Technical Help & Support (PC)
    Replies: 0
    Last Post: 03-12-2017, 05:31
  3. Logitech Driving Force GT not working
    By Gotoxy in forum PC - Technical Help & Support
    Replies: 19
    Last Post: 16-01-2017, 08:34
  4. Is Logitech Driving Force GT Working?
    By rykellim in forum PC - Technical Help & Support
    Replies: 2
    Last Post: 27-12-2015, 19:14
  5. 360 Controller working in menus but not in-game
    By raybey1 in forum PC - Technical Help & Support
    Replies: 5
    Last Post: 09-05-2015, 15:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •