Results 1 to 2 of 2

Thread: Thrustmaster T3PA Brake Pedal not working

  1. #1
    Kart Driver
    Join Date
    Oct 2019
    Posts
    15
    Platform
    PS4 Pro

    Thrustmaster T3PA Brake Pedal not working

    Hey everyone.

    I just received my Thrustmaster T150 Pro with the T3PA Pedal set yesterday.

    The wheel hooks up just fine with the PS4, and the accelerator, brake, and clutch pedals were detected while calibrating (i.e. 0 to 100%).

    However, when I restarted the game, the brake pedal is not being detected at all. Pushing it on the calibration screen does not increase the value from 0.

    I tried restarting and rewiring the connections multiple times but to no avail.

    Does anyone have advice on next steps to fix this?

  2. #2
    Kart Driver
    Join Date
    Oct 2019
    Posts
    15
    Platform
    PS4 Pro
    Solved this.

    Looks like the plastic cog on the brake pedal fell out of place. Had to open up the pedal set and push it back in.

Similar Threads

  1. Great cheap Brake Mod for T3PA Pedal Set. Should work on any other pedals.
    By CeeBee2001 in forum Technical Help & Support (PC)
    Replies: 2
    Last Post: 08-03-2018, 22:39
  2. Thrustmaster T3PA-Pro Pedal Braking issuses
    By Johann26 in forum General Discussion
    Replies: 9
    Last Post: 27-09-2017, 17:46
  3. T3PA PRO PEDAL SET brake pedal issue
    By BreadedVirus in forum Off Topic Discussion
    Replies: 1
    Last Post: 31-08-2017, 20:13
  4. Thrustmaster T500 RS T3PA Pro pedal accelerator pedal issue
    By rambomonkey in forum PC - Technical Help & Support
    Replies: 5
    Last Post: 28-02-2016, 20:11
  5. Thrustmaster T3PA-Pro Brake sensitivity
    By smee in forum PC - Technical Help & Support
    Replies: 3
    Last Post: 17-12-2015, 15:27

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •