Results 1 to 4 of 4

Thread: Need help diagnosing broken t300

  1. #1
    Rookie
    Join Date
    Apr 2020
    Posts
    2
    Platform
    PC

    Need help diagnosing broken t300

    Hello everyone.
    As I am new to this forum i would like to apologize if this isn't the right place for this type of thread.

    Recently i have bought a broken t300rs, hoping for an easy fix and upgrade to my rig. Sadly it turned out the wheel has a fault not mentioned in the listing.
    When plugged into a PC, it connects normally and installs drivers, but the wheel does not calibrate. When taken apart it seems the motor tries to spin slightly to the right, but kind of just gives up and returns to center. The motor also emits a high pitched sound and gets hot quite quickly

    When trying to use the calibration tool the motor starts to strongly vibrate, sometimes actually spinning the wheel a bit to one side.
    But the calibration always ends with "Error:Pre-Calibration not found!"

    So far i have installed the newest firmware, tryed different PC's, checked the black piece on the motor for cracks and taken the motor apart to see if anything is loose.

    I'm pretty sure the motor is fine, although i do not have any good way of testing it

    The only thing i found weird is wear on the encoder board where the magnet on the axle spins, but it seems i can't post pictures on this forum yet. Could that be the problem? Or is it the motor?

    Any help would be greatly appreciated.

  2. #2
    Superkart Pilot
    Join Date
    Jun 2015
    Posts
    229
    Platform
    PS4
    Quote Originally Posted by Kongu View Post
    Recently i have bought a broken t300rs, hoping for an easy fix
    .
    Here is the main issue. You bought a broken T300. I have two T300 broken servo bases sitting in my closet. Gladly sell you a broken base but realize these wheels have both been thru the RMA process more than once. My third base hase been working fine for over a year. I also installed mt own fan to help with the over heating. Early on at the beginning of the T300 there seemed to be issues with force feedback being set to high and the motor was over heating. Here is some reading regarding T300. Hopefully one of these articles may help you.

    https://www.youtube.com/watch?v=OBIzNdy63Zc

    After you dismantle your wheel check for cracks hall sensor
    https://www.shapeways.com/product/R4...00-repair-part

    https://www.racedepartment.com/threa...others.178995/

    https://gameidealist.com/news/thrust...-project-cars/

    When and if you get your base working make sure to enable "fan on" mode http://ts.thrustmaster.com/faqs/eng/thr_eng_00156.pdf

  3. #3
    Rookie
    Join Date
    Apr 2020
    Posts
    2
    Platform
    PC
    Thanks, i'll be sure to read through the articles you provided. Unfortunately i've only found out about the problems People have with those wheels after buying it. Although the listing only spoke about a broken cable. Well anyway thank you for the help. If i can't get it fixed i'll probably just part it out.

  4. #4
    Superkart Pilot
    Join Date
    May 2015
    Location
    Yorkshire
    Posts
    575
    Platform
    PC
    Quote Originally Posted by SGETI View Post
    When and if you get your base working make sure to enable "fan on" mode http://ts.thrustmaster.com/faqs/eng/thr_eng_00156.pdf
    Thanks for posting this. After 11 years of reliable G25 and G29 use, I saw a T300 for a price I couldn't resist. I've kept the Logitech's for when it fails but hopefully this tip might put that day off a bit longer.

Similar Threads

  1. HDR Still Broken
    By DesmoPT in forum Project CARS 2 on Playstation 4
    Replies: 8
    Last Post: 29-12-2017, 07:44
  2. T300 wheel, working fine or broken? Lets get some balance here
    By Diablo944 in forum Off Topic Discussion
    Replies: 6
    Last Post: 11-08-2016, 11:11
  3. T300 sensor housing broken
    By sh0rty in forum PC - Technical Help & Support
    Replies: 5
    Last Post: 27-05-2016, 16:36
  4. [SOLVED] Soft-lock & Auto Centre Broken for T300
    By rosko in forum PC - Technical Help & Support
    Replies: 7
    Last Post: 14-01-2016, 19:09
  5. T300 RS vs T300 GTE Wheel
    By Falconeye in forum Project CARS on Playstation 4
    Replies: 16
    Last Post: 15-05-2015, 15:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •