Results 1 to 10 of 10

Thread: low gpu and cpu usage = low fps

  1. #1
    Rookie
    Join Date
    Apr 2012
    Posts
    3

    low gpu and cpu usage = low fps

    My setup:
    Intel Core i7 2600K@4.8Ghz
    32GB RAM @1600Mhz Dual Channel
    EVGA GTX Titan X with driver 350.12

    Before anyone says "Maybe its your overclock", I must say I only have performance issues in this game. My OC is perfectly stable and there is no overheating at all.

    So in pCars, I'm facing the following issue. The game does not use my CPU and my GPU properly, causing low FPS. Basically that's the problem I have.

    Here is a screenshot to ilustrate the issue. It's a Le Mans solo custom race with 30 cars in the rain at night.

    http://images.akamai.steamuserconten...41B0DA7E7FF37/

    I tried lowering the graphics, tried lowering the number of cars, tried selecting my Titan X as Physx processor, tried turning vsync off and tried turning AA off. Nothing helps. After getting tired of fighting with the game, I found this link that tries to analyse Project Cars performance:

    http://www.dsogaming.com/pc-performa...ance-analysis/

    As you can see, I'm not the only one with this kind of issue.

    So what's the deal? Because it seems like a serious bug im my point of view.

  2. #2
    Kart Driver
    Join Date
    May 2015
    Posts
    16
    Platform
    PC
    wait up dx12/win10 pCars is next game coded/optimized for xbox/ps4 than ported to pc, its not the game thats your sys config.
    Last edited by optik; 12-05-2015 at 22:43.
    ASUS M5A99X Evo
    AMD FX6100 @ 4ghz 1.3V
    TeamGroup Elite DIMM Kit 8GB PC3-10667u
    Sapphire 6850 lite retail
    PC Power & Cooling Silencer 750 Quad CrossFire Edition Wirkungsgrad 87% bei 50% last
    Roccat Kone Pure, Razer Pro Solutions, Logitech G15, Logitech Extreme 3D Pro, Speedlink drift O.Z.

  3. #3
    Rookie
    Join Date
    Apr 2012
    Posts
    3
    Quote Originally Posted by optik View Post
    wait up dx12/win10 pCars is next game coded/optimized for xbox/ps4 than ported to pc, its not the game thats your sys config.
    Sorry, I could not understand what you said. And I find strange that nobody else has posted besides you, optik. Isn't we suposed to post here instead of posting at the steam forums about Project Cars? I need a little help here to solve this issue, if it is possible to solve on my end. I still think it's a bug. The DSO article kinda points to that.

  4. #4
    Moderator Aldo Zampatti's Avatar
    Join Date
    Apr 2012
    Location
    Ushuaia, Argentina - Santiago, Chile
    Posts
    1,796
    Platform
    PC
    Quote Originally Posted by optik View Post
    wait up dx12/win10 pCars is next game coded/optimized for xbox/ps4 than ported to pc, its not the game thats your sys config.
    Quote Originally Posted by cole roddy View Post
    My setup:
    Intel Core i7 2600K@4.8Ghz
    32GB RAM @1600Mhz Dual Channel
    EVGA GTX Titan X with driver 350.12

    Before anyone says "Maybe its your overclock", I must say I only have performance issues in this game. My OC is perfectly stable and there is no overheating at all.

    So in pCars, I'm facing the following issue. The game does not use my CPU and my GPU properly, causing low FPS. Basically that's the problem I have.

    Here is a screenshot to ilustrate the issue. It's a Le Mans solo custom race with 30 cars in the rain at night.

    http://images.akamai.steamuserconten...41B0DA7E7FF37/

    I tried lowering the graphics, tried lowering the number of cars, tried selecting my Titan X as Physx processor, tried turning vsync off and tried turning AA off. Nothing helps. After getting tired of fighting with the game, I found this link that tries to analyse Project Cars performance:

    http://www.dsogaming.com/pc-performa...ance-analysis/

    As you can see, I'm not the only one with this kind of issue.

    So what's the deal? Because it seems like a serious bug im my point of view.

    Lowering your settings you only get you more CPU-bound... How can you be CPU bound with 40% utilization? Hard to explain, but possible to happens. On an old i7 usually happens at abou 60/65%

    1st, before starting, still lacks of some love form the graphics driver perspective. So that WILL improve soon.

    2nd, there are several CPU-bound graphics options you can tune (I'll mention those in a bit) but, You have to know that you have a HyperThreaded processor. this will "lie" to the OS saying that he has twice as much cores than it actually does, and then at a hardware level it will stick all those threads back into the correct ammount of cores. This trick is useful for optimizing some threads/calculations and you can expect gains from 5 o 20% on normal situations.

    If you disable HyperThreading, you can test for yourself with something that it is pure CPU such ycruncher Super PI. Those test WILL SHOW your CPU being 100% While pCARS or other specifics applications won't.
    Again, try disabling HT and re-test. Amazingly, some Softwares run faster without it! On my old days, for Terminal Server support over Windows 2000, we were disabling HT on servers because it lowered the performance... So it is never a win-win situation. Bear that in mind.

    Regarding PCARS specifically, Particles in high/ultra are quite heavy, other thing are crowds (try -skipcrowds in commandline options within steam), and motion blur. Tune them to low.
    Also try Upping AA a little bit, (DS4x maybe as a good balance for that card an triple screen). Also adding -pthreads 4 on Steam must help

    The thing is that *probably* (I don't know this for a fact, I'm just talking about my general IT experience) some of the CPU threads are not that much "splittable" thus making it impossible to load all the HyperThreaded cores. I know that physics thread can not be splitted. That's why the MAX is 4

    So if you can not split a thread, you'll never reach 100% utilization in a Hyperthreaded quad core.

    Give this options a try and let us know, but do not expect magic either. At least not from my suggestions
    Systems tested with Project CARS 2:
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Core i7 4790K - nVidia GTX 1080ti - 16GB RAM (Desktop)
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Core i7 7700HQ - nVidia GTX 1050 - 16GB RAM (Laptop)
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Core i7 6700HQ - nvidia GTX 980m - 8GB RAM (Laptop)
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Core i5 4670K - 2x AMD 7970 - 16GB RAM (Desktop)
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Core i7 4700HQ - nVidia 970M - 16GB RAM - (Laptop)
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


  5. #5
    Rookie
    Join Date
    Apr 2012
    Posts
    3
    Thanks for trying to help, Aldo. But it's a no go. I get low CPU usage all the time, with HT turned on or off, even if I drop most of options in the game. Also, my overclocked i7-2600K can match the raw processing power of an stock i7-4770k. You say "disable HT to see what happens. Maybe you get more performance". But in the recomended specs, the game requires an i7 Ivy Bridge, an i7 3770, which is basically the same CPU I have, same instruction set, just smaller litografy. So what's the point of asking for an i7 if the gamer have to deal with disabling HT for it and basically turning it into an i5 with a little more L3 cache? Besides, I'm running triples, but at 1440x810 for each screen, so it's not even close to 4K or so. It's just 1.68*1080p pixels. Even if I lower to triple 720p screens, I get the same results. On steam, there are people with the same issues. And also, there is the DSOgaming site article to give more evidence to the issue. All that said, it's pretty clear that Project Cars has performance issues even if the player surpass the recomended specs by a lot. I can't even run it at single 1080p screen without issues.

    Some people say we have to blame the gameworks implementation made in this game because Nvidia asked you guys to add a lot more gameworks things when you were about to release (latest builds before the RTM) and performance was much better before it. I for sure could not know if it's true or not, but the fact is: pCars has issues... A LOT, infact. The game should be delayed a little more I think. Or you shouldn't have added more gameworks stuff than what was already in the game sometime ago.

    Anyway, thanks for the help, Aldo. I think I'm going to wait until SMS realises the issues the game have and patch it. Or maybe I can ask for a refund. Not sure about what I'll do. Have a good day.

  6. #6
    Kart Driver NickBRCM's Avatar
    Join Date
    May 2015
    Location
    Maceió
    Posts
    6
    Platform
    PC
    Same issue with GTX 980 Classified and i5 3330, and its not hardware problem. Only have this type of problem with this game.
    GPU at 51% and CPU at 79%. 60 FPS only with GeForce Experience settings but with this settings, the game looks bad, worse than GRID Autosport (I run with 100 FPS in GRID at the Max Settings)
    Last edited by NickBRCM; 13-05-2015 at 19:11.
    PC - i5 3330/GTX 980 Classified EVGA/B75M-D3H/8GB RAM @1600MHz PNY Optima/2,5TB HD + SSD 120GB Samsung 840 EVO/XFX XTR 650W/CM Storm Scout 2 Advanced

  7. #7
    WMD Member
    Join Date
    Dec 2011
    Posts
    30
    I have exactly the same issues than you guys.

    Running triples at resolution of 5760x1080 with a single GTX 770 4GB OC card. Cpu is AMD FX-8150. CPU loads and GPU load low all the time. GPU stays mostly within 50 - 75%. On the visuals I have everything set to low. Antialiasing disabled completely. When driving alone in a good weather conditions the FPS are moving all the time within 30 - 80 at Bathurst.

    Edit: OS = Win 7 64bit

    Statistics from 1 lap around Bathurst:
    Click image for larger version. 

Name:	2015-05-14-14-18-01.jpg 
Views:	2 
Size:	93.7 KB 
ID:	202293

    EDIT 2: Nevermind. At first when I was struggling a lot with the fps I tried to put -dx9 into the launch options and I (what a dumba55.. ) forgot to swipe it off. After cleaning my launch options everything goes smoothly within 80 - 100 fps with the same combo than previously.

    Click image for larger version. 

Name:	2015-05-14-15-24-19.jpg 
Views:	0 
Size:	91.5 KB 
ID:	202320
    Last edited by Nahkamarakatti; 14-05-2015 at 12:32.

  8. #8
    Superkart Pilot
    Join Date
    May 2015
    Posts
    532
    Platform
    PC
    This seems to be the go to thread where low GPU usage is discussed: http://forum.projectcarsgame.com/sho...x760-GPU-usage

    FYI I am also seeing 50-60% GPU usage and 50% CPU usage in game, but I do still get good fps (unless its raining etc), see spec below in sig...

  9. #9
    Moderator Aldo Zampatti's Avatar
    Join Date
    Apr 2012
    Location
    Ushuaia, Argentina - Santiago, Chile
    Posts
    1,796
    Platform
    PC
    Ripgroove, your as you said are related to the post you mentioned
    Systems tested with Project CARS 2:
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Core i7 4790K - nVidia GTX 1080ti - 16GB RAM (Desktop)
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Core i7 7700HQ - nVidia GTX 1050 - 16GB RAM (Laptop)
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Core i7 6700HQ - nvidia GTX 980m - 8GB RAM (Laptop)
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Core i5 4670K - 2x AMD 7970 - 16GB RAM (Desktop)
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Core i7 4700HQ - nVidia 970M - 16GB RAM - (Laptop)
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


  10. #10
    Kart Driver
    Join Date
    May 2015
    Posts
    52
    Platform
    PC
    I have everything on high, only track on ultra... I run stable 60 fps... Look below for my spec... I tell you one of your problems is the overclocking... other is your lack off system tweak
    Intel(R) Core(TM) i5-2500 CPU @ 3.30GHz\ AMD Radeon R9 200 Series 4.0 GB\ Samsung 256GB SSD\ 16 GB DDR3\ Benq 27"\ G27

Similar Threads

  1. SLI discussion thread
    By Traummann in forum PC - Technical Help & Support
    Replies: 714
    Last Post: 22-04-2016, 20:46
  2. GPU Usage only 71% CPU 65% approx FPS 29fps
    By dasalem in forum PC - Technical Help & Support
    Replies: 31
    Last Post: 24-05-2015, 18:07
  3. [Graphics]SLI Usage drops with two GTX 980
    By Traummann in forum PC - Technical Help & Support
    Replies: 9
    Last Post: 12-05-2015, 15:42
  4. ingame fuel usage pr lap/avarage
    By thomasjohansen in forum General Discussion
    Replies: 3
    Last Post: 09-05-2015, 09:11
  5. [NO] Force Accelerated Fuel Usage ?
    By tonyp23 in forum General Discussion
    Replies: 3
    Last Post: 09-05-2015, 08:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •